]> git.pld-linux.org Git - packages/pld-builder.git/blob - pld-builder.spec
47e2d7f697c2ddc22dc26c179874acdd8ede2a5f
[packages/pld-builder.git] / pld-builder.spec
1 Summary:        PLD rpm builder environment
2 Summary(pl):    ¦rodowisko budowniczego pakietów dla PLD
3 Name:           pld-builder
4 %define         _snap   20051101
5 Version:        0.0.%{_snap}
6 Release:        0.14
7 License:        GPL
8 Group:          Development/Building
9 Source0:        %{name}.new-%{_snap}.tar.bz2
10 # Source0-md5:  935e8edd4613686cfc88b793bfb6a6b6
11 URL:            http://cvs.pld-linux.org/cgi-bin/cvsweb/pld-builder.new/
12 BuildRequires:  python
13 Requires:       python-pld-builder = %{version}-%{release}
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _sysconfdir     /etc/pld-builder
18 %define         _datadir        /usr/share/%{name}
19
20 %description
21 PLD rpm builder environment. This is the freshest "new" builder.
22
23 Other new and older attempts can be found from:
24 http://cvs.pld-linux.org/cgi-bin/cvsweb/pld-builder/
25 http://cvs.pld-linux.org/cgi-bin/cvsweb/pld-builder.old/
26 http://cvs.pld-linux.org/cgi-bin/cvsweb/builder_ng/
27
28 %description -l pl
29 ¦rodowisko budowniczego pakietów dla PLD.
30
31 %package -n python-pld-builder
32 Summary:        PLD Builder
33 Group:          Development/Building
34 %pyrequires_eq  python-modules
35
36 %description -n python-pld-builder
37 PLD Builder python code.
38
39 %package client
40 Summary:        PLD Builder client
41 Group:          Development/Building
42 Requires:       gnupg
43
44 %description client
45 This is the client to send build requests to builders, it is usually
46 referred as STBR (Send To Builder Request).
47
48 %prep
49 %setup -q -n %{name}.new
50
51 sed -i -e '
52         s,~/pld-builder.new/,%{_sharedstatedir}/%{name}/,
53         /^conf_dir/s,=.*,= "%{_sysconfdir}/",
54
55 ' PLD_Builder/path.py
56
57 %build
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 # client
63 install -d $RPM_BUILD_ROOT%{_bindir}
64 install client/make-request.sh $RPM_BUILD_ROOT%{_bindir}/%{name}-make-request
65
66 # python
67 install -d $RPM_BUILD_ROOT%{py_scriptdir}/PLD_Builder
68 cp -a PLD_Builder/*.py[co] $RPM_BUILD_ROOT%{py_scriptdir}/PLD_Builder
69
70 # other
71 install -d $RPM_BUILD_ROOT%{_sysconfdir}
72 cp -a config/{rsync-passwords,*.conf} $RPM_BUILD_ROOT%{_sysconfdir}
73 install -d $RPM_BUILD_ROOT%{_datadir}/{bin,admin}
74 for a in bin/*.sh; do
75 sed -e '
76 #       s,cd ~/pld-builder.new,cd %{py_scriptdir},
77         /cd ~\/pld-builder.new/d
78         s,python \(PLD_Builder.*.py\),python %{py_scriptdir}/\1c,
79 ' $a > $RPM_BUILD_ROOT%{_datadir}/bin/$(basename $a)
80 done
81 cp -a admin/*.sh $RPM_BUILD_ROOT%{_datadir}/admin
82
83 # dirs
84 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/{spool/{builds,ftp},lock,www/{s,}rpms}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README TODO
92 %lang(pl) %doc *.txt
93 %dir %{_sysconfdir}
94 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
95
96 %dir %{_datadir}
97 %dir %{_datadir}/bin
98 %attr(755,root,root) %{_datadir}/bin/*
99 %dir %{_datadir}/admin
100 %attr(755,root,root) %{_datadir}/admin/*
101
102 %dir %{_sharedstatedir}/%{name}
103 %dir %{_sharedstatedir}/%{name}/spool
104 %dir %{_sharedstatedir}/%{name}/spool/builds
105 %dir %{_sharedstatedir}/%{name}/spool/ftp
106 %dir %{_sharedstatedir}/%{name}/lock
107 %dir %{_sharedstatedir}/%{name}/www
108 %dir %{_sharedstatedir}/%{name}/www/rpms
109 %dir %{_sharedstatedir}/%{name}/www/srpms
110
111 %files client
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_bindir}/%{name}-make-request
114
115 %files -n python-pld-builder
116 %defattr(644,root,root,755)
117 %{py_scriptdir}/PLD_Builder
This page took 0.105047 seconds and 3 git commands to generate.