]> git.pld-linux.org Git - packages/pida.git/blob - pida.spec
- up to 0.5.1
[packages/pida.git] / pida.spec
1 # TODO:
2 # - investigate the documentation format in doc
3 # - package only py[co] files
4 # - verify if such a big version jump actually works
5 #
6 %define         realname PIDA
7 #
8 Summary:        A framework for integrated development
9 Summary(pl.UTF-8):      Szkielet do programowania zintegrowanego
10 Name:           pida
11 Version:        0.5.1
12 Release:        0.1
13 License:        GPL
14 Group:          Development/Tools
15 Source0:        http://pida.googlecode.com/files/%{realname}-%{version}.tar.gz
16 # Source0-md5:  d24bbdc2c07172062cf55dffe58c85f6
17 Source1:        %{name}.desktop
18 URL:            http://pida.berlios.de/
19 BuildRequires:  python-devel
20 BuildRequires:  python-pygtk-devel
21 BuildRequires:  python-setuptools
22 BuildRequires:  rpm-pythonprov
23 Requires:       python-gnome-desktop-gtksourceview
24 Requires:       python-gnome-gconf
25 Requires:       python-vte
26 Requires:       python-kiwi
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 PIDA is an integrated development environment (IDE) for UNIX-like
31 operating systems.
32
33 Unique Features:
34 - Vim embedding
35 - File browser that understands version status information for CVS,
36   Subversion, Darcs, Monotone, Mercurial, Bazaar-ng and Arch
37 - Built in GTK+ rapid application development
38 - Many more unique and obsessive touches
39
40 %description -l pl.UTF-8
41 PIDA to zintegrowane środowisko programistyczne (IDE) dla uniksowych
42 systemów operacyjnych.
43
44 Unikalne cechy:
45 - osadzony Vim
46 - przeglądarka plików uwzględniająca informacje o stanie wersji dla
47   systemów kontroli wersji CVS, Subversion, Darcs, Monotone, Mercurial,
48   Bazaar-ng i Arch
49 - wbudowane środowisko szybkiego tworzenia aplikacji GTK+
50 - wiele innych unikalnych i pożądanych drobiazgów
51
52 %prep
53 %setup -q -n %{realname}-%{version}
54
55 %build
56 python setup.py build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
61
62 python setup.py install \
63         --install-data=%{_datadir}/%{name} \
64         --root=$RPM_BUILD_ROOT \
65         --optimize=2
66
67 cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
68 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS README
76 %attr(755,root,root) %{_bindir}/*
77 %{py_sitedir}/*
78 %{_pixmapsdir}/*.png
79 %{_desktopdir}/*.desktop
This page took 0.063113 seconds and 4 git commands to generate.