]> git.pld-linux.org Git - packages/pida.git/blob - pida.spec
- typo in TODO
[packages/pida.git] / pida.spec
1 # TODO:
2 # - investigate the documentation format in doc
3 # - verify if such a big version jump actually works
4 # - move .po files to glibc dir and test if it works
5 #   are these used afterall, as they are .po sources not .mo compiled
6 # - moo_stub is just sample? kill it and can make package noarch.
7 # - pida probably needs some .py files to run properly
8 #
9 Summary:        A framework for integrated development
10 Summary(pl.UTF-8):      Szkielet do programowania zintegrowanego
11 Name:           pida
12 Version:        0.6.1
13 Release:        0.1
14 License:        GPL v2+
15 Group:          Development/Tools
16 Source0:        http://pypi.python.org/packages/source/p/pida/%{name}-%{version}.tar.gz
17 # Source0-md5:  ca509c6140b826eacfe87ceb12034abc
18 Source1:        %{name}.desktop
19 URL:            http://pida.co.uk/
20 BuildRequires:  pkgconfig
21 BuildRequires:  python-devel
22 BuildRequires:  python-pygtk-devel
23 BuildRequires:  python-pygtk-glade
24 BuildRequires:  python-setuptools
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.219
27 Requires:       fontconfig
28 Requires:       python-gnome-desktop-gtksourceview
29 Requires:       python-gnome-gconf
30 Requires:       python-kiwi
31 Requires:       python-pygtkhelpers
32 Requires:       python-simplejson
33 Requires:       python-vte
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 PIDA is an integrated development environment (IDE) for UNIX-like
38 operating systems.
39
40 Unique Features:
41 - Vim embedding
42 - File browser that understands version status information for CVS,
43   Subversion, Darcs, Monotone, Mercurial, Bazaar-ng and Arch
44 - Built in GTK+ rapid application development
45 - Many more unique and obsessive touches
46
47 %description -l pl.UTF-8
48 PIDA to zintegrowane środowisko programistyczne (IDE) dla uniksowych
49 systemów operacyjnych.
50
51 Unikalne cechy:
52 - osadzony Vim
53 - przeglądarka plików uwzględniająca informacje o stanie wersji dla
54   systemów kontroli wersji CVS, Subversion, Darcs, Monotone, Mercurial,
55   Bazaar-ng i Arch
56 - wbudowane środowisko szybkiego tworzenia aplikacji GTK+
57 - wiele innych unikalnych i pożądanych drobiazgów
58
59 %prep
60 %setup -q
61
62 %build
63 %{__python} setup.py build
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
68
69 %{__python} setup.py install \
70         --install-data=%{_datadir}/%{name} \
71         --root=$RPM_BUILD_ROOT \
72         --optimize=2
73
74 cp $RPM_BUILD_ROOT%{py_sitedir}/%{name}/resources/pixmaps/pida-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}
75 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
76 %py_postclean
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS README
84 %attr(755,root,root) %{_bindir}/pida
85 %attr(755,root,root) %{_bindir}/pida-remote
86
87 # see todo at top of the spec
88 #%%dir %{py_sitedir}/pida/resources/locale
89 #%%dir %{py_sitedir}/pida/services/appcontroller/locale
90 #%%dir %{py_sitedir}/pida/services/browseweb/locale
91 #%%dir %{py_sitedir}/pida/services/buffer/locale
92 #%%dir %{py_sitedir}/pida/services/bugreport/locale
93 #%%dir %{py_sitedir}/pida/services/commander/locale
94 #%%dir %{py_sitedir}/pida/services/editor/locale
95 #%%dir %{py_sitedir}/pida/services/filemanager/locale
96 #%%dir %{py_sitedir}/pida/services/grepper/locale
97 #%%dir %{py_sitedir}/pida/services/help/locale
98 #%%dir %{py_sitedir}/pida/services/manhole/locale
99 #%%dir %{py_sitedir}/pida/services/notify/locale
100 #%%dir %{py_sitedir}/pida/services/openwith/locale
101 #%%dir %{py_sitedir}/pida/services/optionsmanager/locale
102 #%%dir %{py_sitedir}/pida/services/plugins/locale
103 #%%dir %{py_sitedir}/pida/services/project/locale
104 #%%dir %{py_sitedir}/pida/services/sessions/locale
105 #%%dir %{py_sitedir}/pida/services/shortcuts/locale
106 #%%dir %{py_sitedir}/pida/services/versioncontrol/locale
107 #%%dir %{py_sitedir}/pida/services/window/locale
108 #%%lang(fr) %{py_sitedir}/pida/resources/locale/fr_FR
109 #%%lang(fr) %{py_sitedir}/pida/services/appcontroller/locale/fr_FR
110 #%%lang(fr) %{py_sitedir}/pida/services/browseweb/locale/fr_FR
111 #%%lang(fr) %{py_sitedir}/pida/services/buffer/locale/fr_FR
112 #%%lang(fr) %{py_sitedir}/pida/services/bugreport/locale/fr_FR
113 #%%lang(fr) %{py_sitedir}/pida/services/commander/locale/fr_FR
114 #%%lang(fr) %{py_sitedir}/pida/services/editor/locale/fr_FR
115 #%%lang(fr) %{py_sitedir}/pida/services/filemanager/locale/fr_FR
116 #%%lang(fr) %{py_sitedir}/pida/services/grepper/locale/fr_FR
117 #%%lang(fr) %{py_sitedir}/pida/services/help/locale/fr_FR
118 #%%lang(fr) %{py_sitedir}/pida/services/manhole/locale/fr_FR
119 #%%lang(fr) %{py_sitedir}/pida/services/notify/locale/fr_FR
120 #%%lang(fr) %{py_sitedir}/pida/services/openwith/locale/fr_FR
121 #%%lang(fr) %{py_sitedir}/pida/services/optionsmanager/locale/fr_FR
122 #%%lang(fr) %{py_sitedir}/pida/services/plugins/locale/fr_FR
123 #%%lang(fr) %{py_sitedir}/pida/services/project/locale/fr_FR
124 #%%lang(fr) %{py_sitedir}/pida/services/sessions/locale/fr_FR
125 #%%lang(fr) %{py_sitedir}/pida/services/shortcuts/locale/fr_FR
126 #%%lang(fr) %{py_sitedir}/pida/services/versioncontrol/locale/fr_FR
127 #$%lang(fr) %{py_sitedir}/pida/services/window/locale/fr_FR
128
129 %if "%{py_ver}" > "2.4"
130 %{py_sitedir}/pida-*-py2.*.egg-info
131 %endif
132
133 %dir %{py_sitedir}/pida
134 #%%attr(755,root,root) %{py_sitedir}/moo_stub.so
135 %{py_sitedir}/pida/*.py[co]
136 %{py_sitedir}/pida/core
137 %{py_sitedir}/pida/editors
138 %dir %{py_sitedir}/pida/plugins
139 %dir %{py_sitedir}/pida/plugins/*.py[co]
140 %dir %{py_sitedir}/pida/resources
141 %{py_sitedir}/pida/resources/glade
142 %{py_sitedir}/pida/resources/pixmaps
143 %{py_sitedir}/pida/resources/uidef
144 %dir %{py_sitedir}/pida/resources/data
145 %dir %{py_sitedir}/pida/resources/data/gtkrc-2.0
146 %{py_sitedir}/pida/resources/data/*.py[co]
147 %{py_sitedir}/pida/resources/data/*.vim
148 %{py_sitedir}/pida/resources/data/*.el
149 %dir %{py_sitedir}/pida/services
150 %dir %{py_sitedir}/pida/services/appcontroller
151 %{py_sitedir}/pida/services/appcontroller/*.py[co]
152 %{py_sitedir}/pida/services/appcontroller/uidef
153 %dir %{py_sitedir}/pida/services/browseweb
154 #%%{py_sitedir}/pida/services/browseweb/glade
155 %{py_sitedir}/pida/services/browseweb/*.py[co]
156 %{py_sitedir}/pida/services/browseweb/uidef
157 %dir %{py_sitedir}/pida/services/buffer
158 %{py_sitedir}/pida/services/buffer/glade
159 %{py_sitedir}/pida/services/buffer/*.py[co]
160 %{py_sitedir}/pida/services/buffer/uidef
161 %dir %{py_sitedir}/pida/services/bugreport
162 %{py_sitedir}/pida/services/bugreport/glade
163 %{py_sitedir}/pida/services/bugreport/*.py[co]
164 %{py_sitedir}/pida/services/bugreport/uidef
165 %dir %{py_sitedir}/pida/services/commander
166 %{py_sitedir}/pida/services/commander/*.py[co]
167 %{py_sitedir}/pida/services/commander/pixmaps
168 %{py_sitedir}/pida/services/commander/uidef
169 %dir %{py_sitedir}/pida/services/contexts
170 %{py_sitedir}/pida/services/contexts/*.py[co]
171 %{py_sitedir}/pida/services/contexts/uidef
172 %dir %{py_sitedir}/pida/services/editor
173 %{py_sitedir}/pida/services/editor/*.py[co]
174 %dir %{py_sitedir}/pida/services/filemanager
175 %{py_sitedir}/pida/services/filemanager/*.py[co]
176 %{py_sitedir}/pida/services/filemanager/uidef
177 %dir %{py_sitedir}/pida/services/filewatcher
178 %{py_sitedir}/pida/services/filewatcher/*.py[co]
179 %dir %{py_sitedir}/pida/services/grepper
180 %{py_sitedir}/pida/services/grepper/glade
181 %{py_sitedir}/pida/services/grepper/*.py[co]
182 %{py_sitedir}/pida/services/grepper/uidef
183 %dir %{py_sitedir}/pida/services/help
184 %{py_sitedir}/pida/services/help/*.py[co]
185 %{py_sitedir}/pida/services/help/uidef
186 %dir %{py_sitedir}/pida/services/language
187 %{py_sitedir}/pida/services/language/glade
188 %{py_sitedir}/pida/services/language/*.py[co]
189 %{py_sitedir}/pida/services/language/pixmaps
190 %{py_sitedir}/pida/services/language/uidef
191 %dir %{py_sitedir}/pida/services/manhole
192 %{py_sitedir}/pida/services/manhole/*.py[co]
193 %{py_sitedir}/pida/services/manhole/uidef
194 %dir %{py_sitedir}/pida/services/notify
195 %{py_sitedir}/pida/services/notify/*.py[co]
196 %{py_sitedir}/pida/services/notify/uidef
197 %dir %{py_sitedir}/pida/services/openwith
198 %{py_sitedir}/pida/services/openwith/glade
199 %{py_sitedir}/pida/services/openwith/*.py[co]
200 %{py_sitedir}/pida/services/openwith/uidef
201 %dir %{py_sitedir}/pida/services/optionsmanager
202 #%%{py_sitedir}/pida/services/optionsmanager/glade
203 %{py_sitedir}/pida/services/optionsmanager/*.py[co]
204 %{py_sitedir}/pida/services/optionsmanager/uidef
205 %dir %{py_sitedir}/pida/services/plugins
206 %{py_sitedir}/pida/services/plugins/glade
207 %{py_sitedir}/pida/services/plugins/*.py[co]
208 %{py_sitedir}/pida/services/plugins/uidef
209 %dir %{py_sitedir}/pida/services/project
210 %{py_sitedir}/pida/services/project/glade
211 %{py_sitedir}/pida/services/project/*.py[co]
212 %{py_sitedir}/pida/services/project/uidef
213 %{py_sitedir}/pida/services/*.py[co]
214 #%%dir %{py_sitedir}/pida/services/sessions
215 #%%{py_sitedir}/pida/services/sessions/glade
216 #%%{py_sitedir}/pida/services/sessions/*.py[co]
217 #%%{py_sitedir}/pida/services/sessions/uidef
218 %dir %{py_sitedir}/pida/services/shortcuts
219 %{py_sitedir}/pida/services/shortcuts/*.py[co]
220 %{py_sitedir}/pida/services/shortcuts/uidef
221 %dir %{py_sitedir}/pida/services/statusbar
222 %{py_sitedir}/pida/services/statusbar/*.py[co]
223 %dir %{py_sitedir}/pida/services/versioncontrol
224 %{py_sitedir}/pida/services/versioncontrol/glade
225 %{py_sitedir}/pida/services/versioncontrol/*.py[co]
226 %{py_sitedir}/pida/services/versioncontrol/uidef
227 %dir %{py_sitedir}/pida/services/window
228 %{py_sitedir}/pida/services/window/*.py[co]
229 %{py_sitedir}/pida/services/window/uidef
230 %{py_sitedir}/pida/ui
231 %{py_sitedir}/pida/utils
232
233 %{_pixmapsdir}/*.png
234 %{_desktopdir}/*.desktop
This page took 0.066032 seconds and 3 git commands to generate.