]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- up to 3.4.10.2 (fixes PMASA-2012-2)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        3.4.10.2
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  c4099c9b810065644e34a2a2e5de22f5
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-ServerSelectDisplayName.patch
16 Patch2:         %{name}-ServerSelectDisplayName-config.patch
17 URL:            http://www.phpmyadmin.net/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(triggerpostun):        sed >= 4.0
20 Requires:       php-common >= 4:5.2
21 Requires:       php-ctype
22 Requires:       php-filter
23 Requires:       php-json
24 Requires:       php-mbstring
25 Requires:       php-mcrypt
26 Requires:       php-mysql
27 Requires:       php-pcre
28 Requires:       php-session
29 Requires:       php-simplexml
30 Requires:       webapps
31 Requires:       webserver(access)
32 Requires:       webserver(alias)
33 Suggests:       php-mysqli
34 Suggests:       webserver(indexfile)
35 Suggests:       webserver(php)
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _appdir         %{_datadir}/%{name}
40 %define         _webapps        /etc/webapps
41 %define         _webapp         %{name}
42 %define         _sysconfdir     %{_webapps}/%{_webapp}
43
44 %description
45 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
46 but also a single database. To accomplish the latter you'll need a
47 properly set up MySQL-user who can read/write only the desired
48 database. It's up to you to look up the appropiate part in the MySQL
49 manual. Currently phpMyAdmin can:
50 - create and drop databases
51 - create, copy, drop and alter tables
52 - delete, edit and add fields
53 - execute any SQL-statement, even batch-queries
54 - manage keys on fields
55 - load text files into tables
56 - create (*) and read dumps of tables
57 - export (*) and import data to CSV values
58 - administer multiple servers and single databases
59 - check referencial integrity
60 - create complex queries automatically connecting required tables
61 - create PDF graphics of your database layout
62 - communicate in more than 50 different languages
63
64 %description -l pl.UTF-8
65 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
66 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
67 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
68 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
69 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
70 - tworzyć i usuwać bazy
71 - wykonywać create, copy, drop oraz alter na tabelach
72 - dodawać, usuwać i modyfikować pola
73 - wykonywać dowolne zapytania SQL
74 - zarządzać kluczami na rekordach
75 - wczytywać tekst z plików do tabel
76 - obsługiwać ponad 20 języków
77 - zarządzać wieloma serwerami i pojedynczymi bazami danych
78 - eksportować i importować dane do wartości CSV
79 - tworzyć i czytać zrzuty tabel
80
81 %prep
82 %setup -q -n %{name}-%{version}-all-languages
83 %patch0 -p1
84 %patch1 -p0
85 %patch2 -p0
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
90
91 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
92 cp -a locale pmd themes js libraries $RPM_BUILD_ROOT%{_appdir}
93
94 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
95 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
96
97 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
98 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
99 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
100
101 cp -f libraries/import/README{,-import}
102 cp -f libraries/transformations/README{,-transformations}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %triggerin -- apache1 < 1.3.37-3, apache1-base
108 %webapp_register apache %{_webapp}
109
110 %triggerun -- apache1 < 1.3.37-3, apache1-base
111 %webapp_unregister apache %{_webapp}
112
113 %triggerin -- apache < 2.2.0, apache-base
114 %webapp_register httpd %{_webapp}
115
116 %triggerun -- apache < 2.2.0, apache-base
117 %webapp_unregister httpd %{_webapp}
118
119 %triggerin -- lighttpd
120 %webapp_register lighttpd %{_webapp}
121
122 %triggerun -- lighttpd
123 %webapp_unregister lighttpd %{_webapp}
124
125 %files
126 %defattr(644,root,root,755)
127 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh
128 %dir %attr(750,root,http) %{_sysconfdir}
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
132 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
133 %dir %{_appdir}
134 %{_appdir}/js
135 %{_appdir}/libraries
136 %{_appdir}/locale
137 %{_appdir}/pmd
138 %{_appdir}/themes
139 %{_appdir}/*.css
140 %{_appdir}/*.html
141 %{_appdir}/*.php
This page took 0.066541 seconds and 4 git commands to generate.