]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
- working Source URL
[packages/phpBB.git] / phpBB.spec
1 Summary:        A feature-rich PHP discussion board
2 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
3 Name:           phpBB
4 Version:        2.0.4
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://dl.sourceforge.net/phpbb/%{name}-%{version}.tar.gz
9 Source1:        http://dl.sourceforge.net/phpbb/lang_polish.tar.gz
10 Source2:        http://dl.sourceforge.net/phpbb/subSilver_polish.tar.gz
11 Source3:        http://dl.sourceforge.net/phpbb/lang_german.tar.gz
12 Source4:        http://dl.sourceforge.net/phpbb/subSilver_german.tar.gz
13 Source5:        http://dl.sourceforge.net/phpbb/lang_french.tar.gz
14 Source6:        http://dl.sourceforge.net/phpbb/subSilver_french.tar.gz
15 URL:            http://www.phpbb.com/
16 Requires:       php-mysql >= 4.1.0
17 Requires:       php-pcre
18 Requires:       webserver
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _phpdir         /home/services/httpd/html/phpBB
23
24 %description
25 phpBB is a UBB-style dissussion board written in PHP backended by a
26 MySQL database. It includes features such as posting/replying/editing
27 messages, private messages, private forums, user and anonymous
28 posting, robust theming, user ranking by posts or by special, admin
29 definable, ranks, and much more.
30
31 %description -l pl
32 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
33 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
34 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
35 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
36 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
37 rankingi i wiele innych.
38
39 %package install
40 Summary:        A feature-rich PHP discussion board - installer
41 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
42 Group:          Applications/Databases/Interfaces
43 Requires:       phpBB
44
45 %description install
46 Package needed for %{name} forum instalation.
47
48 %description install -l pl
49 Pakiet potrzebny do instalacji forum %{name}.
50
51 %prep
52 %setup -q -n %{name}2
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,install/schemas,language,templates}
57
58 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
59 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
60 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
61 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
62 install install/*.{htm,php} $RPM_BUILD_ROOT%{_phpdir}/install
63 install install/schemas/*.sql $RPM_BUILD_ROOT%{_phpdir}/install/schemas
64
65 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
66 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
67 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
68
69 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
70 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
71
72 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
73 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
74
75 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
76 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post install
82 echo "Remember to uninstall %{name}-install after initiation of %{name}!!"
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/*
87 %attr(755,root,http) %dir %{_phpdir}
88 %attr(640,root,http) %config(noreplace) %{_phpdir}/config.php
89 %attr(640,root,http) %{_phpdir}/[^c]*.php
90 %attr(640,root,http) %{_phpdir}/common.php
91 %attr(640,root,http) %{_phpdir}/*.inc
92 %attr(750,root,http) %dir %{_phpdir}/admin
93 %attr(750,root,http) %dir %{_phpdir}/db
94 %attr(750,root,http) %dir %{_phpdir}/images
95 %attr(750,root,http) %dir %{_phpdir}/includes
96 %{_phpdir}/admin/*
97 %{_phpdir}/db/*
98 %{_phpdir}/images/*
99 %{_phpdir}/includes/*
100 %attr(750,root,http) %dir %{_phpdir}/templates
101 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
102 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
103 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
104 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
105 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
106 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
107 %attr(640,root,http) %{_phpdir}/language/*.htm
108
109 %lang(en) %{_phpdir}/language/lang_english
110 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
111
112 %lang(pl) %{_phpdir}/language/lang_polish
113 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
114
115 %lang(de) %{_phpdir}/language/lang_german
116 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
117
118 %lang(fr) %{_phpdir}/language/lang_french
119 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
120
121 %files install
122 %defattr(644,root,root,755)
123 %doc install/schemas/*.zip
124 %attr(750,root,http) %dir %{_phpdir}/install
125 %attr(640,root,http) %{_phpdir}/install/*.php
126 %attr(640,root,http) %{_phpdir}/install/*.htm
127 %attr(750,root,http) %dir %{_phpdir}/install/schemas
128 %attr(640,root,http) %{_phpdir}/install/schemas/*.sql
This page took 0.050286 seconds and 4 git commands to generate.