]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
- switched to bz2 sources
[packages/phpBB.git] / phpBB.spec
1 Summary:        A feature-rich PHP discussion board
2 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
3 Name:           phpBB
4 %define _version 2.0.6
5 Version:        2.0.6c
6 Release:        1
7 License:        GPL v2
8 Group:          Applications/WWW
9 Source0:        http://dl.sourceforge.net/phpbb/%{name}-%{_version}.tar.bz2
10 # Source0-md5:  0c2a43e1f482dffbcdb91dd366c9894f
11 Source1:        http://dl.sourceforge.net/phpbb/lang_polish.tar.gz
12 # Source1-md5:  db020ef788d4bd50ce04014964e3e043
13 Source2:        http://dl.sourceforge.net/phpbb/subSilver_polish.tar.gz
14 # Source2-md5:  9367f7a761aef3795ffa296b413136b4
15 Source3:        http://dl.sourceforge.net/phpbb/lang_german.tar.gz
16 # Source3-md5:  afc686072978b896e18fa211210c3b13
17 Source4:        http://dl.sourceforge.net/phpbb/subSilver_german.tar.gz
18 # Source4-md5:  8340f310ee4892f3e19da3e000fdb708
19 Source5:        http://dl.sourceforge.net/phpbb/lang_french.tar.gz
20 # Source5-md5:  c81f843d4adf0a086efef590074478e6
21 Source6:        http://dl.sourceforge.net/phpbb/subSilver_french.tar.gz
22 # Source6-md5:  419157eb144fa81b7464a5f2edeea434
23 URL:            http://www.phpbb.com/
24 Requires:       php-pcre
25 Requires:       webserver
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _phpdir         /home/services/httpd/html/phpBB
30
31 %description
32 phpBB is a UBB-style dissussion board written in PHP backended by a
33 MySQL database. It includes features such as posting/replying/editing
34 messages, private messages, private forums, user and anonymous
35 posting, robust theming, user ranking by posts or by special, admin
36 definable, ranks, and much more.
37
38 %description -l pl
39 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
40 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
41 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
42 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
43 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
44 rankingi i wiele innych.
45
46 %package install
47 Summary:        A feature-rich PHP discussion board - installer
48 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
49 Group:          Applications/Databases/Interfaces
50 Requires:       phpBB
51
52 %description install
53 Package needed for %{name} forum instalation.
54
55 %description install -l pl
56 Pakiet potrzebny do instalacji forum %{name}.
57
58 %prep
59 %setup -q -n %{name}2
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,install/schemas,language,templates}
64
65 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
66 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
67 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
68 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
69 install install/*.{htm,php} $RPM_BUILD_ROOT%{_phpdir}/install
70 install install/schemas/*.sql $RPM_BUILD_ROOT%{_phpdir}/install/schemas
71
72 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
73 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
74 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
75
76 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
77 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
78
79 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
80 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
81
82 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
83 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post install
89 echo "For instalation: http://<your.site.address>/<path>/install/install.php"
90 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
91 echo
92 echo "Remember to uninstall %{name}-install after initiation/upgrade of %{name}!!"
93
94 %triggerpostun  -- %{name} <= %{version}
95 echo "You have to install %{name}-install package to prepare upgrade!!!"
96 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
97
98 %files
99 %defattr(644,root,root,755)
100 %doc docs/*
101 %attr(755,root,http) %dir %{_phpdir}
102 %attr(640,root,http) %config(noreplace) %{_phpdir}/config.php
103 %attr(640,root,http) %{_phpdir}/[^c]*.php
104 %attr(640,root,http) %{_phpdir}/common.php
105 %attr(640,root,http) %{_phpdir}/*.inc
106 %attr(750,root,http) %dir %{_phpdir}/admin
107 %attr(750,root,http) %dir %{_phpdir}/db
108 %attr(750,root,http) %dir %{_phpdir}/images
109 %attr(750,root,http) %dir %{_phpdir}/includes
110 %{_phpdir}/admin/*
111 %{_phpdir}/db/*
112 %{_phpdir}/images/*
113 %{_phpdir}/includes/*
114 %attr(750,root,http) %dir %{_phpdir}/templates
115 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
116 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
117 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
118 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
119 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
120 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
121 %attr(640,root,http) %{_phpdir}/language/*.htm
122
123 %lang(en) %{_phpdir}/language/lang_english
124 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
125
126 %lang(pl) %{_phpdir}/language/lang_polish
127 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
128
129 %lang(de) %{_phpdir}/language/lang_german
130 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
131
132 %lang(fr) %{_phpdir}/language/lang_french
133 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
134
135 %files install
136 %defattr(644,root,root,755)
137 %doc install/schemas/*.zip
138 %attr(750,root,http) %dir %{_phpdir}/install
139 %attr(640,root,http) %{_phpdir}/install/*.php
140 %attr(640,root,http) %{_phpdir}/install/*.htm
141 %attr(750,root,http) %dir %{_phpdir}/install/schemas
142 %attr(640,root,http) %{_phpdir}/install/schemas/*.sql
This page took 0.039056 seconds and 4 git commands to generate.