]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
- group Applications/WWW
[packages/phpBB.git] / phpBB.spec
1 Summary:        A feature-rich PHP discussion board
2 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
3 Name:           phpBB
4 Version:        2.0.3
5 Release:        5
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://prdownloads.sourceforge.net/phpbb/%{name}-%{version}.tar.gz
9 Source1:        http://prdownloads.sourceforge.net/phpbb/lang_polish.tar.gz
10 Source2:        http://prdownloads.sourceforge.net/phpbb/subSilver_polish.tar.gz
11 Source3:        http://prdownloads.sourceforge.net/phpbb/lang_german.tar.gz
12 Source4:        http://prdownloads.sourceforge.net/phpbb/subSilver_german.tar.gz
13 Source5:        http://prdownloads.sourceforge.net/phpbb/lang_french.tar.gz
14 Source6:        http://prdownloads.sourceforge.net/phpbb/subSilver_french.tar.gz
15 Patch0:         %{name}-viewtopic-sec_fix.patch
16 URL:            http://www.phpbb.com/
17 Requires:       php-mysql >= 4.1.0
18 Requires:       php-pcre
19 Requires:       webserver
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _phpdir         /home/services/httpd/html/phpBB
24
25 %description
26 phpBB is a UBB-style dissussion board written in PHP backended by a
27 MySQL database. It includes features such as posting/replying/editing
28 messages, private messages, private forums, user and anonymous
29 posting, robust theming, user ranking by posts or by special, admin
30 definable, ranks, and much more.
31
32 %description -l pl
33 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
34 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
35 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
36 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
37 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
38 rankingi i wiele innych.
39
40 %package install
41 Summary:        A feature-rich PHP discussion board - installer
42 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
43 Group:          Applications/Databases/Interfaces
44 Requires:       phpBB
45
46 %description install
47 Package needed for %{name} forum instalation.
48
49 %description install -l pl
50 Pakiet potrzebny do instalacji forum %{name}.
51
52 %prep
53 %setup -q -n %{name}2
54 %patch0 -p1
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,language,templates}
59
60 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
61 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
62 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
63 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
64
65 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
66 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
67 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
68
69 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
70 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
71
72 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
73 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
74
75 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
76 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post install
82 echo "Remember to uninstall %{name}-install after initiation of %{name}!!"
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/* db/schemas/*
87 %attr(755,root,http) %dir %{_phpdir}
88 %attr(640,root,http) %config(noreplace) %{_phpdir}/config.php
89 %attr(640,root,http) %{_phpdir}/[efglmpsv]*.php
90 %attr(640,root,http) %{_phpdir}/index.php
91 %attr(640,root,http) %{_phpdir}/com*.php
92 %attr(640,root,http) %{_phpdir}/*.inc
93 %attr(750,root,http) %dir %{_phpdir}/admin
94 %attr(750,root,http) %dir %{_phpdir}/db
95 %attr(750,root,http) %dir %{_phpdir}/images
96 %attr(750,root,http) %dir %{_phpdir}/includes
97 %{_phpdir}/admin/*
98 %{_phpdir}/db/*
99 %{_phpdir}/images/*
100 %{_phpdir}/includes/*
101 %attr(750,root,http) %dir %{_phpdir}/templates
102 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
103 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
104 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
105 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
106 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
107 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
108 %attr(640,root,http) %{_phpdir}/language/*.htm
109
110 %lang(en) %{_phpdir}/language/lang_english
111 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
112
113 %lang(pl) %{_phpdir}/language/lang_polish
114 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
115
116 %lang(de) %{_phpdir}/language/lang_german
117 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
118
119 %lang(fr) %{_phpdir}/language/lang_french
120 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
121
122 %files install
123 %defattr(644,root,root,755)
124 %attr(640,root,http) %{_phpdir}/install.php
125 %attr(640,root,http) %{_phpdir}/up*.php
This page took 0.046205 seconds and 4 git commands to generate.