]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
- small info in trigger - hope it'll work right
[packages/phpBB.git] / phpBB.spec
1 Summary:        A feature-rich PHP discussion board
2 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
3 Name:           phpBB
4 Version:        2.0.6
5 Release:        1.1
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://dl.sourceforge.net/phpbb/%{name}-%{version}.tar.gz
9 # Source0-md5:  9fcaa3148203159db03947998a3cba9d
10 Source1:        http://dl.sourceforge.net/phpbb/lang_polish.tar.gz
11 # Source1-md5:  feabc41c40577dbdb148b06d3e0a9f41
12 Source2:        http://dl.sourceforge.net/phpbb/subSilver_polish.tar.gz
13 # Source2-md5:  9367f7a761aef3795ffa296b413136b4
14 Source3:        http://dl.sourceforge.net/phpbb/lang_german.tar.gz
15 # Source3-md5:  5a36c6b00740e17a12500ad303c92113
16 Source4:        http://dl.sourceforge.net/phpbb/subSilver_german.tar.gz
17 # Source4-md5:  8340f310ee4892f3e19da3e000fdb708
18 Source5:        http://dl.sourceforge.net/phpbb/lang_french.tar.gz
19 # Source5-md5:  c81f843d4adf0a086efef590074478e6
20 Source6:        http://dl.sourceforge.net/phpbb/subSilver_french.tar.gz
21 # Source6-md5:  419157eb144fa81b7464a5f2edeea434
22 URL:            http://www.phpbb.com/
23 Requires:       php-pcre
24 Requires:       webserver
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _phpdir         /home/services/httpd/html/phpBB
29
30 %description
31 phpBB is a UBB-style dissussion board written in PHP backended by a
32 MySQL database. It includes features such as posting/replying/editing
33 messages, private messages, private forums, user and anonymous
34 posting, robust theming, user ranking by posts or by special, admin
35 definable, ranks, and much more.
36
37 %description -l pl
38 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
39 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
40 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
41 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
42 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
43 rankingi i wiele innych.
44
45 %package install
46 Summary:        A feature-rich PHP discussion board - installer
47 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
48 Group:          Applications/Databases/Interfaces
49 Requires:       phpBB
50
51 %description install
52 Package needed for %{name} forum instalation.
53
54 %description install -l pl
55 Pakiet potrzebny do instalacji forum %{name}.
56
57 %prep
58 %setup -q -n %{name}2
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,install/schemas,language,templates}
63
64 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
65 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
66 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
67 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
68 install install/*.{htm,php} $RPM_BUILD_ROOT%{_phpdir}/install
69 install install/schemas/*.sql $RPM_BUILD_ROOT%{_phpdir}/install/schemas
70
71 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
72 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
73 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
74
75 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
76 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
77
78 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
79 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
80
81 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
82 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post install
88 echo "For instalation: http://<your.site.address>/<path>/install/install.php"
89 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
90 echo
91 echo "Remember to uninstall %{name}-install after initiation/upgrade of %{name}!!"
92
93 %triggerpostun  -- %{name} <= %{version}
94 echo "You have to install %{name}-install package to prepare upgrade!!!"
95 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
96
97 %files
98 %defattr(644,root,root,755)
99 %doc docs/*
100 %attr(755,root,http) %dir %{_phpdir}
101 %attr(640,root,http) %config(noreplace) %{_phpdir}/config.php
102 %attr(640,root,http) %{_phpdir}/[^c]*.php
103 %attr(640,root,http) %{_phpdir}/common.php
104 %attr(640,root,http) %{_phpdir}/*.inc
105 %attr(750,root,http) %dir %{_phpdir}/admin
106 %attr(750,root,http) %dir %{_phpdir}/db
107 %attr(750,root,http) %dir %{_phpdir}/images
108 %attr(750,root,http) %dir %{_phpdir}/includes
109 %{_phpdir}/admin/*
110 %{_phpdir}/db/*
111 %{_phpdir}/images/*
112 %{_phpdir}/includes/*
113 %attr(750,root,http) %dir %{_phpdir}/templates
114 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
115 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
116 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
117 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
118 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
119 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
120 %attr(640,root,http) %{_phpdir}/language/*.htm
121
122 %lang(en) %{_phpdir}/language/lang_english
123 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
124
125 %lang(pl) %{_phpdir}/language/lang_polish
126 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
127
128 %lang(de) %{_phpdir}/language/lang_german
129 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
130
131 %lang(fr) %{_phpdir}/language/lang_french
132 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
133
134 %files install
135 %defattr(644,root,root,755)
136 %doc install/schemas/*.zip
137 %attr(750,root,http) %dir %{_phpdir}/install
138 %attr(640,root,http) %{_phpdir}/install/*.php
139 %attr(640,root,http) %{_phpdir}/install/*.htm
140 %attr(750,root,http) %dir %{_phpdir}/install/schemas
141 %attr(640,root,http) %{_phpdir}/install/schemas/*.sql
This page took 0.061519 seconds and 4 git commands to generate.