]> git.pld-linux.org Git - packages/phpBB.git/blob - phpBB.spec
- spaces->tabs
[packages/phpBB.git] / phpBB.spec
1 # TODO:
2 # - move everything to %{_datadir}/%{name}
3 # - move config to /etc
4 Summary:        A feature-rich PHP discussion board
5 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach
6 Name:           phpBB
7 Version:        2.0.10
8 Release:        2
9 License:        GPL v2
10 Group:          Applications/WWW
11 Source0:        http://dl.sourceforge.net/phpbb/%{name}-%{version}.tar.bz2
12 # Source0-md5:  9aaf577d3160f6e3ba069eb2e670e2a4
13 Source1:        http://dl.sourceforge.net/phpbb/lang_polish.tar.gz
14 # Source1-md5:  db020ef788d4bd50ce04014964e3e043
15 Source2:        http://dl.sourceforge.net/phpbb/subSilver_polish.tar.gz
16 # Source2-md5:  9367f7a761aef3795ffa296b413136b4
17 Source3:        http://dl.sourceforge.net/phpbb/lang_german.tar.gz
18 # Source3-md5:  afc686072978b896e18fa211210c3b13
19 Source4:        http://dl.sourceforge.net/phpbb/subSilver_german.tar.gz
20 # Source4-md5:  8340f310ee4892f3e19da3e000fdb708
21 Source5:        http://dl.sourceforge.net/phpbb/lang_french.tar.gz
22 # Source5-md5:  c81f843d4adf0a086efef590074478e6
23 Source6:        http://dl.sourceforge.net/phpbb/subSilver_french.tar.gz
24 # Source6-md5:  419157eb144fa81b7464a5f2edeea434
25 URL:            http://www.phpbb.com/
26 Requires:       php-pcre
27 Requires:       webserver
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _phpdir         /home/services/httpd/html/phpBB
32
33 %description
34 phpBB is a UBB-style dissussion board written in PHP backended by a
35 MySQL database. It includes features such as posting/replying/editing
36 messages, private messages, private forums, user and anonymous
37 posting, robust theming, user ranking by posts or by special, admin
38 definable, ranks, and much more.
39
40 %description -l pl
41 phpBB jest forum dyskusyjnym w stylu UBB napisanym w PHP z u¿yciem
42 bazy danych MySQL. Ma mo¿liwo¶ci takie jak: wysy³anie, odpisywanie,
43 edycja wiadomo¶ci, prywatne wiadomo¶ci, prywatne fora, wysy³anie jako
44 u¿ytkownik i anonimowe, bogaty wybór motywów, ranking u¿ytkowników
45 wed³ug ich wiadomo¶ci lub specjalne, definiowane przez administratora,
46 rankingi i wiele innych.
47
48 %package install
49 Summary:        A feature-rich PHP discussion board - installer
50 Summary(pl):    Forum dyskusyjne o du¿ych mo¿liwo¶ciach - instalator
51 Group:          Applications/Databases/Interfaces
52 Requires:       phpBB
53
54 %description install
55 Package needed for %{name} forum instalation.
56
57 %description install -l pl
58 Pakiet potrzebny do instalacji forum %{name}.
59
60 %prep
61 %setup -q -n %{name}2
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_phpdir}/{admin,db,images,includes,install/schemas,language,templates}
66
67 install *.{php,inc}     $RPM_BUILD_ROOT%{_phpdir}
68 install admin/*.php     $RPM_BUILD_ROOT%{_phpdir}/admin
69 install db/*.php        $RPM_BUILD_ROOT%{_phpdir}/db
70 install includes/*.php  $RPM_BUILD_ROOT%{_phpdir}/includes
71 install install/*.php   $RPM_BUILD_ROOT%{_phpdir}/install
72 install install/schemas/*.sql $RPM_BUILD_ROOT%{_phpdir}/install/schemas
73
74 cp -R images/*          $RPM_BUILD_ROOT%{_phpdir}/images
75 cp -R language/*        $RPM_BUILD_ROOT%{_phpdir}/language
76 cp -R templates/*       $RPM_BUILD_ROOT%{_phpdir}/templates
77
78 tar zxfv %{SOURCE1} -C $RPM_BUILD_ROOT%{_phpdir}/language/
79 tar zxfv %{SOURCE2} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
80
81 tar zxfv %{SOURCE3} -C $RPM_BUILD_ROOT%{_phpdir}/language/
82 tar zxfv %{SOURCE4} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
83
84 tar zxfv %{SOURCE5} -C $RPM_BUILD_ROOT%{_phpdir}/language/
85 tar zxfv %{SOURCE6} -C $RPM_BUILD_ROOT%{_phpdir}/templates/
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post install
91 echo "For instalation: http://<your.site.address>/<path>/install/install.php"
92 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
93 echo
94 echo "Remember to uninstall %{name}-install after initiation/upgrade of %{name}!!"
95
96 %triggerpostun -- %{name} <= %{version}
97 echo "You have to install %{name}-install package to prepare upgrade!!!"
98 echo "For upgrade: http://<your.site.address>/<path>/install/upgrade.php"
99
100 %files
101 %defattr(644,root,root,755)
102 %doc docs/*
103 %attr(755,root,http) %dir %{_phpdir}
104 %attr(640,root,http) %config(noreplace) %{_phpdir}/config.php
105 %attr(640,root,http) %{_phpdir}/[^c]*.php
106 %attr(640,root,http) %{_phpdir}/common.php
107 %attr(640,root,http) %{_phpdir}/*.inc
108 %attr(750,root,http) %dir %{_phpdir}/admin
109 %attr(750,root,http) %dir %{_phpdir}/db
110 %attr(750,root,http) %dir %{_phpdir}/images
111 %attr(640,root,http) %{_phpdir}/images/*.gif
112 %attr(640,root,http) %{_phpdir}/images/index.htm
113 %attr(750,root,http) %dir %{_phpdir}/images/smiles
114 %attr(1770,root,http) %dir %{_phpdir}/images/avatars
115 %attr(750,root,http) %dir %{_phpdir}/includes
116 %{_phpdir}/admin/*
117 %{_phpdir}/db/*
118 %{_phpdir}/images/smiles/*
119 %{_phpdir}/images/avatars/*
120 %{_phpdir}/includes/*
121 %{_phpdir}/templates/index.htm
122 %attr(750,root,http) %dir %{_phpdir}/templates
123 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver
124 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/admin
125 %attr(640,root,http) %{_phpdir}/templates/subSilver/admin/*
126 %attr(640,root,http) %{_phpdir}/templates/subSilver/*.*
127 %attr(750,root,http) %dir %{_phpdir}/templates/subSilver/images
128 %attr(640,root,http) %{_phpdir}/templates/subSilver/images/*.*
129 %attr(640,root,http) %{_phpdir}/language/*.htm
130
131 %lang(en) %{_phpdir}/language/lang_english
132 %lang(en) %{_phpdir}/templates/subSilver/images/lang_english
133
134 %lang(pl) %{_phpdir}/language/lang_polish
135 %lang(pl) %{_phpdir}/templates/subSilver/images/lang_polish
136
137 %lang(de) %{_phpdir}/language/lang_german
138 %lang(de) %{_phpdir}/templates/subSilver/images/lang_german
139
140 %lang(fr) %{_phpdir}/language/lang_french
141 %lang(fr) %{_phpdir}/templates/subSilver/images/lang_french
142
143 %files install
144 %defattr(644,root,root,755)
145 %doc install/schemas/*.zip
146 %attr(750,root,http) %dir %{_phpdir}/install
147 %attr(640,root,http) %{_phpdir}/install/*.php
148 %attr(750,root,http) %dir %{_phpdir}/install/schemas
149 %attr(640,root,http) %{_phpdir}/install/schemas/*.sql
This page took 0.0365 seconds and 4 git commands to generate.