]> git.pld-linux.org Git - packages/php4-pecl-tidy.git/blob - php4-pecl-tidy.spec
- ./adapter -s
[packages/php4-pecl-tidy.git] / php4-pecl-tidy.spec
1 %define         _modname        tidy
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php4
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5
6 Summary:        %{_modname} - Tidy HTML Repairing and Parsing
7 Summary(pl):    %{_modname} - Czyszczenie, naprawa oraz parsowanie HTML
8 Name:           php4-pecl-%{_modname}
9 Version:        1.1
10 Release:        1
11 License:        PHP
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
14 # Source0-md5:  ecb2d3c62e1d720265a65dfb7e00e081
15 URL:            http://pecl.php.net/package/tidy/
16 BuildRequires:  php4-devel
17 BuildRequires:  rpmbuild(macros) >= 1.230
18 BuildRequires:  tidy-devel
19 %requires_eq_to php4-common php4-devel
20 Requires:       %{_sysconfdir}/conf.d
21 Obsoletes:      php-pear-%{_modname}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Tidy is a binding for the Tidy HTML clean and repair utility which
26 allows you to not only clean and otherwise manipluate HTML documents,
27 but also traverse the document tree using the Zend Engine 2 OO
28 semantics.
29
30 In PECL status of this package is: %{_status}.
31
32 %description -l pl
33 Tidy jest dowi±zaniem do narzêdzia "Tidy HTML clean and repair", które
34 pozwala nie tylko na czyszczenie oraz manipulacjê dokumentami HTML,
35 ale tak¿e na przemierzanie przez strukturê dokumentu za pomoc±
36 zorientowanej obiektowo semantyki silnika Zend Engine 2.
37
38 To rozszerzenie ma w PECL status: %{_status}.
39
40 %prep
41 %setup -q -c
42
43 %build
44 cd %{_modname}-%{version}
45 phpize
46 %configure
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
53
54 %{__make} -C %{_modname}-%{version} install \
55         INSTALL_ROOT=$RPM_BUILD_ROOT
56
57 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
58 ; Enable %{_modname} extension module
59 extension=%{_modname}.so
60 EOF
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
67 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
68
69 %postun
70 if [ "$1" = 0 ]; then
71         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
72         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc %{_modname}-%{version}/{CREDITS,TODO,README}
78 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
79 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.091161 seconds and 4 git commands to generate.