]> git.pld-linux.org Git - packages/php4-pecl-http.git/blob - php4-pecl-http.spec
- rebuild with zts and debug requires
[packages/php4-pecl-http.git] / php4-pecl-http.spec
1 %define         _modname        http
2 %define         _fmodname       pecl_http
3 %define         _status         beta
4 %define         _sysconfdir     /etc/php4
5 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
6
7 Summary:        %{_modname} - extended HTTP support
8 Summary(pl):    %{_modname} - rozszerzona obs³uga protoko³u HTTP
9 Name:           php4-pecl-%{_modname}
10 Version:        0.13.0
11 Release:        5
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
15 # Source0-md5:  97d867fced7c93b7b6e016044faa7579
16 URL:            http://pecl.php.net/package/pecl_http/
17 BuildRequires:  mhash-devel
18 BuildRequires:  php4-devel >= 3:4.3.0
19 BuildRequires:  rpmbuild(macros) >= 1.254
20 %{?requires_php_extension}
21 Requires:       %{_sysconfdir}/conf.d
22 Obsoletes:      php-pear-%{_modname}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Currently implemented features:
27 - Building absolute URIs
28 - RFC compliant HTTP redirects
29 - RFC compliant HTTP date handling
30 - Parsing of HTTP headers and messages
31 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
32   ETag generation from buffered output)
33 - Sending data/files/streams with (multiple) ranges support
34 - Negotiating user preferred language/charset
35 - Convenient request functions to HEAD/GET/POST if libcurl is
36   available
37 - HTTP auth hooks (Basic)
38 - PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
39   HttpMessage
40
41 In PECL status of this extension is: %{_status}.
42
43 %description -l pl
44 Aktualnie zaimplementowane mo¿liwo¶ci:
45 - tworzenie bezwzglêdnych URI
46 - zgodne z RFC przekierowania HTTP
47 - zgodna z RFC obs³uga daty HTTP
48 - przetwarzanie nag³ówków i wiadomo¶ci HTTP
49 - buforowanie z u¿yciem "Last-Modified" i/lub ETagów (z opcjê
50   generowania "w locie" ETagów z buforowanego wyj¶cia)
51 - wysy³anie danych/plików/strumieni z obs³ug± (wielu) przedzia³ów
52 - negocjacja preferowanego przez u¿ytkownika jêzyka/zestawu znaków
53 - wygodne funkcje do ¿±dañ HEAD/GET/POST je¶li dostêpna jest libcurl
54 - wywo³ania HTTP auth (Basic)
55 - klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
56   HttpMessage
57
58 To rozszerzenie ma w PECL status: %{_status}.
59
60 %prep
61 %setup -q -c
62
63 %build
64 cd %{_fmodname}-%{version}
65 phpize
66 %configure
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
72
73 install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
74 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
75 ; Enable %{_modname} extension module
76 extension=%{_modname}.so
77 EOF
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
84 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
85
86 %postun
87 if [ "$1" = 0 ]; then
88         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
89         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
90 fi
91
92 %files
93 %defattr(644,root,root,755)
94 %doc %{_fmodname}-%{version}/{docs,EXPERIMENTAL}
95 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
96 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.063751 seconds and 4 git commands to generate.