]> git.pld-linux.org Git - packages/php4-pecl-http.git/blob - php4-pecl-http.spec
- move %define calls to the top of the file
[packages/php4-pecl-http.git] / php4-pecl-http.spec
1 %define         _modname        http
2 %define         _fmodname       pecl_http
3 %define         _status         beta
4 %define         _sysconfdir     /etc/php4
5 %define         extensionsdir   %(php4-config --extension-dir 2>/dev/null)
6
7 Summary:        %{_modname} - extended HTTP support
8 Summary(pl):    %{_modname} - rozszerzona obs³uga protoko³u HTTP
9 Name:           php4-pecl-%{_modname}
10 Version:        0.12.0
11 Release:        1
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
15 # Source0-md5:  d180e5b95d22c911e40d8265f7c8fd96
16 URL:            http://pecl.php.net/package/pecl_http/
17 BuildRequires:  libtool
18 BuildRequires:  php4-devel >= 3:4.3.0
19 Requires:       %{_sysconfdir}/conf.d
20 %requires_eq_to php4-common php4-devel
21 Obsoletes:      php-pear-%{_modname}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Currently implemented features:
26 - Building absolute URIs
27 - RFC compliant HTTP redirects
28 - RFC compliant HTTP date handling
29 - Parsing of HTTP headers and messages
30 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
31   ETag generation from buffered output)
32 - Sending data/files/streams with (multiple) ranges support
33 - Negotiating user preferred language/charset
34 - Convenient request functions to HEAD/GET/POST if libcurl is available
35 - HTTP auth hooks (Basic)
36 - PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool, HttpMessage
37
38 In PECL status of this extension is: %{_status}.
39
40 %description -l pl
41 Aktualnie zaimplementowane mo¿liwo¶ci:
42 - tworzenie bezwzglêdnych URI
43 - zgodne z RFC przekierowania HTTP
44 - zgodna z RFC obs³uga daty HTTP
45 - przetwarzanie nag³ówków i wiadomo¶ci HTTP
46 - buforowanie z u¿yciem "Last-Modified" i/lub ETagów (z opcjê
47   generowania "w locie" ETagów z buforowanego wyj¶cia)
48 - wysy³anie danych/plików/strumieni z obs³ug± (wielu) przedzia³ów
49 - negocjacja preferowanego przez u¿ytkownika jêzyka/zestawu znaków
50 - wygodne funkcje do ¿±dañ HEAD/GET/POST je¶li dostêpna jest libcurl
51 - wywo³ania HTTP auth (Basic)
52 - klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool, HttpMessage
53
54 To rozszerzenie ma w PECL status: %{_status}.
55
56 %prep
57 %setup -q -c
58
59 %build
60 cd %{_fmodname}-%{version}
61 phpize
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
68
69 install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
70 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
71 ; Enable %{_modname} extension module
72 extension=%{_modname}.so
73 EOF
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
80 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
81
82 %postun
83 if [ "$1" = 0 ]; then
84         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
85         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
86 fi
87
88 %files
89 %defattr(644,root,root,755)
90 %doc %{_fmodname}-%{version}/{docs,EXPERIMENTAL}
91 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/%{_modname}.ini
92 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.128143 seconds and 3 git commands to generate.