]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- disable debug
[packages/php.git] / php.spec
1 Summary:        The PHP HTML-embedded scripting language for use with Apache.
2 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache.
3 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
4 Name:           php
5 Version:        4.0b4pl1
6 Release:        1
7 Group:          Libraries
8 Group(fr):      Librairies
9 Group(pl):      Biblioteki
10 License:        GPL
11 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
12 Source1:        FAQ.php
13 Source2:        php.ini
14 Source3:        zend.gif
15 Icon:           php4.gif
16 URL:            http://www.php.net/
17 BuildRequires:  apache-devel
18 BuildRequires:  zlib-devel
19 BuildRequires:  mysql-devel >= 3.22.30-2
20 Requires:       apache >= 1.3.9
21 Prereq:         /usr/sbin/apxs
22 BuildRoot:      /tmp/%{name}-%{version}-root
23
24 %define         _pkglibdir      %{_libdir}/apache
25
26 %description
27 PHP is an HTML-embedded scripting language.  PHP attempts to make it easy
28 for developers to write dynamically generated web pages.  PHP also offers
29 built-in database integration for several commercial and non-commercial
30 database management systems, so writing a database-enabled web page with
31 PHP is fairly simple.  The most common use of PHP coding is probably as a
32 replacement for CGI scripts.  The mod_php module enables the Apache web
33 server to understand and process the embedded PHP language in web pages.
34 This package contains PHP version %{version}.  If you use applications which
35 specifically rely on PHP/FI (PHP v2 and earlier), you should instead install
36 the PHP/FI module contained in the phpfi package.  If you're just starting
37 with PHP, you should install this package.  You'll also need to install
38 the Apache web server.
39
40 %description -l fr
41 PHP est un langage de script embarque dans le HTM. PHP essaye de rendre
42 simple aux developpeurs d'ecrire des pages web generees dynamiquement.
43 PHP incorpore egalement une integration avec plusieurs systemes de gestion
44 de bases de donnees commerciaux et non-connerciaux, qui rent facile
45 la creation de pages web liees avec des bases de donnees. L'utilisation la
46 plus commune de PHP est probablement en remplacement de scripts CGI. Le
47 module mod_php permet au serveur web apache de comprendre et de traiter le
48 langage PHP integre dans des pages web.
49 Ce package contient PHP version %{version}. Si vous utilisez des
50 applications qui utilisent specifiquement PHP/FI, vous devrez installer le
51 module PHP/FI inclus dans le package mod_php. Si vous debutez avec PHP, vous
52 devriez installer ce package. Vous aurez egalement besoin d'installer le
53 serveur web Apache.
54
55 %description -l pl
56 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w plikach
57 HTML.  Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP (jak np.
58 Apache), który interpretuje te polecenia.  Umo¿liwia to tworzenie
59 dynamicznie stron WWW.  Spora czê¶æ sk³adni PHP zapo¿yczona zosta³a
60 z jêzyków: C, Java i Perl.
61
62 %package mysql
63 Summary:        MySQL database module for PHP4
64 Summary(pl):    Modu³ bazy danych MySQL dla PHP4
65 Group:          Libraries
66 Group(fr):      Librairies
67 Group(pl):      Biblioteki
68 Requires:       %{name} = %{version}
69
70 %description mysql
71 This is a dynamic shared object (DSO) for Apache that will add MySQL
72 database support to PHP4.  If you need back-end support for MySQL,
73 you should install this package in addition to the main %{name} package.
74
75 %package gd
76 Summary:        GD extension module fot PHP4
77 Summary:        Modu³ GD dla PHP4
78 Group:          Libraries
79 Group(fr):      Librairies
80 Group(pl):      Biblioteki
81 Requires:       %{name} = %{version}
82
83 %description gd
84
85 %description gd -l pl
86
87 %prep
88 %setup -q 
89
90 %build
91 LDFLAGS=""; export LDFLAGS
92 ./buildconf
93 %configure \
94         --with-apxs=%{_sbindir}/apxs \
95         --with-config-file-path=%{_sysconfdir}/httpd \
96         --enable-safe-mode \
97         --with-exec-dir=%{_bindir} \
98         --disable-debug \
99         --with-zlib \
100         --enable-magic-quotes \
101         --enable-track-vars \
102         --with-gd=shared \
103         --with-regex=system \
104         --with-gettext \
105         --with-mysql=shared \
106         --enable-shared 
107 make
108
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_pkglibdir}/php,%{_sysconfdir}/httpd} \
113                 $RPM_BUILD_ROOT/home/httpd/html/icons
114
115
116 install .libs/*.so      $RPM_BUILD_ROOT%{_pkglibdir}
117 install modules/*.so    $RPM_BUILD_ROOT%{_pkglibdir}/php
118
119 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
120 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
121
122 strip --strip-unneeded  \
123         $RPM_BUILD_ROOT%{_pkglibdir}/*.so \
124         $RPM_BUILD_ROOT%{_pkglibdir}/php/*.so
125
126 install  %{SOURCE1}     .
127 gzip -9nf CODING_STANDARDS CREDITS FAQ* ChangeLog FUNCTION_LIST.txt \
128         MAINTAINERS MODULES_STATUS NEWS TODO*
129
130 %post
131 /usr/sbin/apxs -e -a -n php %{_pkglibdir}/libphp4.so 1>&2
132 if [ -f /var/lock/subsys/httpd ]; then
133         /etc/rc.d/init.d/httpd restart 1>&2
134 fi
135
136
137 %preun
138 if [ "$1" = "0" ]; then
139         /usr/sbin/apxs -e -A -n php %{_pkglibdir}/libphp4.so 1>&2
140         if [ -f /var/lock/subsys/httpd ]; then
141                 /etc/rc.d/init.d/httpd restart 1>&2
142         fi
143 fi
144
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %doc {CODING_STANDARDS,CREDITS,FAQ*,ChangeLog,FUNCTION_LIST.txt}.gz
152 %doc {MAINTAINERS,MODULES_STATUS,NEWS,TODO*}.gz  
153
154 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
155 %dir %{_pkglibdir}/php
156
157 #%attr(755,root,root) %{_libdir}/apache/php/*.so
158
159 /home/httpd/html/icons/*
160
161 %attr(755,root,root) %{_pkglibdir}/libphp4.so
162
163 %files mysql
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_pkglibdir}/php/mysql.so
166
167 %files gd
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_pkglibdir}/php/gd.so
This page took 0.047086 seconds and 4 git commands to generate.