]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- adapterized version from Tsunami
[packages/php.git] / php.spec
1 Summary:        The PHP HTML-embedded scripting language for use with Apache.
2 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
3 Name:           php
4 Version:        4.0b3
5 Release:        1
6 Group:          Libraries
7 Group(pl):      X11/Programowanie/Biblioteki
8 Group:          Biblioteki
9 License:        GPL
10 Icon:           php4.gif
11 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
12 Source1:        FAQ.php
13 Source2:        php.ini
14 Source3:        zend.gif
15 BuildRequires:  apache-devel
16 BuildRequires:  zlib-devel
17 BuildRoot:      /tmp/%{name}-%{version}-root
18
19 %description
20 PHP is an HTML-embedded scripting language.  PHP attempts to make it easy
21 for developers to write dynamically generated web pages.  PHP also offers
22 built-in database integration for several commercial and non-commercial
23 database management systems, so writing a database-enabled web page with
24 PHP is fairly simple.  The most common use of PHP coding is probably as a
25 replacement for CGI scripts.  The mod_php module enables the Apache web
26 server to understand and process the embedded PHP language in web pages.
27 This package contains PHP.  If you use applications which specifically rely
28 on PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
29 module contained in the phpfi package.  If you're just starting with PHP,
30 you should install this package.  You'll also need to install the Apache
31 web server.
32
33 %description -l pl
34 PHP jest jêzykiem skryptowym
35
36 %prep
37 %setup -q 
38
39 %build
40 libtoolize --copy --force
41 aclocal
42 autoheader
43 autoconf
44 %configure \
45         --with-apxs=%{_sbindir}/apxs \
46         --with-config-file-path=%{_sysconfdir}/httpd \
47         --enable-safe-mode \
48         --with-exec-dir=%{_bindir} \
49         --disable-debug \
50         --with-zlib \
51         --enable-magic-quotes \
52         --enable-track-vars \
53         --without-gd \
54         --enable-shared 
55 make
56
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d      $RPM_BUILD_ROOT{%{_libdir}/apache,%{_sysconfdir}/httpd,/home/httpd/html/icons/}
61
62 install         .libs/*.so              $RPM_BUILD_ROOT%{_libdir}/apache
63 install         %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
64 install %{SOURCE3} $RPM_BUILD_ROOT/home/httpd/html/icons/
65
66 strip --strip-unneeded  $RPM_BUILD_ROOT%{_libdir}/apache/*.so
67
68 install  %{SOURCE1}     .
69 gzip -9nf CODING_STANDARDS CREDITS FAQ* 
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74
75 %files
76 %defattr(644,root,root,755)
77 %doc {CODING_STANDARDS,CREDITS,FAQ*}.gz  
78
79 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
80 %attr(755,root,root) %{_libdir}/apache/libphp4.so
This page took 0.030375 seconds and 4 git commands to generate.