]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- added --with-mysql to ./configure options
[packages/php.git] / php.spec
1 Summary:        The PHP HTML-embedded scripting language for use with Apache.
2 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
3 Name:           php
4 Version:        4.0b4pl1
5 Release:        1
6 Group:          Libraries
7 Group(pl):      X11/Programowanie/Biblioteki
8 Group:          Biblioteki
9 License:        GPL
10 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
11 Source1:        FAQ.php
12 Source2:        php.ini
13 Source3:        zend.gif
14 Icon:           php4.gif
15 URL:            http://www.php.net/
16 BuildRequires:  apache-devel
17 BuildRequires:  zlib-devel
18 BuildRequires:  mysql-devel
19 BuildRoot:      /tmp/%{name}-%{version}-root
20
21 %description
22 PHP is an HTML-embedded scripting language.  PHP attempts to make it easy
23 for developers to write dynamically generated web pages.  PHP also offers
24 built-in database integration for several commercial and non-commercial
25 database management systems, so writing a database-enabled web page with
26 PHP is fairly simple.  The most common use of PHP coding is probably as a
27 replacement for CGI scripts.  The mod_php module enables the Apache web
28 server to understand and process the embedded PHP language in web pages.
29 This package contains PHP.  If you use applications which specifically rely
30 on PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
31 module contained in the phpfi package.  If you're just starting with PHP,
32 you should install this package.  You'll also need to install the Apache
33 web server.
34
35 %description -l pl
36 PHP jest jêzykiem skryptowym
37
38 %prep
39 %setup -q 
40
41 %build
42 ./buildconf
43 %configure \
44         --with-apxs=%{_sbindir}/apxs \
45         --with-config-file-path=%{_sysconfdir}/httpd \
46         --enable-safe-mode \
47         --with-exec-dir=%{_bindir} \
48         --disable-debug \
49         --with-zlib \
50         --enable-magic-quotes \
51         --enable-track-vars \
52         --without-gd \
53         --with-mysql \
54         --enable-shared 
55 make
56
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_libdir}/apache,%{_sysconfdir}/httpd} \
61                 $RPM_BUILD_ROOT/home/httpd/html/icons
62
63 install .libs/*.so      $RPM_BUILD_ROOT%{_libdir}/apache
64 install %{SOURCE2}      $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
65 install %{SOURCE3}      $RPM_BUILD_ROOT/home/httpd/html/icons
66
67 strip --strip-unneeded  $RPM_BUILD_ROOT%{_libdir}/apache/*.so
68
69 install  %{SOURCE1}     .
70 gzip -9nf CODING_STANDARDS CREDITS FAQ* 
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc {CODING_STANDARDS,CREDITS,FAQ*}.gz  
78
79 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
80 %attr(755,root,root) %{_libdir}/apache/libphp4.so
This page took 0.0542010000000001 seconds and 4 git commands to generate.