]> git.pld-linux.org Git - packages/php.git/blob - php.spec
mysql fixes
[packages/php.git] / php.spec
1 #
2 #   oracle - with oracle support 
3 #   oci8   - with oci8 support
4 #       
5 Summary:        The PHP HTML-embedded scripting language for use with Apache
6 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache
7 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
8 Name:           php
9 Version:        4.0.4pl1
10 Release:        0.4
11 Epoch:          1
12 Group:          Libraries
13 Group(de):      Libraries
14 Group(fr):      Librairies
15 Group(pl):      Biblioteki
16 License:        The PHP license (see "LICENSE" file included in distribution)
17 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
18 Source1:        FAQ.php
19 Source2:        %{name}.ini
20 Source3:        zend.gif
21 Source4:        http://www.php.net/distributions/manual.tar.gz
22 Source5:        php-module-install
23 Patch0:         %{name}-imap.patch
24 Patch1:         %{name}-mysql-socket.patch
25 Patch2:         %{name}-mail.patch
26 Patch5:         %{name}-no_libnsl.patch
27 Patch6:         %{name}-DESTDIR.patch
28 Patch7:         %{name}-gd-shared.patch
29 Patch8:         %{name}-apache-fixes.patch
30 #Patch9:                %{name}-system-expat.patch
31 Icon:           php4.gif
32 URL:            http://www.php.net/
33 BuildRequires:  apache(EAPI)-devel
34 BuildRequires:  zip
35 BuildRequires:  bison
36 BuildRequires:  flex
37 BuildRequires:  db3-devel >= 3.1.17
38 BuildRequires:  freetype-devel
39 BuildRequires:  gd-devel >= 1.8.3
40 BuildRequires:  gdbm-devel
41 BuildRequires:  imap-devel >= 4.7b-1
42 # I think jdk is better for java
43 # BuildRequires:        jdk
44 %{?bcond_on_java:BuildRequires: kaffe-devel}
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libltdl-devel
47 BuildRequires:  libpng >= 1.0.8
48 BuildRequires:  libtiff-devel
49 BuildRequires:  mm-devel >= 1.1.3
50 BuildRequires:  mysql-devel >= 3.23.32
51 %{!?bcond_off_ldap:BuildRequires: openldap-devel >= 2.0}
52 BuildRequires:  pam-devel
53 BuildRequires:  pdflib-devel >= 3.0
54 #BuildRequires: libxml-devel >= 2.0.0
55 BuildRequires:  postgresql-devel
56 BuildRequires:  recode-devel >= 3.5
57 BuildRequires:  t1lib-devel
58 BuildRequires:  unixODBC-devel
59 BuildRequires:  zlib-devel >= 1.0.9
60 BuildRequires:  ucd-snmp-devel >= 4.1
61 BuildRequires:  libmcrypt-devel >= 2.4.4
62 BuildRequires:  mhash-devel
63 BuildRequires:  bzip2-devel
64 BuildRequires:  gmp-devel
65 BuildRequires:  curl-devel
66 %if %(expr %{?bcond_on_openssl:1}%{!?bcond_on_openssl:0} + %{!?bcond_off_ldap:1}%{?bcond_off_ldap:0})
67 BuildRequires:  openssl-devel >= 0.9.6
68 %endif
69 Requires:       apache(EAPI) >= 1.3.9
70 Prereq:         perl
71 Prereq:         /usr/sbin/apxs
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     /etc/php
75 %define         extensionsdir   %{_libdir}/php/extensions/no-debug-non-zts-%(egrep '#define ZEND_MODULE_API_NO ' %{_builddir}/%{buildsubdir}/Zend/modules.h|sed 's/#define ZEND_MODULE_API_NO //')
76
77 %description
78 PHP is an HTML-embedded scripting language. PHP attempts to make it
79 easy for developers to write dynamically generated web pages. PHP also
80 offers built-in database integration for several commercial and
81 non-commercial database management systems, so writing a
82 database-enabled web page with PHP is fairly simple. The most common
83 use of PHP coding is probably as a replacement for CGI scripts. The
84 mod_php module enables the Apache web server to understand and process
85 the embedded PHP language in web pages. This package contains PHP
86 version %{version}. If you use applications which specifically rely on
87 PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
88 module contained in the phpfi package. If you're just starting with
89 PHP, you should install this package. You'll also need to install the
90 Apache web server.
91
92 %description -l fr
93 PHP est un langage de script embarque dans le HTM. PHP essaye de
94 rendre simple aux developpeurs d'ecrire des pages web generees
95 dynamiquement. PHP incorpore egalement une integration avec plusieurs
96 systemes de gestion de bases de donnees commerciaux et
97 non-connerciaux, qui rent facile la creation de pages web liees avec
98 des bases de donnees. L'utilisation la plus commune de PHP est
99 probablement en remplacement de scripts CGI. Le module mod_php permet
100 au serveur web apache de comprendre et de traiter le langage PHP
101 integre dans des pages web. Ce package contient PHP version
102 %{version}. Si vous utilisez des applications qui utilisent
103 specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
104 dans le package mod_php. Si vous debutez avec PHP, vous devriez
105 installer ce package. Vous aurez egalement besoin d'installer le
106 serveur web Apache.
107
108 %description -l pl
109 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
110 plikach HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP
111 (jak np. Apache), który interpretuje te polecenia. Umo¿liwia to
112 tworzenie dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona
113 zosta³a z jêzyków: C, Java i Perl.
114
115 %package mysql
116 Summary:        MySQL database module for PHP
117 Summary(pl):    Modu³ bazy danych MySQL dla PHP
118 Group:          Libraries
119 Group(de):      Libraries
120 Group(fr):      Librairies
121 Group(pl):      Biblioteki
122 PreReq: %{name} = %{version}
123
124 %description mysql
125 This is a dynamic shared object (DSO) for Apache that will add MySQL
126 database support to PHP. If you need back-end support for MySQL, you
127 should install this package in addition to the main %{name} package.
128
129 %description mysql -l pl
130 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych MySQL.
131
132
133 %package pgsql
134 Summary:        PostgreSQL database module for PHP
135 Summary(pl):    Modu³ bazy danych PostgreSQL dla PHP
136 Group:          Libraries
137 Group(de):      Libraries
138 Group(fr):      Librairies
139 Group(pl):      Biblioteki
140 PreReq: %{name} = %{version}
141
142 %description pgsql
143 This is a dynamic shared object (DSO) for Apache that will add
144 PostgreSQL database support to PHP. If you need back-end support for
145 PostgreSQL, you should install this package in addition to the main
146 %{name} package.
147
148 %description pgsql -l pl
149 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych PostgreSQL.
150
151 %package oci8
152 Summary:        Oracle 8 database module for PHP
153 Summary(pl):    Modu³ bazy danych Oracle 8 dla PHP
154 Group:          Libraries
155 Group(de):      Libraries
156 Group(fr):      Librairies
157 Group(pl):      Biblioteki
158 PreReq: %{name} = %{version}
159 Autoreq:        false
160
161 %description oci8
162 This is a dynamic shared object (DSO) for Apache that will add Oracle
163 8 database support to PHP. If you need back-end support for Oracle 8,
164 you should install this package in addition to the main %{name}
165 package.
166
167 %description oci8 -l pl
168 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 8. }
169
170 %package oracle
171 Summary:        Oracle 7 database module for PHP
172 Summary(pl):    Modu³ bazy danych Oracle 7 dla PHP
173 Group:          Libraries
174 Group(de):      Libraries
175 Group(fr):      Librairies
176 Group(pl):      Biblioteki
177 PreReq: %{name} = %{version}
178 Autoreq:        false
179
180 %description oracle
181 This is a dynamic shared object (DSO) for Apache that will add Oracle
182 7 database support to PHP. If you need back-end support for Oracle 7,
183 you should install this package in addition to the main %{name}
184 package.
185
186 %description oracle -l pl
187 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 7. }
188
189 %package gd
190 Summary:        GD extension module for PHP
191 Summary:        Modu³ GD dla PHP
192 Group:          Libraries
193 Group(de):      Libraries
194 Group(fr):      Librairies
195 Group(pl):      Biblioteki
196 PreReq: %{name} = %{version}
197
198 %description gd
199 This is a dynamic shared object (DSO) for Apache that will add GD
200 support to PHP. You should install this package in addition to the
201 main %{name} package if you want to create and manipulate images with
202 PHP.
203
204 %description gd -l pl
205
206 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
207 %package java
208 Summary:        Java extension module for PHP
209 Summary(pl):    Modu³ Javy dla PHP
210 Group:          Libraries
211 Group(de):      Libraries
212 Group(fr):      Librairies
213 Group(pl):      Biblioteki
214 PreReq: %{name} = %{version}
215
216 %description java
217 This is a dynamic shared object (DSO) for Apache that will add JAVA
218 support to PHP. This extension provides a simple and effective means
219 for creating and invoking methods on Java objects from PHP.
220
221 %description java -l pl
222 %endif
223
224 %package xml
225 Summary:        XML extension module for PHP
226 Summary(pl):    Modu³ XML dla PHP
227 Group:          Libraries
228 Group(de):      Libraries
229 Group(fr):      Librairies
230 Group(pl):      Biblioteki
231 PreReq: %{name} = %{version}
232
233 %description xml
234 This is a dynamic shared object (DSO) for Apache that will add XML
235 support to PHP. This extension lets you create XML parsers and then
236 define handlers for different XML events. If you want to be able to
237 parse XML documents you should install this package in addition to the
238 main %{name} package.
239
240 #%description xml -l pl
241
242 %package dba
243 Summary:        DBA extension module for PHP
244 Summary(pl):    Modu³ DBA dla PHP
245 Group:          Libraries
246 Group(de):      Libraries
247 Group(fr):      Librairies
248 Group(pl):      Biblioteki
249 PreReq: %{name} = %{version}
250
251 %description dba
252 This is a dynamic shared object (DSO) for Apache that will add
253 flat-file databases (DBA) support to PHP.
254
255 #%description dba -l pl
256
257 %package odbc
258 Summary:        ODBC extension module for PHP
259 Summary(pl):    Modu³ ODBC dla PHP
260 Group:          Libraries
261 Group(de):      Libraries
262 Group(fr):      Librairies
263 Group(pl):      Biblioteki
264 PreReq: %{name} = %{version}
265
266 %description odbc
267 This is a dynamic shared object (DSO) for Apache that will add
268 ODBC support to PHP.
269
270 #%description odbc -l pl
271
272 %package calendar
273 Summary:        Calendar extension module for PHP
274 Summary(pl):    Modu³ funkcji kalendarza dla PHP
275 Group:          Libraries
276 Group(de):      Libraries
277 Group(fr):      Librairies
278 Group(pl):      Biblioteki
279 PreReq: %{name} = %{version}
280
281 %description calendar
282 This is a dynamic shared object (DSO) for Apache that will add
283 calendar support to PHP.
284
285 #%description calendar -l pl
286
287 %package dbase
288 Summary:        DBase extension module for PHP
289 Summary(pl):    Modu³ DBase dla PHP
290 Group:          Libraries
291 Group(de):      Libraries
292 Group(fr):      Librairies
293 Group(pl):      Biblioteki
294 PreReq: %{name} = %{version}
295
296 %description dbase
297 This is a dynamic shared object (DSO) for Apache that will add DBase
298 support to PHP.
299
300 #%description dbase -l pl
301
302 %package filepro
303 Summary:        FilePro extension module for PHP
304 Summary(pl):    Modu³ FilePro dla PHP
305 Group:          Libraries
306 Group(de):      Libraries
307 Group(fr):      Librairies
308 Group(pl):      Biblioteki
309 PreReq: %{name} = %{version}
310
311 %description filepro
312 This is a dynamic shared object (DSO) for Apache that will add FilePro
313 support to PHP.
314
315 #%description filepro -l pl
316
317 %package posix
318 Summary:        POSIX extension module for PHP
319 Summary(pl):    Modu³ POSIX dla PHP
320 Group:          Libraries
321 Group(de):      Libraries
322 Group(fr):      Librairies
323 Group(pl):      Biblioteki
324 PreReq: %{name} = %{version}
325
326 %description posix
327 This is a dynamic shared object (DSO) for Apache that will add POSIX
328 functions support to PHP.
329
330 #%description posix -l pl
331
332 %package pcre
333 Summary:        PCRE extension module for PHP
334 Summary(pl):    Modu³ PCRE dla PHP
335 Group:          Libraries
336 Group(de):      Libraries
337 Group(fr):      Librairies
338 Group(pl):      Biblioteki
339 PreReq: %{name} = %{version}
340
341 %description pcre
342 This is a dynamic shared object (DSO) for Apache that will add Perl
343 Compatible Regular Expression support to PHP.
344
345 #%description pcre -l pl
346
347 %package sysvsem
348 Summary:        SysV sem extension module for PHP
349 Summary(pl):    Modu³ SysV sem dla PHP
350 Group:          Libraries
351 Group(de):      Libraries
352 Group(fr):      Librairies
353 Group(pl):      Biblioteki
354 PreReq: %{name} = %{version}
355
356 %description sysvsem
357 This is a dynamic shared object (DSO) for Apache that will add SysV
358 semafores support to PHP.
359
360 #%description sysvsem -l pl
361
362 %package sysvshm
363 Summary:        SysV shm extension module for PHP
364 Summary(pl):    Modu³ SysV shm dla PHP
365 Group:          Libraries
366 Group(de):      Libraries
367 Group(fr):      Librairies
368 Group(pl):      Biblioteki
369 PreReq: %{name} = %{version}
370
371 %description sysvshm
372 This is a dynamic shared object (DSO) for Apache that will add SysV
373 Shared Memory support to PHP.
374
375 #%description sysvshm -l pl
376
377 %package yp
378 Summary:        NIS (yp) extension module for PHP
379 Summary(pl):    Modu³ NIS (yp) dla PHP
380 Group:          Libraries
381 Group(de):      Libraries
382 Group(fr):      Librairies
383 Group(pl):      Biblioteki
384 PreReq: %{name} = %{version}
385
386 %description yp
387 This is a dynamic shared object (DSO) for Apache that will add NIS
388 (Yellow Pages) support to PHP.
389
390 #%description yp -l pl
391
392 %package bcmath
393 Summary:        bcmath extension module for PHP
394 Summary(pl):    Modu³ bcmath dla PHP
395 Group:          Libraries
396 Group(de):      Libraries
397 Group(fr):      Librairies
398 Group(pl):      Biblioteki
399 PreReq: %{name} = %{version}
400
401 %description bcmath
402 This is a dynamic shared object (DSO) for Apache that will add bc
403 style precision math functions support to PHP.
404
405 #%description bcmath -l pl
406
407 %package ftp
408 Summary:        FTP extension module for PHP
409 Summary(pl):    Modu³ FTP dla PHP
410 Group:          Libraries
411 Group(de):      Libraries
412 Group(fr):      Librairies
413 Group(pl):      Biblioteki
414 PreReq: %{name} = %{version}
415
416 %description ftp
417 This is a dynamic shared object (DSO) for Apache that will add FTP
418 support to PHP.
419
420 #%description ftp -l pl
421
422 %package zlib
423 Summary:        Zlib extension module for PHP
424 Summary(pl):    Modu³ zlib dla PHP
425 Group:          Libraries
426 Group(de):      Libraries
427 Group(fr):      Librairies
428 Group(pl):      Biblioteki
429 PreReq: %{name} = %{version}
430
431 %description zlib
432 This is a dynamic shared object (DSO) for Apache that will add
433 commpresion (zlib) support to PHP.
434
435 #%description zlib -l pl
436
437 %package exif
438 Summary:        exifextension module for PHP
439 Summary(pl):    Modu³ exif dla PHP
440 Group:          Libraries
441 Group(de):      Libraries
442 Group(fr):      Librairies
443 Group(pl):      Biblioteki
444 PreReq: %{name} = %{version}
445
446 %description exif
447 This is a dynamic shared object (DSO) for Apache that will add exif
448 support to PHP.
449
450 #%description exif -l pl
451
452 %package recode
453 Summary:        recodeextension module for PHP
454 Summary(pl):    Modu³ recode dla PHP
455 Group:          Libraries
456 Group(de):      Libraries
457 Group(fr):      Librairies
458 Group(pl):      Biblioteki
459 PreReq: %{name} = %{version}
460
461 %description recode
462 This is a dynamic shared object (DSO) for Apache that will add recode
463 support to PHP.
464
465 #%description recode -l pl
466
467 %package session
468 Summary:        sessionextension module for PHP
469 Summary(pl):    Modu³ session dla PHP
470 Group:          Libraries
471 Group(de):      Libraries
472 Group(fr):      Librairies
473 Group(pl):      Biblioteki
474 PreReq: %{name} = %{version}
475
476 %description session
477 This is a dynamic shared object (DSO) for Apache that will add session
478 support to PHP.
479
480 #%description session -l pl
481
482 %package gettext
483 Summary:        gettextextension module for PHP
484 Summary(pl):    Modu³ gettext dla PHP
485 Group:          Libraries
486 Group(de):      Libraries
487 Group(fr):      Librairies
488 Group(pl):      Biblioteki
489 PreReq: %{name} = %{version}
490
491 %description gettext
492 This is a dynamic shared object (DSO) for Apache that will add gettext
493 support to PHP.
494
495 #%description gettext -l pl
496
497
498 %package snmp
499 Summary:        snmpextension module for PHP
500 Summary(pl):    Modu³ snmp dla PHP
501 Group:          Libraries
502 Group(de):      Libraries
503 Group(fr):      Librairies
504 Group(pl):      Biblioteki
505 PreReq: %{name} = %{version}
506
507 %description snmp
508 This is a dynamic shared object (DSO) for Apache that will add snmp
509 support to PHP.
510
511 #%description snmp -l pl
512
513 %package imap
514 Summary:        imapextension module for PHP
515 Summary(pl):    Modu³ imap dla PHP
516 Group:          Libraries
517 Group(de):      Libraries
518 Group(fr):      Librairies
519 Group(pl):      Biblioteki
520 PreReq: %{name} = %{version}
521
522 %description imap
523 This is a dynamic shared object (DSO) for Apache that will add imap
524 support to PHP.
525
526 #%description imap -l pl
527
528 %package ldap
529 Summary:        LDAP extension module for PHP
530 Summary(pl):    Modu³ LDAP dla PHP
531 Group:          Libraries
532 Group(de):      Libraries
533 Group(fr):      Librairies
534 Group(pl):      Biblioteki
535 PreReq: %{name} = %{version}
536
537 %description ldap
538 This is a dynamic shared object (DSO) for Apache that will add LDAP
539 support to PHP.
540
541 #%description ldap -l pl
542
543 %package sockets
544 Summary:        sockets extension module for PHP
545 Summary(pl):    Modu³ socket dla PHP
546 Group:          Libraries
547 Group(de):      Libraries
548 Group(fr):      Librairies
549 Group(pl):      Biblioteki
550 PreReq: %{name} = %{version}
551
552 %description sockets
553 This is a dynamic shared object (DSO) for Apache that will add sockets
554 support to PHP.
555
556 #%description sockets -l pl
557
558 %package mcrypt
559 Summary:        mcrypt extension module for PHP
560 Summary(pl):    Modu³ mcrypt dla PHP
561 Group:          Libraries
562 Group(de):      Libraries
563 Group(fr):      Librairies
564 Group(pl):      Biblioteki
565 PreReq: %{name} = %{version}
566
567 %description mcrypt
568 This is a dynamic shared object (DSO) for Apache that will add mcrypt
569 support to PHP.
570
571 #%description mcrypt -l pl
572
573 %package mhash
574 Summary:        mhash extension module for PHP
575 Summary(pl):    Modu³ mhash dla PHP
576 Group:          Libraries
577 Group(de):      Libraries
578 Group(fr):      Librairies
579 Group(pl):      Biblioteki
580 PreReq: %{name} = %{version}
581
582 %description mhash
583 This is a dynamic shared object (DSO) for Apache that will add mhash
584 support to PHP.
585
586 #%description mcrypt -l pl
587
588
589 %package doc
590 Summary:        Online manual for PHP
591 Summary(pl):    Dokumentacja dla PHP
592 Group:          Networking/Daemons
593 Group(de):      Netzwerkwesen/Server
594 Group(pl):      Sieciowe/Serwery
595
596 %description doc
597 Comprehensive documentation for PHP, viewable through your web
598 server, too!
599
600 %description doc -l pl
601 Dokumentacja dla pakietu PHP. Mo¿na j± równie¿ ogl±daæ poprzez serwer
602 WWW.
603
604 %package pear
605 Summary:        PEAR
606 Group:          Development/Languages/PHP
607
608 %description pear
609 PEAR.
610
611 %package devel
612 Summary:        Files for PHP modules development
613 Group:          Development/Languages/PHP
614
615 %description devel
616 Files for PHP modules development.
617
618 %prep
619 %setup  -q
620 %patch0 -p1
621 %patch1 -p1
622 %patch2 -p1
623 %patch5 -p1
624 %patch6 -p1
625 %patch7 -p1
626 %patch8 -p1
627 #%patch9 -p1
628
629
630 %build
631 CFLAGS="$RPM_OPT_FLAGS -DEAPI -I/usr/X11R6/include"; export CFLAGS
632 ./buildconf
633 %configure \
634         --with-apxs=/usr/sbin/apxs \
635         --with-config-file-path=%{_sysconfdir}/apache \
636         --with-exec-dir=%{_bindir} \
637         --disable-debug \
638         --enable-magic-quotes \
639         --enable-shared \
640         --enable-track-vars \
641         --enable-safe-mode \
642         --enable-trans-sid \
643         --enable-sysvsem=shared \
644         --enable-sysvshm=shared \
645         --enable-shmop=shared \
646         --enable-session \
647         --enable-exif=shared \
648         --with-regex=system \
649         --with-gettext=shared \
650         %{!?bcond_off_ldap:--with-ldap=shared} \
651         --with-mysql=shared,/usr \
652         --with-mysql-sock=/var/lib/mysql/mysql.sock \
653         --with-gd=shared \
654          --enable-gd-imgstrttf \
655         --with-dbase=shared \
656         --with-filepro=shared \
657         --enable-ftp=shared \
658         --with-hyperwave \
659         --with-pdflib=shared \
660         --with-cpdflib=shared \
661         %{?bcond_on_java:--with-java} \
662         --with-pgsql=shared,/usr \
663         --with-imap=shared \
664         --enable-bcmath=shared \
665         --enable-calendar=shared \
666         --with-mm \
667         --with-pcre-regex=shared \
668         --enable-posix=shared \
669         --with-ttf \
670         --with-t1lib \
671         --with-recode=shared \
672         --enable-ucd-snmp-hack \
673         --enable-dba=shared \
674         --with-snmp=shared \
675         --with-openssl \
676         --with-gdbm \
677         --with-db3 \
678         --enable-yp=shared \
679         --with-xml=shared \
680         --enable-xml=shared \
681         --with-zlib=shared \
682         --with-mcrypt=shared \
683         --enable-sockets=shared \
684         --with-bz2=shared \
685         --with-ctype=shared \
686         --with-mhash=shared \
687         --with-curl=shared \
688         --with-gmp=shared \
689         %{?bcond_on_openssl:--with-openssl} \
690         --with-unixODBC=shared \
691         %{?bcond_on_oracle:--with-oracle=shared} \
692         %{?bcond_on_oci8:--with-oci8=shared} \
693         --without-db2 
694
695
696
697 # TODO --with-pspell=/usr,shared (pspell missing)
698
699
700 # --with-dom need libxml >= 2.2.7 \
701
702 %{__make}
703
704 %install
705 rm -rf $RPM_BUILD_ROOT
706 install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache},%{_sysconfdir}/{apache,cgi}} \
707                 $RPM_BUILD_ROOT/home/httpd/html/{icons,docs,docs/php4-doc} \
708                 $RPM_BUILD_ROOT/%{_sbindir}
709
710 %{__make} install DESTDIR=$RPM_BUILD_ROOT INSTALL_IT="install .libs/*.so $RPM_BUILD_ROOT%{_libdir}/apache/"
711 #exit 1
712 #install .libs/*.so     $RPM_BUILD_ROOT%{_pkglibdir}
713 #install modules/*.so   $RPM_BUILD_ROOT%{_pkglibdir}/php
714
715 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/apache/php.ini
716 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
717 install %{SOURCE5} $RPM_BUILD_ROOT/%{_sbindir}
718
719 tar zxf %{SOURCE4} -C $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc
720 ln -s manual.html $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc/index.html
721
722 install %{SOURCE1} .
723 gzip -9nf CODING_STANDARDS CREDITS FUNCTION_LIST.txt \
724       EXTENSIONS NEWS TODO* LICENSE Zend/LICENSE \
725       Zend/ZEND_CHANGES README.SELF-CONTAINED-EXTENSIONS README.EXT_SKEL
726
727 %post
728 /usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
729 perl -pi -e 's|^#AddType application/x-httpd-php .php|AddType application/x-httpd-php .php|'
730 if [ -f /var/lock/subsys/httpd ]; then
731         /etc/rc.d/init.d/httpd restart 1>&2
732 fi
733
734 %postun
735 perl -pi -e 's|^AddType application/x-httpd-php .php|#AddType application/x-httpd-php .php|'
736 if [ -f /var/lock/subsys/httpd ]; then
737       /etc/rc.d/init.d/httpd restart 1>&2
738 fi
739
740 %preun
741 if [ "$1" = "0" ]; then
742         /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
743         if [ -f /var/lock/subsys/httpd ]; then
744                 /etc/rc.d/init.d/httpd restart 1>&2
745         fi
746 fi
747
748
749 %post bcmath
750 %{_sbindir}/php-module-install install bcmath %{_sysconfdir}/apache/php.ini
751
752 %preun bcmath
753 if [ "$1" = "0" ]; then
754         %{_sbindir}/php-module-install remove bcmath %{_sysconfdir}/apache/php.ini
755 fi
756
757 %post calendar
758 %{_sbindir}/php-module-install install calendar %{_sysconfdir}/apache/php.ini
759
760 %preun calendar
761 if [ "$1" = "0" ]; then
762         %{_sbindir}/php-module-install remove calendar %{_sysconfdir}/apache/php.ini
763 fi
764
765 %post dba
766 %{_sbindir}/php-module-install install dba %{_sysconfdir}/apache/php.ini
767
768 %preun dba
769 if [ "$1" = "0" ]; then
770         %{_sbindir}/php-module-install remove dba %{_sysconfdir}/apache/php.ini
771 fi
772
773 %post dbase
774 %{_sbindir}/php-module-install install dbase %{_sysconfdir}/apache/php.ini
775
776 %preun dbase
777 if [ "$1" = "0" ]; then
778         %{_sbindir}/php-module-install remove dbase %{_sysconfdir}/apache/php.ini
779 fi
780
781 %post exif
782 %{_sbindir}/php-module-install install exif %{_sysconfdir}/apache/php.ini
783
784 %preun exif
785 if [ "$1" = "0" ]; then
786         %{_sbindir}/php-module-install remove exif %{_sysconfdir}/apache/php.ini
787 fi
788
789 %post filepro
790 %{_sbindir}/php-module-install install filepro %{_sysconfdir}/apache/php.ini
791
792 %preun filepro
793 if [ "$1" = "0" ]; then
794         %{_sbindir}/php-module-install remove filepro %{_sysconfdir}/apache/php.ini
795 fi
796
797 %post ftp
798 %{_sbindir}/php-module-install install ftp %{_sysconfdir}/apache/php.ini
799
800 %preun ftp
801 if [ "$1" = "0" ]; then
802         %{_sbindir}/php-module-install remove ftp %{_sysconfdir}/apache/php.ini
803 fi
804
805 %post gd
806 %{_sbindir}/php-module-install install gd %{_sysconfdir}/apache/php.ini
807
808 %preun gd
809 if [ "$1" = "0" ]; then
810         %{_sbindir}/php-module-install remove gd %{_sysconfdir}/apache/php.ini
811 fi
812
813 %post gettext
814 %{_sbindir}/php-module-install install gettext %{_sysconfdir}/apache/php.ini
815
816 %preun gettext
817 if [ "$1" = "0" ]; then
818         %{_sbindir}/php-module-install remove gettext %{_sysconfdir}/apache/php.ini
819 fi
820
821 %post imap
822 %{_sbindir}/php-module-install install imap %{_sysconfdir}/apache/php.ini
823
824 %preun imap
825 if [ "$1" = "0" ]; then
826         %{_sbindir}/php-module-install remove imap %{_sysconfdir}/apache/php.ini
827 fi
828
829 %if %{?bond_on_java:1}%{!?bond_on_java:0}
830 %post java
831 %{_sbindir}/php-module-install install libphp_java %{_sysconfdir}/apache/php.ini
832
833 %preun java
834 if [ "$1" = "0" ]; then
835         %{_sbindir}/php-module-install remove libphp_java %{_sysconfdir}/apache/php.ini
836 fi
837 %endif
838
839 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
840 %post ldap
841 %{_sbindir}/php-module-install install ldap %{_sysconfdir}/apache/php.ini
842
843 %preun ldap
844 if [ "$1" = "0" ]; then
845         %{_sbindir}/php-module-install remove ldap %{_sysconfdir}/apache/php.ini
846 fi
847 %endif
848
849 %post mcrypt
850 %{_sbindir}/php-module-install install mcrypt %{_sysconfdir}/apache/php.ini
851
852 %preun mcrypt
853 if [ "$1" = "0" ]; then
854         %{_sbindir}/php-module-install remove mcrypt %{_sysconfdir}/apache/php.ini
855 fi
856
857 %post mhash
858 %{_sbindir}/php-module-install install mhash %{_sysconfdir}/apache/php.ini
859
860 %preun mhash
861 if [ "$1" = "0" ]; then
862         %{_sbindir}/php-module-install remove mhash %{_sysconfdir}/apache/php.ini
863 fi
864
865 %post mysql
866 %{_sbindir}/php-module-install install mysql %{_sysconfdir}/apache/php.ini
867
868 %preun mysql
869 if [ "$1" = "0" ]; then
870         %{_sbindir}/php-module-install remove mysql %{_sysconfdir}/apache/php.ini
871 fi
872
873 %if %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
874 %post oci8
875 %{_sbindir}/php-module-install install oci8 %{_sysconfdir}/apache/php.ini
876
877 %preun oci8
878 if [ "$1" = "0" ]; then
879         %{_sbindir}/php-module-install remove oci8 %{_sysconfdir}/apache/php.ini
880 fi
881 %endif
882
883 %post odbc
884 %{_sbindir}/php-module-install install odbc %{_sysconfdir}/apache/php.ini
885
886 %preun odbc
887 if [ "$1" = "0" ]; then
888         %{_sbindir}/php-module-install remove odbc %{_sysconfdir}/apache/php.ini
889 fi
890
891 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
892 %post oracle
893 %{_sbindir}/php-module-install install oracle %{_sysconfdir}/apache/php.ini
894
895 %preun oracle
896 if [ "$1" = "0" ]; then
897         %{_sbindir}/php-module-install remove oracle %{_sysconfdir}/apache/php.ini
898 fi
899 %endif
900
901 %post pcre
902 %{_sbindir}/php-module-install install pcre %{_sysconfdir}/apache/php.ini
903
904 %preun pcre
905 if [ "$1" = "0" ]; then
906         %{_sbindir}/php-module-install remove pcre %{_sysconfdir}/apache/php.ini
907 fi
908
909 %post pgsql
910 %{_sbindir}/php-module-install install pgsql %{_sysconfdir}/apache/php.ini
911
912 %preun pgsql
913 if [ "$1" = "0" ]; then
914         %{_sbindir}/php-module-install remove pgsql %{_sysconfdir}/apache/php.ini
915 fi
916
917 %post posix
918 %{_sbindir}/php-module-install install posix %{_sysconfdir}/apache/php.ini
919
920 %preun posix
921 if [ "$1" = "0" ]; then
922         %{_sbindir}/php-module-install remove posix %{_sysconfdir}/apache/php.ini
923 fi
924
925 %post recode
926 %{_sbindir}/php-module-install install recode %{_sysconfdir}/apache/php.ini
927
928 %preun recode
929 if [ "$1" = "0" ]; then
930         %{_sbindir}/php-module-install remove recode %{_sysconfdir}/apache/php.ini
931 fi
932
933 %post session
934 %{_sbindir}/php-module-install install session %{_sysconfdir}/apache/php.ini
935
936 %preun session
937 if [ "$1" = "0" ]; then
938         %{_sbindir}/php-module-install remove session %{_sysconfdir}/apache/php.ini
939 fi
940
941 %post snmp
942 %{_sbindir}/php-module-install install snmp %{_sysconfdir}/apache/php.ini
943
944 %preun snmp
945 if [ "$1" = "0" ]; then
946         %{_sbindir}/php-module-install remove snmp %{_sysconfdir}/apache/php.ini
947 fi
948
949 %post sockets
950 %{_sbindir}/php-module-install install sockets %{_sysconfdir}/apache/php.ini
951
952 %preun sockets
953 if [ "$1" = "0" ]; then
954         %{_sbindir}/php-module-install remove sockets %{_sysconfdir}/apache/php.ini
955 fi
956
957 %post sysvsem
958 %{_sbindir}/php-module-install install sysvsem %{_sysconfdir}/apache/php.ini
959
960 %preun sysvsem
961 if [ "$1" = "0" ]; then
962         %{_sbindir}/php-module-install remove sysvsem %{_sysconfdir}/apache/php.ini
963 fi
964
965 %post sysvshm
966 %{_sbindir}/php-module-install install sysvshm %{_sysconfdir}/apache/php.ini
967
968 %preun sysvshm
969 if [ "$1" = "0" ]; then
970         %{_sbindir}/php-module-install remove sysvshm %{_sysconfdir}/apache/php.ini
971 fi
972
973 %post xml
974 %{_sbindir}/php-module-install install xml %{_sysconfdir}/apache/php.ini
975
976 %preun xml
977 if [ "$1" = "0" ]; then
978         %{_sbindir}/php-module-install remove xml %{_sysconfdir}/apache/php.ini
979 fi
980
981 %post yp
982 %{_sbindir}/php-module-install install yp %{_sysconfdir}/apache/php.ini
983
984 %preun yp
985 if [ "$1" = "0" ]; then
986         %{_sbindir}/php-module-install remove yp %{_sysconfdir}/apache/php.ini
987 fi
988
989 %post zlib
990 %{_sbindir}/php-module-install install zlib %{_sysconfdir}/apache/php.ini
991
992 %preun zlib
993 if [ "$1" = "0" ]; then
994         %{_sbindir}/php-module-install remove zlib %{_sysconfdir}/apache/php.ini
995 fi
996
997 %clean
998 rm -rf $RPM_BUILD_ROOT
999
1000 %files
1001 %defattr(644,root,root,755)
1002 %doc {CODING_STANDARDS,CREDITS,FUNCTION_LIST.txt,Zend/ZEND_CHANGES}.gz
1003 %doc {LICENSE,Zend/LICENSE,EXTENSIONS,NEWS,TODO*}.gz  
1004 %doc {README.EXT_SKEL,README.SELF-CONTAINED-EXTENSIONS}.gz
1005
1006 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/apache/*
1007
1008
1009 /home/httpd/html/icons/*
1010
1011 %attr(755,root,root) %{_libdir}/apache/libphp4.so
1012 %attr(755,root,root) %{_sbindir}/*
1013
1014 %dir %{_libdir}/php
1015 %dir %{_libdir}/php/extensions
1016 %dir %{extensionsdir}
1017
1018 %files devel
1019 %defattr(644,root,root,755)
1020 %{_includedir}/php4
1021 %{_libdir}/php4/build
1022 %attr(755,root,root) %{_bindir}/phpextdist
1023 %attr(755,root,root) %{_bindir}/phpize
1024 %attr(755,root,root) %{_bindir}/php-config
1025
1026 %files pear
1027 %defattr(644,root,root,755)
1028 %attr(755,root,root) %{_bindir}/pear
1029 %{_libdir}/php/Benchmark
1030 %{_libdir}/php/Crypt
1031 %{_libdir}/php/Date
1032 %{_libdir}/php/DB
1033 %{_libdir}/php/File
1034 %{_libdir}/php/HTML
1035 %{_libdir}/php/Mail
1036 %{_libdir}/php/Math
1037 %{_libdir}/php/Net
1038 %{_libdir}/php/Payment
1039 %{_libdir}/php/PEAR
1040 %{_libdir}/php/XML
1041 %{_libdir}/php/*.php
1042
1043
1044 %files mysql
1045 %defattr(644,root,root,755)
1046 %attr(755,root,root) %{extensionsdir}/mysql.*
1047
1048 %files pgsql
1049 %defattr(644,root,root,755)
1050 %attr(755,root,root) %{extensionsdir}/pgsql.so
1051
1052 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
1053 %files oracle
1054 %defattr(644,root,root,755)
1055 %attr(755,root,root) %{extensionsdir}/oracle.so
1056 %endif
1057
1058 %if  %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
1059 %files oci8
1060 %defattr(644,root,root,755)
1061 %attr(755,root,root) %{extensionsdir}/oci8.so
1062 %endif
1063
1064 %files gd
1065 %defattr(644,root,root,755)
1066 %attr(755,root,root) %{extensionsdir}/gd.so
1067
1068 %files xml
1069 %defattr(644,root,root,755)
1070 %attr(755,root,root) %{extensionsdir}/xml.so
1071
1072 %files dba
1073 %defattr(644,root,root,755)
1074 %attr(755,root,root) %{extensionsdir}/dba.so
1075
1076 %files dbase
1077 %defattr(644,root,root,755)
1078 %attr(755,root,root) %{extensionsdir}/dbase.so
1079
1080 %files filepro
1081 %defattr(644,root,root,755)
1082 %attr(755,root,root) %{extensionsdir}/filepro.so
1083
1084 %files pcre
1085 %defattr(644,root,root,755)
1086 %attr(755,root,root) %{extensionsdir}/pcre.so
1087
1088 %files posix
1089 %defattr(644,root,root,755)
1090 %attr(755,root,root) %{extensionsdir}/posix.so
1091
1092 %files sysvsem
1093 %defattr(644,root,root,755)
1094 %attr(755,root,root) %{extensionsdir}/sysvsem.so
1095
1096 %files sysvshm
1097 %defattr(644,root,root,755)
1098 %attr(755,root,root) %{extensionsdir}/sysvshm.so
1099
1100 %files yp
1101 %defattr(644,root,root,755)
1102 %attr(755,root,root) %{extensionsdir}/yp.so
1103
1104 %files calendar
1105 %defattr(644,root,root,755)
1106 %attr(755,root,root) %{extensionsdir}/calendar.so
1107
1108 %files bcmath
1109 %defattr(644,root,root,755)
1110 %attr(755,root,root) %{extensionsdir}/bcmath.so
1111
1112 %files ftp
1113 %defattr(644,root,root,755)
1114 %attr(755,root,root) %{extensionsdir}/ftp.so
1115
1116 %files zlib
1117 %defattr(644,root,root,755)
1118 %attr(755,root,root) %{extensionsdir}/zlib.so
1119
1120 %files exif
1121 %defattr(644,root,root,755)
1122 %attr(755,root,root) %{extensionsdir}/exif.so
1123
1124 %files recode
1125 %defattr(644,root,root,755)
1126 %attr(755,root,root) %{extensionsdir}/recode.so
1127
1128 #%files session
1129 #%defattr(644,root,root,755)
1130 #%attr(755,root,root) %{extensionsdir}/session.so
1131
1132 %files gettext
1133 %defattr(644,root,root,755)
1134 %attr(755,root,root) %{extensionsdir}/gettext.so
1135
1136 %files imap
1137 %defattr(644,root,root,755)
1138 %attr(755,root,root) %{extensionsdir}/imap.so
1139
1140 %files snmp
1141 %defattr(644,root,root,755)
1142 %attr(755,root,root) %{extensionsdir}/snmp.so
1143
1144 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
1145 %files java
1146 %defattr(644,root,root,755)
1147 %attr(755,root,root) %{extensionsdir}/libphp_java.so
1148 %endif
1149
1150 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
1151 %files ldap
1152 %defattr(644,root,root,755)
1153 %attr(755,root,root) %{extensionsdir}/ldap.*
1154 %endif
1155
1156 %files sockets
1157 %defattr(644,root,root,755)
1158 %attr(755,root,root) %{extensionsdir}/sockets.so
1159
1160 %files mcrypt
1161 %defattr(644,root,root,755)
1162 %attr(755,root,root) %{extensionsdir}/mcrypt.so
1163
1164 %files mhash
1165 %defattr(644,root,root,755)
1166 %attr(755,root,root) %{extensionsdir}/mhash.so
1167
1168 %files odbc
1169 %defattr(644,root,root,755)
1170 %attr(755,root,root) %{extensionsdir}/odbc.so
1171
1172 %files doc
1173 %defattr(644,root,root,755)
1174 /home/httpd/html/docs/php4-doc
This page took 0.105776 seconds and 4 git commands to generate.