]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- removed php-no_libnsl.patch
[packages/php.git] / php.spec
1 #
2 #   oracle - with oracle support 
3 #   oci8   - with oci8 support
4 #       
5 Summary:        The PHP HTML-embedded scripting language for use with Apache
6 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache
7 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
8 Name:           php
9 Version:        4.0.4pl1
10 Release:        0.6
11 Epoch:          1
12 Group:          Libraries
13 Group(de):      Libraries
14 Group(fr):      Librairies
15 Group(pl):      Biblioteki
16 License:        The PHP license (see "LICENSE" file included in distribution)
17 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
18 Source1:        FAQ.php
19 Source2:        %{name}.ini
20 Source3:        zend.gif
21 Source4:        http://www.php.net/distributions/manual.tar.gz
22 Source5:        php-module-install
23 Patch0:         %{name}-imap.patch
24 Patch1:         %{name}-mysql-socket.patch
25 Patch2:         %{name}-mail.patch
26 #Patch5:        %{name}-no_libnsl.patch
27 Patch6:         %{name}-DESTDIR.patch
28 Patch7:         %{name}-gd-shared.patch
29 Patch8:         %{name}-apache-fixes.patch
30 #Patch9:                %{name}-system-expat.patch
31 Icon:           php4.gif
32 URL:            http://www.php.net/
33 BuildRequires:  apache(EAPI)-devel
34 BuildRequires:  zip
35 BuildRequires:  bison
36 BuildRequires:  flex
37 BuildRequires:  db3-devel >= 3.1.17
38 BuildRequires:  freetype-devel
39 BuildRequires:  gd-devel >= 1.8.3
40 BuildRequires:  gdbm-devel
41 BuildRequires:  imap-devel >= 4.7b-1
42 # I think jdk is better for java
43 # BuildRequires:        jdk
44 %{?bcond_on_java:BuildRequires: kaffe-devel}
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libltdl-devel
47 BuildRequires:  libpng >= 1.0.8
48 BuildRequires:  libtiff-devel
49 BuildRequires:  mm-devel >= 1.1.3
50 BuildRequires:  mysql-devel >= 3.23.32
51 %{!?bcond_off_ldap:BuildRequires: openldap-devel >= 2.0}
52 BuildRequires:  pam-devel
53 BuildRequires:  pdflib-devel >= 3.0
54 #BuildRequires: libxml-devel >= 2.0.0
55 BuildRequires:  postgresql-devel
56 BuildRequires:  recode-devel >= 3.5
57 BuildRequires:  t1lib-devel
58 BuildRequires:  unixODBC-devel
59 BuildRequires:  zlib-devel >= 1.0.9
60 BuildRequires:  ucd-snmp-devel >= 4.1
61 BuildRequires:  libmcrypt-devel >= 2.4.4
62 BuildRequires:  mhash-devel
63 BuildRequires:  bzip2-devel
64 BuildRequires:  gmp-devel
65 BuildRequires:  curl-devel
66 %if %(expr %{?bcond_on_openssl:1}%{!?bcond_on_openssl:0} + %{!?bcond_off_ldap:1}%{?bcond_off_ldap:0})
67 BuildRequires:  openssl-devel >= 0.9.6
68 %endif
69 Requires:       apache(EAPI) >= 1.3.9
70 Prereq:         perl
71 Prereq:         /usr/sbin/apxs
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     /etc/php
75 # check ZEND_MODULE_API_NO in  Zend/modules.h
76 %define         extensionsdir   %{_libdir}/php/extensions/no-debug-non-zts-20001214
77
78 %description
79 PHP is an HTML-embedded scripting language. PHP attempts to make it
80 easy for developers to write dynamically generated web pages. PHP also
81 offers built-in database integration for several commercial and
82 non-commercial database management systems, so writing a
83 database-enabled web page with PHP is fairly simple. The most common
84 use of PHP coding is probably as a replacement for CGI scripts. The
85 mod_php module enables the Apache web server to understand and process
86 the embedded PHP language in web pages. This package contains PHP
87 version %{version}. If you use applications which specifically rely on
88 PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
89 module contained in the phpfi package. If you're just starting with
90 PHP, you should install this package. You'll also need to install the
91 Apache web server.
92
93 %description -l fr
94 PHP est un langage de script embarque dans le HTM. PHP essaye de
95 rendre simple aux developpeurs d'ecrire des pages web generees
96 dynamiquement. PHP incorpore egalement une integration avec plusieurs
97 systemes de gestion de bases de donnees commerciaux et
98 non-connerciaux, qui rent facile la creation de pages web liees avec
99 des bases de donnees. L'utilisation la plus commune de PHP est
100 probablement en remplacement de scripts CGI. Le module mod_php permet
101 au serveur web apache de comprendre et de traiter le langage PHP
102 integre dans des pages web. Ce package contient PHP version
103 %{version}. Si vous utilisez des applications qui utilisent
104 specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
105 dans le package mod_php. Si vous debutez avec PHP, vous devriez
106 installer ce package. Vous aurez egalement besoin d'installer le
107 serveur web Apache.
108
109 %description -l pl
110 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
111 plikach HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP
112 (jak np. Apache), który interpretuje te polecenia. Umo¿liwia to
113 tworzenie dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona
114 zosta³a z jêzyków: C, Java i Perl.
115
116 %package mysql
117 Summary:        MySQL database module for PHP
118 Summary(pl):    Modu³ bazy danych MySQL dla PHP
119 Group:          Libraries
120 Group(de):      Libraries
121 Group(fr):      Librairies
122 Group(pl):      Biblioteki
123 PreReq: %{name} = %{version}
124
125 %description mysql
126 This is a dynamic shared object (DSO) for Apache that will add MySQL
127 database support to PHP. If you need back-end support for MySQL, you
128 should install this package in addition to the main %{name} package.
129
130 %description mysql -l pl
131 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych MySQL.
132
133
134 %package pgsql
135 Summary:        PostgreSQL database module for PHP
136 Summary(pl):    Modu³ bazy danych PostgreSQL dla PHP
137 Group:          Libraries
138 Group(de):      Libraries
139 Group(fr):      Librairies
140 Group(pl):      Biblioteki
141 PreReq: %{name} = %{version}
142
143 %description pgsql
144 This is a dynamic shared object (DSO) for Apache that will add
145 PostgreSQL database support to PHP. If you need back-end support for
146 PostgreSQL, you should install this package in addition to the main
147 %{name} package.
148
149 %description pgsql -l pl
150 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych PostgreSQL.
151
152 %package oci8
153 Summary:        Oracle 8 database module for PHP
154 Summary(pl):    Modu³ bazy danych Oracle 8 dla PHP
155 Group:          Libraries
156 Group(de):      Libraries
157 Group(fr):      Librairies
158 Group(pl):      Biblioteki
159 PreReq: %{name} = %{version}
160 Autoreq:        false
161
162 %description oci8
163 This is a dynamic shared object (DSO) for Apache that will add Oracle
164 8 database support to PHP. If you need back-end support for Oracle 8,
165 you should install this package in addition to the main %{name}
166 package.
167
168 %description oci8 -l pl
169 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 8. }
170
171 %package oracle
172 Summary:        Oracle 7 database module for PHP
173 Summary(pl):    Modu³ bazy danych Oracle 7 dla PHP
174 Group:          Libraries
175 Group(de):      Libraries
176 Group(fr):      Librairies
177 Group(pl):      Biblioteki
178 PreReq: %{name} = %{version}
179 Autoreq:        false
180
181 %description oracle
182 This is a dynamic shared object (DSO) for Apache that will add Oracle
183 7 database support to PHP. If you need back-end support for Oracle 7,
184 you should install this package in addition to the main %{name}
185 package.
186
187 %description oracle -l pl
188 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 7. }
189
190 %package gd
191 Summary:        GD extension module for PHP
192 Summary:        Modu³ GD dla PHP
193 Group:          Libraries
194 Group(de):      Libraries
195 Group(fr):      Librairies
196 Group(pl):      Biblioteki
197 PreReq: %{name} = %{version}
198
199 %description gd
200 This is a dynamic shared object (DSO) for Apache that will add GD
201 support to PHP. You should install this package in addition to the
202 main %{name} package if you want to create and manipulate images with
203 PHP.
204
205 %description gd -l pl
206
207 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
208 %package java
209 Summary:        Java extension module for PHP
210 Summary(pl):    Modu³ Javy dla PHP
211 Group:          Libraries
212 Group(de):      Libraries
213 Group(fr):      Librairies
214 Group(pl):      Biblioteki
215 PreReq: %{name} = %{version}
216
217 %description java
218 This is a dynamic shared object (DSO) for Apache that will add JAVA
219 support to PHP. This extension provides a simple and effective means
220 for creating and invoking methods on Java objects from PHP.
221
222 %description java -l pl
223 %endif
224
225 %package xml
226 Summary:        XML extension module for PHP
227 Summary(pl):    Modu³ XML dla PHP
228 Group:          Libraries
229 Group(de):      Libraries
230 Group(fr):      Librairies
231 Group(pl):      Biblioteki
232 PreReq: %{name} = %{version}
233
234 %description xml
235 This is a dynamic shared object (DSO) for Apache that will add XML
236 support to PHP. This extension lets you create XML parsers and then
237 define handlers for different XML events. If you want to be able to
238 parse XML documents you should install this package in addition to the
239 main %{name} package.
240
241 #%description xml -l pl
242
243 %package dba
244 Summary:        DBA extension module for PHP
245 Summary(pl):    Modu³ DBA dla PHP
246 Group:          Libraries
247 Group(de):      Libraries
248 Group(fr):      Librairies
249 Group(pl):      Biblioteki
250 PreReq: %{name} = %{version}
251
252 %description dba
253 This is a dynamic shared object (DSO) for Apache that will add
254 flat-file databases (DBA) support to PHP.
255
256 #%description dba -l pl
257
258 %package odbc
259 Summary:        ODBC extension module for PHP
260 Summary(pl):    Modu³ ODBC dla PHP
261 Group:          Libraries
262 Group(de):      Libraries
263 Group(fr):      Librairies
264 Group(pl):      Biblioteki
265 PreReq: %{name} = %{version}
266
267 %description odbc
268 This is a dynamic shared object (DSO) for Apache that will add
269 ODBC support to PHP.
270
271 #%description odbc -l pl
272
273 %package calendar
274 Summary:        Calendar extension module for PHP
275 Summary(pl):    Modu³ funkcji kalendarza dla PHP
276 Group:          Libraries
277 Group(de):      Libraries
278 Group(fr):      Librairies
279 Group(pl):      Biblioteki
280 PreReq: %{name} = %{version}
281
282 %description calendar
283 This is a dynamic shared object (DSO) for Apache that will add
284 calendar support to PHP.
285
286 #%description calendar -l pl
287
288 %package dbase
289 Summary:        DBase extension module for PHP
290 Summary(pl):    Modu³ DBase dla PHP
291 Group:          Libraries
292 Group(de):      Libraries
293 Group(fr):      Librairies
294 Group(pl):      Biblioteki
295 PreReq: %{name} = %{version}
296
297 %description dbase
298 This is a dynamic shared object (DSO) for Apache that will add DBase
299 support to PHP.
300
301 #%description dbase -l pl
302
303 %package filepro
304 Summary:        FilePro extension module for PHP
305 Summary(pl):    Modu³ FilePro dla PHP
306 Group:          Libraries
307 Group(de):      Libraries
308 Group(fr):      Librairies
309 Group(pl):      Biblioteki
310 PreReq: %{name} = %{version}
311
312 %description filepro
313 This is a dynamic shared object (DSO) for Apache that will add FilePro
314 support to PHP.
315
316 #%description filepro -l pl
317
318 %package posix
319 Summary:        POSIX extension module for PHP
320 Summary(pl):    Modu³ POSIX dla PHP
321 Group:          Libraries
322 Group(de):      Libraries
323 Group(fr):      Librairies
324 Group(pl):      Biblioteki
325 PreReq: %{name} = %{version}
326
327 %description posix
328 This is a dynamic shared object (DSO) for Apache that will add POSIX
329 functions support to PHP.
330
331 #%description posix -l pl
332
333 %package pcre
334 Summary:        PCRE extension module for PHP
335 Summary(pl):    Modu³ PCRE dla PHP
336 Group:          Libraries
337 Group(de):      Libraries
338 Group(fr):      Librairies
339 Group(pl):      Biblioteki
340 PreReq: %{name} = %{version}
341
342 %description pcre
343 This is a dynamic shared object (DSO) for Apache that will add Perl
344 Compatible Regular Expression support to PHP.
345
346 #%description pcre -l pl
347
348 %package sysvsem
349 Summary:        SysV sem extension module for PHP
350 Summary(pl):    Modu³ SysV sem dla PHP
351 Group:          Libraries
352 Group(de):      Libraries
353 Group(fr):      Librairies
354 Group(pl):      Biblioteki
355 PreReq: %{name} = %{version}
356
357 %description sysvsem
358 This is a dynamic shared object (DSO) for Apache that will add SysV
359 semafores support to PHP.
360
361 #%description sysvsem -l pl
362
363 %package sysvshm
364 Summary:        SysV shm extension module for PHP
365 Summary(pl):    Modu³ SysV shm dla PHP
366 Group:          Libraries
367 Group(de):      Libraries
368 Group(fr):      Librairies
369 Group(pl):      Biblioteki
370 PreReq: %{name} = %{version}
371
372 %description sysvshm
373 This is a dynamic shared object (DSO) for Apache that will add SysV
374 Shared Memory support to PHP.
375
376 #%description sysvshm -l pl
377
378 %package yp
379 Summary:        NIS (yp) extension module for PHP
380 Summary(pl):    Modu³ NIS (yp) dla PHP
381 Group:          Libraries
382 Group(de):      Libraries
383 Group(fr):      Librairies
384 Group(pl):      Biblioteki
385 PreReq: %{name} = %{version}
386
387 %description yp
388 This is a dynamic shared object (DSO) for Apache that will add NIS
389 (Yellow Pages) support to PHP.
390
391 #%description yp -l pl
392
393 %package bcmath
394 Summary:        bcmath extension module for PHP
395 Summary(pl):    Modu³ bcmath dla PHP
396 Group:          Libraries
397 Group(de):      Libraries
398 Group(fr):      Librairies
399 Group(pl):      Biblioteki
400 PreReq: %{name} = %{version}
401
402 %description bcmath
403 This is a dynamic shared object (DSO) for Apache that will add bc
404 style precision math functions support to PHP.
405
406 #%description bcmath -l pl
407
408 %package ftp
409 Summary:        FTP extension module for PHP
410 Summary(pl):    Modu³ FTP dla PHP
411 Group:          Libraries
412 Group(de):      Libraries
413 Group(fr):      Librairies
414 Group(pl):      Biblioteki
415 PreReq: %{name} = %{version}
416
417 %description ftp
418 This is a dynamic shared object (DSO) for Apache that will add FTP
419 support to PHP.
420
421 #%description ftp -l pl
422
423 %package zlib
424 Summary:        Zlib extension module for PHP
425 Summary(pl):    Modu³ zlib dla PHP
426 Group:          Libraries
427 Group(de):      Libraries
428 Group(fr):      Librairies
429 Group(pl):      Biblioteki
430 PreReq: %{name} = %{version}
431
432 %description zlib
433 This is a dynamic shared object (DSO) for Apache that will add
434 commpresion (zlib) support to PHP.
435
436 #%description zlib -l pl
437
438 %package exif
439 Summary:        exifextension module for PHP
440 Summary(pl):    Modu³ exif dla PHP
441 Group:          Libraries
442 Group(de):      Libraries
443 Group(fr):      Librairies
444 Group(pl):      Biblioteki
445 PreReq: %{name} = %{version}
446
447 %description exif
448 This is a dynamic shared object (DSO) for Apache that will add exif
449 support to PHP.
450
451 #%description exif -l pl
452
453 %package recode
454 Summary:        recodeextension module for PHP
455 Summary(pl):    Modu³ recode dla PHP
456 Group:          Libraries
457 Group(de):      Libraries
458 Group(fr):      Librairies
459 Group(pl):      Biblioteki
460 PreReq: %{name} = %{version}
461
462 %description recode
463 This is a dynamic shared object (DSO) for Apache that will add recode
464 support to PHP.
465
466 #%description recode -l pl
467
468 %package session
469 Summary:        sessionextension module for PHP
470 Summary(pl):    Modu³ session dla PHP
471 Group:          Libraries
472 Group(de):      Libraries
473 Group(fr):      Librairies
474 Group(pl):      Biblioteki
475 PreReq: %{name} = %{version}
476
477 %description session
478 This is a dynamic shared object (DSO) for Apache that will add session
479 support to PHP.
480
481 #%description session -l pl
482
483 %package gettext
484 Summary:        gettextextension module for PHP
485 Summary(pl):    Modu³ gettext dla PHP
486 Group:          Libraries
487 Group(de):      Libraries
488 Group(fr):      Librairies
489 Group(pl):      Biblioteki
490 PreReq: %{name} = %{version}
491
492 %description gettext
493 This is a dynamic shared object (DSO) for Apache that will add gettext
494 support to PHP.
495
496 #%description gettext -l pl
497
498
499 %package snmp
500 Summary:        snmpextension module for PHP
501 Summary(pl):    Modu³ snmp dla PHP
502 Group:          Libraries
503 Group(de):      Libraries
504 Group(fr):      Librairies
505 Group(pl):      Biblioteki
506 PreReq: %{name} = %{version}
507
508 %description snmp
509 This is a dynamic shared object (DSO) for Apache that will add snmp
510 support to PHP.
511
512 #%description snmp -l pl
513
514 %package imap
515 Summary:        imapextension module for PHP
516 Summary(pl):    Modu³ imap dla PHP
517 Group:          Libraries
518 Group(de):      Libraries
519 Group(fr):      Librairies
520 Group(pl):      Biblioteki
521 PreReq: %{name} = %{version}
522
523 %description imap
524 This is a dynamic shared object (DSO) for Apache that will add imap
525 support to PHP.
526
527 #%description imap -l pl
528
529 %package ldap
530 Summary:        LDAP extension module for PHP
531 Summary(pl):    Modu³ LDAP dla PHP
532 Group:          Libraries
533 Group(de):      Libraries
534 Group(fr):      Librairies
535 Group(pl):      Biblioteki
536 PreReq: %{name} = %{version}
537
538 %description ldap
539 This is a dynamic shared object (DSO) for Apache that will add LDAP
540 support to PHP.
541
542 #%description ldap -l pl
543
544 %package sockets
545 Summary:        sockets extension module for PHP
546 Summary(pl):    Modu³ socket dla PHP
547 Group:          Libraries
548 Group(de):      Libraries
549 Group(fr):      Librairies
550 Group(pl):      Biblioteki
551 PreReq: %{name} = %{version}
552
553 %description sockets
554 This is a dynamic shared object (DSO) for Apache that will add sockets
555 support to PHP.
556
557 #%description sockets -l pl
558
559 %package mcrypt
560 Summary:        mcrypt extension module for PHP
561 Summary(pl):    Modu³ mcrypt dla PHP
562 Group:          Libraries
563 Group(de):      Libraries
564 Group(fr):      Librairies
565 Group(pl):      Biblioteki
566 PreReq: %{name} = %{version}
567
568 %description mcrypt
569 This is a dynamic shared object (DSO) for Apache that will add mcrypt
570 support to PHP.
571
572 #%description mcrypt -l pl
573
574 %package mhash
575 Summary:        mhash extension module for PHP
576 Summary(pl):    Modu³ mhash dla PHP
577 Group:          Libraries
578 Group(de):      Libraries
579 Group(fr):      Librairies
580 Group(pl):      Biblioteki
581 PreReq: %{name} = %{version}
582
583 %description mhash
584 This is a dynamic shared object (DSO) for Apache that will add mhash
585 support to PHP.
586
587 #%description mcrypt -l pl
588
589
590 %package doc
591 Summary:        Online manual for PHP
592 Summary(pl):    Dokumentacja dla PHP
593 Group:          Networking/Daemons
594 Group(de):      Netzwerkwesen/Server
595 Group(pl):      Sieciowe/Serwery
596
597 %description doc
598 Comprehensive documentation for PHP, viewable through your web
599 server, too!
600
601 %description doc -l pl
602 Dokumentacja dla pakietu PHP. Mo¿na j± równie¿ ogl±daæ poprzez serwer
603 WWW.
604
605 %package pear
606 Summary:        PEAR
607 Group:          Development/Languages/PHP
608
609 %description pear
610 PEAR.
611
612 %package devel
613 Summary:        Files for PHP modules development
614 Group:          Development/Languages/PHP
615
616 %description devel
617 Files for PHP modules development.
618
619 %prep
620 %setup  -q
621 %patch0 -p1
622 %patch1 -p1
623 %patch2 -p1
624 #%patch5 -p1
625 %patch6 -p1
626 %patch7 -p1
627 %patch8 -p1
628 #%patch9 -p1
629
630
631 %build
632 CFLAGS="$RPM_OPT_FLAGS -DEAPI -I/usr/X11R6/include"; export CFLAGS
633 ./buildconf
634 %configure \
635         --with-apxs=/usr/sbin/apxs \
636         --with-config-file-path=%{_sysconfdir}/apache \
637         --with-exec-dir=%{_bindir} \
638         --disable-debug \
639         --enable-magic-quotes \
640         --enable-shared \
641         --enable-track-vars \
642         --enable-safe-mode \
643         --enable-trans-sid \
644         --enable-sysvsem=shared \
645         --enable-sysvshm=shared \
646         --enable-shmop=shared \
647         --enable-session \
648         --enable-exif=shared \
649         --with-regex=system \
650         --with-gettext=shared \
651         %{!?bcond_off_ldap:--with-ldap=shared} \
652         --with-mysql=shared,/usr \
653         --with-mysql-sock=/var/lib/mysql/mysql.sock \
654         --with-gd=shared \
655          --enable-gd-imgstrttf \
656         --with-dbase=shared \
657         --with-filepro=shared \
658         --enable-ftp=shared \
659         --with-hyperwave \
660         --with-pdflib=shared \
661         --with-cpdflib=shared \
662         %{?bcond_on_java:--with-java} \
663         --with-pgsql=shared,/usr \
664         --with-imap=shared \
665         --enable-bcmath=shared \
666         --enable-calendar=shared \
667         --with-mm \
668         --with-pcre-regex=shared \
669         --enable-posix=shared \
670         --with-ttf \
671         --with-t1lib \
672         --with-recode=shared \
673         --enable-ucd-snmp-hack \
674         --enable-dba=shared \
675         --with-snmp=shared \
676         --with-openssl \
677         --with-gdbm \
678         --with-db3 \
679         --enable-yp=shared \
680         --with-xml=shared \
681         --enable-xml=shared \
682         --with-zlib=shared \
683         --with-mcrypt=shared \
684         --enable-sockets=shared \
685         --with-bz2=shared \
686         --with-ctype=shared \
687         --with-mhash=shared \
688         --with-curl=shared \
689         --with-gmp=shared \
690         %{?bcond_on_openssl:--with-openssl} \
691         --with-unixODBC=shared \
692         %{?bcond_on_oracle:--with-oracle=shared} \
693         %{?bcond_on_oci8:--with-oci8=shared} \
694         --without-db2 
695
696
697
698 # TODO --with-pspell=/usr,shared (pspell missing)
699
700
701 # --with-dom need libxml >= 2.2.7 \
702
703 %{__make}
704
705 %install
706 rm -rf $RPM_BUILD_ROOT
707 install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache},%{_sysconfdir}/{apache,cgi}} \
708                 $RPM_BUILD_ROOT/home/httpd/html/{icons,docs,docs/php4-doc} \
709                 $RPM_BUILD_ROOT/%{_sbindir}
710
711 %{__make} install DESTDIR=$RPM_BUILD_ROOT INSTALL_IT="install .libs/*.so $RPM_BUILD_ROOT%{_libdir}/apache/"
712 #exit 1
713 #install .libs/*.so     $RPM_BUILD_ROOT%{_pkglibdir}
714 #install modules/*.so   $RPM_BUILD_ROOT%{_pkglibdir}/php
715
716 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/apache/php.ini
717 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
718 install %{SOURCE5} $RPM_BUILD_ROOT/%{_sbindir}
719
720 tar zxf %{SOURCE4} -C $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc
721 ln -s manual.html $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc/index.html
722
723 install %{SOURCE1} .
724 gzip -9nf CODING_STANDARDS CREDITS FUNCTION_LIST.txt \
725       EXTENSIONS NEWS TODO* LICENSE Zend/LICENSE \
726       Zend/ZEND_CHANGES README.SELF-CONTAINED-EXTENSIONS README.EXT_SKEL
727
728 %post
729 /usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
730 perl -pi -e 's|^#AddType application/x-httpd-php .php|AddType application/x-httpd-php .php|'
731 if [ -f /var/lock/subsys/httpd ]; then
732         /etc/rc.d/init.d/httpd restart 1>&2
733 fi
734
735 %postun
736 perl -pi -e 's|^AddType application/x-httpd-php .php|#AddType application/x-httpd-php .php|'
737 if [ -f /var/lock/subsys/httpd ]; then
738       /etc/rc.d/init.d/httpd restart 1>&2
739 fi
740
741 %preun
742 if [ "$1" = "0" ]; then
743         /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
744         if [ -f /var/lock/subsys/httpd ]; then
745                 /etc/rc.d/init.d/httpd restart 1>&2
746         fi
747 fi
748
749
750 %post bcmath
751 %{_sbindir}/php-module-install install bcmath %{_sysconfdir}/apache/php.ini
752
753 %preun bcmath
754 if [ "$1" = "0" ]; then
755         %{_sbindir}/php-module-install remove bcmath %{_sysconfdir}/apache/php.ini
756 fi
757
758 %post calendar
759 %{_sbindir}/php-module-install install calendar %{_sysconfdir}/apache/php.ini
760
761 %preun calendar
762 if [ "$1" = "0" ]; then
763         %{_sbindir}/php-module-install remove calendar %{_sysconfdir}/apache/php.ini
764 fi
765
766 %post dba
767 %{_sbindir}/php-module-install install dba %{_sysconfdir}/apache/php.ini
768
769 %preun dba
770 if [ "$1" = "0" ]; then
771         %{_sbindir}/php-module-install remove dba %{_sysconfdir}/apache/php.ini
772 fi
773
774 %post dbase
775 %{_sbindir}/php-module-install install dbase %{_sysconfdir}/apache/php.ini
776
777 %preun dbase
778 if [ "$1" = "0" ]; then
779         %{_sbindir}/php-module-install remove dbase %{_sysconfdir}/apache/php.ini
780 fi
781
782 %post exif
783 %{_sbindir}/php-module-install install exif %{_sysconfdir}/apache/php.ini
784
785 %preun exif
786 if [ "$1" = "0" ]; then
787         %{_sbindir}/php-module-install remove exif %{_sysconfdir}/apache/php.ini
788 fi
789
790 %post filepro
791 %{_sbindir}/php-module-install install filepro %{_sysconfdir}/apache/php.ini
792
793 %preun filepro
794 if [ "$1" = "0" ]; then
795         %{_sbindir}/php-module-install remove filepro %{_sysconfdir}/apache/php.ini
796 fi
797
798 %post ftp
799 %{_sbindir}/php-module-install install ftp %{_sysconfdir}/apache/php.ini
800
801 %preun ftp
802 if [ "$1" = "0" ]; then
803         %{_sbindir}/php-module-install remove ftp %{_sysconfdir}/apache/php.ini
804 fi
805
806 %post gd
807 %{_sbindir}/php-module-install install gd %{_sysconfdir}/apache/php.ini
808
809 %preun gd
810 if [ "$1" = "0" ]; then
811         %{_sbindir}/php-module-install remove gd %{_sysconfdir}/apache/php.ini
812 fi
813
814 %post gettext
815 %{_sbindir}/php-module-install install gettext %{_sysconfdir}/apache/php.ini
816
817 %preun gettext
818 if [ "$1" = "0" ]; then
819         %{_sbindir}/php-module-install remove gettext %{_sysconfdir}/apache/php.ini
820 fi
821
822 %post imap
823 %{_sbindir}/php-module-install install imap %{_sysconfdir}/apache/php.ini
824
825 %preun imap
826 if [ "$1" = "0" ]; then
827         %{_sbindir}/php-module-install remove imap %{_sysconfdir}/apache/php.ini
828 fi
829
830 %if %{?bond_on_java:1}%{!?bond_on_java:0}
831 %post java
832 %{_sbindir}/php-module-install install libphp_java %{_sysconfdir}/apache/php.ini
833
834 %preun java
835 if [ "$1" = "0" ]; then
836         %{_sbindir}/php-module-install remove libphp_java %{_sysconfdir}/apache/php.ini
837 fi
838 %endif
839
840 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
841 %post ldap
842 %{_sbindir}/php-module-install install ldap %{_sysconfdir}/apache/php.ini
843
844 %preun ldap
845 if [ "$1" = "0" ]; then
846         %{_sbindir}/php-module-install remove ldap %{_sysconfdir}/apache/php.ini
847 fi
848 %endif
849
850 %post mcrypt
851 %{_sbindir}/php-module-install install mcrypt %{_sysconfdir}/apache/php.ini
852
853 %preun mcrypt
854 if [ "$1" = "0" ]; then
855         %{_sbindir}/php-module-install remove mcrypt %{_sysconfdir}/apache/php.ini
856 fi
857
858 %post mhash
859 %{_sbindir}/php-module-install install mhash %{_sysconfdir}/apache/php.ini
860
861 %preun mhash
862 if [ "$1" = "0" ]; then
863         %{_sbindir}/php-module-install remove mhash %{_sysconfdir}/apache/php.ini
864 fi
865
866 %post mysql
867 %{_sbindir}/php-module-install install mysql %{_sysconfdir}/apache/php.ini
868
869 %preun mysql
870 if [ "$1" = "0" ]; then
871         %{_sbindir}/php-module-install remove mysql %{_sysconfdir}/apache/php.ini
872 fi
873
874 %if %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
875 %post oci8
876 %{_sbindir}/php-module-install install oci8 %{_sysconfdir}/apache/php.ini
877
878 %preun oci8
879 if [ "$1" = "0" ]; then
880         %{_sbindir}/php-module-install remove oci8 %{_sysconfdir}/apache/php.ini
881 fi
882 %endif
883
884 %post odbc
885 %{_sbindir}/php-module-install install odbc %{_sysconfdir}/apache/php.ini
886
887 %preun odbc
888 if [ "$1" = "0" ]; then
889         %{_sbindir}/php-module-install remove odbc %{_sysconfdir}/apache/php.ini
890 fi
891
892 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
893 %post oracle
894 %{_sbindir}/php-module-install install oracle %{_sysconfdir}/apache/php.ini
895
896 %preun oracle
897 if [ "$1" = "0" ]; then
898         %{_sbindir}/php-module-install remove oracle %{_sysconfdir}/apache/php.ini
899 fi
900 %endif
901
902 %post pcre
903 %{_sbindir}/php-module-install install pcre %{_sysconfdir}/apache/php.ini
904
905 %preun pcre
906 if [ "$1" = "0" ]; then
907         %{_sbindir}/php-module-install remove pcre %{_sysconfdir}/apache/php.ini
908 fi
909
910 %post pgsql
911 %{_sbindir}/php-module-install install pgsql %{_sysconfdir}/apache/php.ini
912
913 %preun pgsql
914 if [ "$1" = "0" ]; then
915         %{_sbindir}/php-module-install remove pgsql %{_sysconfdir}/apache/php.ini
916 fi
917
918 %post posix
919 %{_sbindir}/php-module-install install posix %{_sysconfdir}/apache/php.ini
920
921 %preun posix
922 if [ "$1" = "0" ]; then
923         %{_sbindir}/php-module-install remove posix %{_sysconfdir}/apache/php.ini
924 fi
925
926 %post recode
927 %{_sbindir}/php-module-install install recode %{_sysconfdir}/apache/php.ini
928
929 %preun recode
930 if [ "$1" = "0" ]; then
931         %{_sbindir}/php-module-install remove recode %{_sysconfdir}/apache/php.ini
932 fi
933
934 %post session
935 %{_sbindir}/php-module-install install session %{_sysconfdir}/apache/php.ini
936
937 %preun session
938 if [ "$1" = "0" ]; then
939         %{_sbindir}/php-module-install remove session %{_sysconfdir}/apache/php.ini
940 fi
941
942 %post snmp
943 %{_sbindir}/php-module-install install snmp %{_sysconfdir}/apache/php.ini
944
945 %preun snmp
946 if [ "$1" = "0" ]; then
947         %{_sbindir}/php-module-install remove snmp %{_sysconfdir}/apache/php.ini
948 fi
949
950 %post sockets
951 %{_sbindir}/php-module-install install sockets %{_sysconfdir}/apache/php.ini
952
953 %preun sockets
954 if [ "$1" = "0" ]; then
955         %{_sbindir}/php-module-install remove sockets %{_sysconfdir}/apache/php.ini
956 fi
957
958 %post sysvsem
959 %{_sbindir}/php-module-install install sysvsem %{_sysconfdir}/apache/php.ini
960
961 %preun sysvsem
962 if [ "$1" = "0" ]; then
963         %{_sbindir}/php-module-install remove sysvsem %{_sysconfdir}/apache/php.ini
964 fi
965
966 %post sysvshm
967 %{_sbindir}/php-module-install install sysvshm %{_sysconfdir}/apache/php.ini
968
969 %preun sysvshm
970 if [ "$1" = "0" ]; then
971         %{_sbindir}/php-module-install remove sysvshm %{_sysconfdir}/apache/php.ini
972 fi
973
974 %post xml
975 %{_sbindir}/php-module-install install xml %{_sysconfdir}/apache/php.ini
976
977 %preun xml
978 if [ "$1" = "0" ]; then
979         %{_sbindir}/php-module-install remove xml %{_sysconfdir}/apache/php.ini
980 fi
981
982 %post yp
983 %{_sbindir}/php-module-install install yp %{_sysconfdir}/apache/php.ini
984
985 %preun yp
986 if [ "$1" = "0" ]; then
987         %{_sbindir}/php-module-install remove yp %{_sysconfdir}/apache/php.ini
988 fi
989
990 %post zlib
991 %{_sbindir}/php-module-install install zlib %{_sysconfdir}/apache/php.ini
992
993 %preun zlib
994 if [ "$1" = "0" ]; then
995         %{_sbindir}/php-module-install remove zlib %{_sysconfdir}/apache/php.ini
996 fi
997
998 %clean
999 rm -rf $RPM_BUILD_ROOT
1000
1001 %files
1002 %defattr(644,root,root,755)
1003 %doc {CODING_STANDARDS,CREDITS,FUNCTION_LIST.txt,Zend/ZEND_CHANGES}.gz
1004 %doc {LICENSE,Zend/LICENSE,EXTENSIONS,NEWS,TODO*}.gz  
1005 %doc {README.EXT_SKEL,README.SELF-CONTAINED-EXTENSIONS}.gz
1006
1007 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/apache/*
1008
1009
1010 /home/httpd/html/icons/*
1011
1012 %attr(755,root,root) %{_libdir}/apache/libphp4.so
1013 %attr(755,root,root) %{_sbindir}/*
1014
1015 %dir %{_libdir}/php
1016 %dir %{_libdir}/php/extensions
1017 %dir %{extensionsdir}
1018
1019 %files devel
1020 %defattr(644,root,root,755)
1021 %{_includedir}/php4
1022 %{_libdir}/php4/build
1023 %attr(755,root,root) %{_bindir}/phpextdist
1024 %attr(755,root,root) %{_bindir}/phpize
1025 %attr(755,root,root) %{_bindir}/php-config
1026
1027 %files pear
1028 %defattr(644,root,root,755)
1029 %attr(755,root,root) %{_bindir}/pear
1030 %{_libdir}/php/Benchmark
1031 %{_libdir}/php/Crypt
1032 %{_libdir}/php/Date
1033 %{_libdir}/php/DB
1034 %{_libdir}/php/File
1035 %{_libdir}/php/HTML
1036 %{_libdir}/php/Mail
1037 %{_libdir}/php/Math
1038 %{_libdir}/php/Net
1039 %{_libdir}/php/Payment
1040 %{_libdir}/php/PEAR
1041 %{_libdir}/php/XML
1042 %{_libdir}/php/*.php
1043
1044
1045 %files mysql
1046 %defattr(644,root,root,755)
1047 %attr(755,root,root) %{extensionsdir}/mysql.*
1048
1049 %files pgsql
1050 %defattr(644,root,root,755)
1051 %attr(755,root,root) %{extensionsdir}/pgsql.so
1052
1053 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
1054 %files oracle
1055 %defattr(644,root,root,755)
1056 %attr(755,root,root) %{extensionsdir}/oracle.so
1057 %endif
1058
1059 %if  %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
1060 %files oci8
1061 %defattr(644,root,root,755)
1062 %attr(755,root,root) %{extensionsdir}/oci8.so
1063 %endif
1064
1065 %files gd
1066 %defattr(644,root,root,755)
1067 %attr(755,root,root) %{extensionsdir}/gd.so
1068
1069 %files xml
1070 %defattr(644,root,root,755)
1071 %attr(755,root,root) %{extensionsdir}/xml.so
1072
1073 %files dba
1074 %defattr(644,root,root,755)
1075 %attr(755,root,root) %{extensionsdir}/dba.so
1076
1077 %files dbase
1078 %defattr(644,root,root,755)
1079 %attr(755,root,root) %{extensionsdir}/dbase.so
1080
1081 %files filepro
1082 %defattr(644,root,root,755)
1083 %attr(755,root,root) %{extensionsdir}/filepro.so
1084
1085 %files pcre
1086 %defattr(644,root,root,755)
1087 %attr(755,root,root) %{extensionsdir}/pcre.so
1088
1089 %files posix
1090 %defattr(644,root,root,755)
1091 %attr(755,root,root) %{extensionsdir}/posix.so
1092
1093 %files sysvsem
1094 %defattr(644,root,root,755)
1095 %attr(755,root,root) %{extensionsdir}/sysvsem.so
1096
1097 %files sysvshm
1098 %defattr(644,root,root,755)
1099 %attr(755,root,root) %{extensionsdir}/sysvshm.so
1100
1101 %files yp
1102 %defattr(644,root,root,755)
1103 %attr(755,root,root) %{extensionsdir}/yp.so
1104
1105 %files calendar
1106 %defattr(644,root,root,755)
1107 %attr(755,root,root) %{extensionsdir}/calendar.so
1108
1109 %files bcmath
1110 %defattr(644,root,root,755)
1111 %attr(755,root,root) %{extensionsdir}/bcmath.so
1112
1113 %files ftp
1114 %defattr(644,root,root,755)
1115 %attr(755,root,root) %{extensionsdir}/ftp.so
1116
1117 %files zlib
1118 %defattr(644,root,root,755)
1119 %attr(755,root,root) %{extensionsdir}/zlib.so
1120
1121 %files exif
1122 %defattr(644,root,root,755)
1123 %attr(755,root,root) %{extensionsdir}/exif.so
1124
1125 %files recode
1126 %defattr(644,root,root,755)
1127 %attr(755,root,root) %{extensionsdir}/recode.so
1128
1129 #%files session
1130 #%defattr(644,root,root,755)
1131 #%attr(755,root,root) %{extensionsdir}/session.so
1132
1133 %files gettext
1134 %defattr(644,root,root,755)
1135 %attr(755,root,root) %{extensionsdir}/gettext.so
1136
1137 %files imap
1138 %defattr(644,root,root,755)
1139 %attr(755,root,root) %{extensionsdir}/imap.so
1140
1141 %files snmp
1142 %defattr(644,root,root,755)
1143 %attr(755,root,root) %{extensionsdir}/snmp.so
1144
1145 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
1146 %files java
1147 %defattr(644,root,root,755)
1148 %attr(755,root,root) %{extensionsdir}/libphp_java.so
1149 %endif
1150
1151 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
1152 %files ldap
1153 %defattr(644,root,root,755)
1154 %attr(755,root,root) %{extensionsdir}/ldap.*
1155 %endif
1156
1157 %files sockets
1158 %defattr(644,root,root,755)
1159 %attr(755,root,root) %{extensionsdir}/sockets.so
1160
1161 %files mcrypt
1162 %defattr(644,root,root,755)
1163 %attr(755,root,root) %{extensionsdir}/mcrypt.so
1164
1165 %files mhash
1166 %defattr(644,root,root,755)
1167 %attr(755,root,root) %{extensionsdir}/mhash.so
1168
1169 %files odbc
1170 %defattr(644,root,root,755)
1171 %attr(755,root,root) %{extensionsdir}/odbc.so
1172
1173 %files doc
1174 %defattr(644,root,root,755)
1175 /home/httpd/html/docs/php4-doc
This page took 0.10644 seconds and 4 git commands to generate.