]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- BuildRequires: apache(EAPI)-devel
[packages/php.git] / php.spec
1 Summary:        The PHP HTML-embedded scripting language for use with Apache.
2 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache.
3 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
4 Name:           php
5 Version:        4.0b4pl1
6 Release:        1
7 Group:          Libraries
8 Group(fr):      Librairies
9 Group(pl):      Biblioteki
10 License:        GPL
11 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
12 Source1:        FAQ.php
13 Source2:        php.ini
14 Source3:        zend.gif
15 Icon:           php4.gif
16 URL:            http://www.php.net/
17 BuildRequires:  apache(EAPI)-devel
18 BuildRequires:  zlib-devel
19 BuildRequires:  mysql-devel >= 3.22.30-2
20 BuildRequires:  kaffe-devel
21 BuildRequires:  libxml-devel >= 1.0.0
22 BuildRequires:  gd-devel
23 Requires:       apache(EAPI) >= 1.3.9
24 Prereq:         /usr/sbin/apxs
25 BuildRoot:      /tmp/%{name}-%{version}-root
26
27 %define         _pkglibdir      %{_libdir}/apache
28
29 %description
30 PHP is an HTML-embedded scripting language.  PHP attempts to make it easy
31 for developers to write dynamically generated web pages.  PHP also offers
32 built-in database integration for several commercial and non-commercial
33 database management systems, so writing a database-enabled web page with
34 PHP is fairly simple.  The most common use of PHP coding is probably as a
35 replacement for CGI scripts.  The mod_php module enables the Apache web
36 server to understand and process the embedded PHP language in web pages.
37 This package contains PHP version %{version}.  If you use applications which
38 specifically rely on PHP/FI (PHP v2 and earlier), you should instead install
39 the PHP/FI module contained in the phpfi package.  If you're just starting
40 with PHP, you should install this package.  You'll also need to install
41 the Apache web server.
42
43 %description -l fr
44 PHP est un langage de script embarque dans le HTM. PHP essaye de rendre
45 simple aux developpeurs d'ecrire des pages web generees dynamiquement.
46 PHP incorpore egalement une integration avec plusieurs systemes de gestion
47 de bases de donnees commerciaux et non-connerciaux, qui rent facile
48 la creation de pages web liees avec des bases de donnees. L'utilisation la
49 plus commune de PHP est probablement en remplacement de scripts CGI. Le
50 module mod_php permet au serveur web apache de comprendre et de traiter le
51 langage PHP integre dans des pages web.
52 Ce package contient PHP version %{version}. Si vous utilisez des
53 applications qui utilisent specifiquement PHP/FI, vous devrez installer le
54 module PHP/FI inclus dans le package mod_php. Si vous debutez avec PHP, vous
55 devriez installer ce package. Vous aurez egalement besoin d'installer le
56 serveur web Apache.
57
58 %description -l pl
59 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w plikach
60 HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP (jak np.
61 Apache), który interpretuje te polecenia.  Umo¿liwia to tworzenie
62 dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona zosta³a
63 z jêzyków: C, Java i Perl.
64
65 %package mysql
66 Summary:        MySQL database module for PHP4
67 Summary(pl):    Modu³ bazy danych MySQL dla PHP4
68 Group:          Libraries
69 Group(fr):      Librairies
70 Group(pl):      Biblioteki
71 Requires:       %{name} = %{version}
72
73 %description mysql
74 This is a dynamic shared object (DSO) for Apache that will add MySQL
75 database support to PHP4.  If you need back-end support for MySQL,
76 you should install this package in addition to the main %{name} package.
77
78 %description mysql -l pl
79
80 %package gd
81 Summary:        GD extension module for PHP4
82 Summary:        Modu³ GD dla PHP4
83 Group:          Libraries
84 Group(fr):      Librairies
85 Group(pl):      Biblioteki
86 Requires:       %{name} = %{version}
87
88 %description gd
89 This is a dynamic shared object (DSO) for Apache that will add GD
90 support to PHP4. You should install this package in addition to the main
91 %{name} package if you want to create and manipulate images with PHP.
92
93 %description gd -l pl
94
95 %package java
96 Summary:        Java extension module for PHP4
97 Summary(pl):    Modu³ Javy dla PHP4
98 Group:          Libraries
99 Group(fr):      Librairies
100 Group(pl):      Biblioteki
101 Requires:       %{name} = %{version}
102
103 %description java
104 This is a dynamic shared object (DSO) for Apache that will add JAVA
105 support to PHP4. This extension provides a simple and effective means
106 for creating and invoking methods on Java objects from PHP.
107
108 %description java -l pl
109
110 %package xml
111 Summary:        XML extension module for PHP4
112 Summary(pl):    Modu³ XML dla PHP4
113 Group:          Libraries
114 Group(fr):      Librairies
115 Group(pl):      Biblioteki
116 Requires:       %{name} = %{version}
117
118 %description xml
119 This is a dynamic shared object (DSO) for Apache that will add XML
120 support to PHP4. This extension lets you create XML parsers and then
121 define handlers for different XML events. If you want to be able to parse
122 XML documents you should install this package in addition to the main 
123 %{name} package.
124
125 %description xml -l pl
126
127 %prep
128 %setup -q 
129
130 %build
131 LDFLAGS=""; export LDFLAGS
132 CFLAGS="$RPM_OPT_FLAGS -DEAPI"; export CFLAGS
133 ./buildconf
134 %configure \
135         --with-apxs=%{_sbindir}/apxs \
136         --with-config-file-path=%{_sysconfdir}/httpd \
137         --with-exec-dir=%{_bindir} \
138         --disable-debug \
139         --enable-magic-quotes \
140         --enable-shared \
141         --enable-track-vars \
142         --enable-safe-mode \
143         --enable-trans-sid \
144         --enable-sysvsem \
145         --enable-sysvshm \
146         --enable-xml=shared \
147         --with-zlib \
148         --with-regex=system \
149         --with-gettext \
150         --with-mysql=shared \
151         --with-gd=shared \
152         --with-dbase \
153         --with-filepro \
154         --with-ftp \
155         --with-hyperwave \
156         --with-java
157 #       --with-pgsql=shared 
158 #       --with-snmp=shared 
159
160 make
161
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT{%{_pkglibdir}/php,%{_sysconfdir}/httpd} \
166                 $RPM_BUILD_ROOT/home/httpd/html/icons
167
168
169 install .libs/*.so      $RPM_BUILD_ROOT%{_pkglibdir}
170 install modules/*.so    $RPM_BUILD_ROOT%{_pkglibdir}/php
171
172 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
173 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
174
175 strip --strip-unneeded  \
176         $RPM_BUILD_ROOT%{_pkglibdir}/*.so \
177         $RPM_BUILD_ROOT%{_pkglibdir}/php/*.so
178
179 install  %{SOURCE1}     .
180 gzip -9nf CODING_STANDARDS CREDITS FAQ* ChangeLog FUNCTION_LIST.txt \
181         MAINTAINERS MODULES_STATUS NEWS TODO*
182
183 %post
184 /usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
185 if [ -f /var/lock/subsys/httpd ]; then
186         /etc/rc.d/init.d/httpd restart 1>&2
187 fi
188
189
190 %preun
191 if [ "$1" = "0" ]; then
192         /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
193         if [ -f /var/lock/subsys/httpd ]; then
194                 /etc/rc.d/init.d/httpd restart 1>&2
195         fi
196 fi
197
198 %post mysql
199 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
200         echo "activating module 'mysql.so' in /etc/httpd/php.ini" 1>&2
201         perl -pi -e 's|^;extension=mysql.so|extension=mysql.so|g' \
202         %{_sysconfdir}/httpd/php.ini
203 fi
204 if [ -f /var/lock/subsys/httpd ]; then
205         /etc/rc.d/init.d/httpd restart 1>&2
206 fi
207
208 %postun mysql
209 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
210         echo "deactivating module 'mysql.so' in /etc/httpd/php.ini" 1>&2
211         perl -pi -e 's|^extension=mysql.so|;extension=mysql.so|g' \
212         %{_sysconfdir}/httpd/php.ini
213 fi
214 if [ -f /var/lock/subsys/httpd ]; then
215         /etc/rc.d/init.d/httpd restart 1>&2
216 fi
217
218 %post gd
219 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
220         echo "activating module 'gd.so' in /etc/httpd/php.ini" 1>&2
221         perl -pi -e 's|^;extension=gd.so|extension=gd.so|g' \
222         %{_sysconfdir}/httpd/php.ini
223 fi
224 if [ -f /var/lock/subsys/httpd ]; then
225         /etc/rc.d/init.d/httpd restart 1>&2
226 fi
227
228 %postun gd
229 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
230         echo "deactivating module 'gd.so' in /etc/httpd/php.ini" 1>&2
231         perl -pi -e 's|^extension=gd.so|;extension=gd.so|g' \
232         %{_sysconfdir}/httpd/php.ini
233 fi
234 if [ -f /var/lock/subsys/httpd ]; then
235         /etc/rc.d/init.d/httpd restart 1>&2
236 fi
237
238 %post xml
239 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
240         echo "activating module 'xml.so' in /etc/httpd/php.ini" 1>&2
241         perl -pi -e 's|^;extension=xml.so|extension=xml.so|g' \
242         %{_sysconfdir}/httpd/php.ini
243 fi
244 if [ -f /var/lock/subsys/httpd ]; then
245         /etc/rc.d/init.d/httpd restart 1>&2
246 fi
247
248 %postun xml
249 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
250         echo "deactivating module 'xml.so' in /etc/httpd/php.ini" 1>&2
251         perl -pi -e 's|^extension=xml.so|;extension=xml.so|g' \
252         %{_sysconfdir}/httpd/php.ini
253 fi
254 if [ -f /var/lock/subsys/httpd ]; then
255         /etc/rc.d/init.d/httpd restart 1>&2
256 fi
257
258 %post java
259 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
260         echo "activating module 'libphp_java.so' in /etc/httpd/php.ini" 1>&2
261         perl -pi -e 's|^;extension=libphp_java.so|extension=libphp_java.so|g' \
262         %{_sysconfdir}/httpd/php.ini
263 fi
264 if [ -f /var/lock/subsys/httpd ]; then
265         /etc/rc.d/init.d/httpd restart 1>&2
266 fi
267
268 %postun java
269 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
270         echo "deactivating module 'libphp_java.so' in /etc/httpd/php.ini" 1>&2
271         perl -pi -e 's|^extension=libphp_java.so|;extension=libphp_java.so|g' \
272         %{_sysconfdir}/httpd/php.ini
273 fi
274 if [ -f /var/lock/subsys/httpd ]; then
275         /etc/rc.d/init.d/httpd restart 1>&2
276 fi
277
278 %clean
279 rm -rf $RPM_BUILD_ROOT
280
281 %files
282 %defattr(644,root,root,755)
283 %doc {CODING_STANDARDS,CREDITS,FAQ*,ChangeLog,FUNCTION_LIST.txt}.gz
284 %doc {MAINTAINERS,MODULES_STATUS,NEWS,TODO*}.gz  
285
286 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
287 %dir %{_pkglibdir}/php
288
289 #%attr(755,root,root) %{_libdir}/apache/php/*.so
290
291 /home/httpd/html/icons/*
292
293 %attr(755,root,root) %{_pkglibdir}/libphp4.so
294
295 %files mysql
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_pkglibdir}/php/mysql.so
298
299 %files gd
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_pkglibdir}/php/gd.so
302
303 %files xml
304 %defattr(644,root,root,755)
305 %attr(755,root,root) %{_pkglibdir}/php/xml.so
306
307 %files java
308 %defattr(644,root,root,755)
309 %attr(755,root,root) %{_pkglibdir}/php/libphp_java.so
This page took 0.059478 seconds and 4 git commands to generate.