]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- added separate subpackage for mysql module
[packages/php.git] / php.spec
1 Summary:        The PHP HTML-embedded scripting language for use with Apache.
2 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache.
3 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
4 Name:           php
5 Version:        4.0b4pl1
6 Release:        1
7 Group:          Libraries
8 Group(fr):      Librairies
9 Group(pl):      Biblioteki
10 License:        GPL
11 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
12 Source1:        FAQ.php
13 Source2:        php.ini
14 Source3:        zend.gif
15 Icon:           php4.gif
16 URL:            http://www.php.net/
17 BuildRequires:  apache-devel
18 BuildRequires:  zlib-devel
19 BuildRequires:  mysql-devel
20 Requires:       apache >= 1.3.9
21 Prereq:         /usr/sbin/apxs
22 BuildRoot:      /tmp/%{name}-%{version}-root
23
24 %define         _pkglibdir      %{_libdir}/apache
25
26 %description
27 PHP is an HTML-embedded scripting language.  PHP attempts to make it easy
28 for developers to write dynamically generated web pages.  PHP also offers
29 built-in database integration for several commercial and non-commercial
30 database management systems, so writing a database-enabled web page with
31 PHP is fairly simple.  The most common use of PHP coding is probably as a
32 replacement for CGI scripts.  The mod_php module enables the Apache web
33 server to understand and process the embedded PHP language in web pages.
34 This package contains PHP version %{version}.  If you use applications which
35 specifically rely on PHP/FI (PHP v2 and earlier), you should instead install
36 the PHP/FI module contained in the phpfi package.  If you're just starting
37 with PHP, you should install this package.  You'll also need to install
38 the Apache web server.
39
40 %description -l fr
41 PHP est un langage de script embarque dans le HTM. PHP essaye de rendre
42 simple aux developpeurs d'ecrire des pages web generees dynamiquement.
43 PHP incorpore egalement une integration avec plusieurs systemes de gestion
44 de bases de donnees commerciaux et non-connerciaux, qui rent facile
45 la creation de pages web liees avec des bases de donnees. L'utilisation la
46 plus commune de PHP est probablement en remplacement de scripts CGI. Le
47 module mod_php permet au serveur web apache de comprendre et de traiter le
48 langage PHP integre dans des pages web.
49 Ce package contient PHP version %{version}. Si vous utilisez des
50 applications qui utilisent specifiquement PHP/FI, vous devrez installer le
51 module PHP/FI inclus dans le package mod_php. Si vous debutez avec PHP, vous
52 devriez installer ce package. Vous aurez egalement besoin d'installer le
53 serveur web Apache.
54
55 %description -l pl
56 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w plikach
57 HTML.  Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP (jak np.
58 Apache), który interpretuje te polecenia.  Umo¿liwia to tworzenie
59 dynamicznie stron WWW.  Spora czê¶æ sk³adni PHP zapo¿yczona zosta³a
60 z jêzyków: C, Java i Perl.
61
62 %package mysql
63 Summary:        MySQL database module for PHP4
64 Summary(pl):    Modu³ bazy danych MySQL dla PHP4
65 Group:          Libraries
66 Group(fr):      Librairies
67 Group(pl):      Biblioteki
68 Requires:       %{name} = %{version}
69
70 %description mysql
71 This is a dynamic shared object (DSO) for Apache that will add MySQL
72 database support to PHP4.  If you need back-end support for MySQL,
73 you should install this package in addition to the main %{name} package.
74
75 %prep
76 %setup -q 
77
78 %build
79 ./buildconf
80 %configure \
81         --with-apxs=%{_sbindir}/apxs \
82         --with-config-file-path=%{_sysconfdir}/httpd \
83         --enable-safe-mode \
84         --with-exec-dir=%{_bindir} \
85         --disable-debug \
86         --with-zlib \
87         --enable-magic-quotes \
88         --enable-track-vars \
89         --without-gd \
90         --with-gettext \
91         --with-mysql=shared \
92         --enable-shared 
93 make
94
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd} \
99                 $RPM_BUILD_ROOT/home/httpd/html/icons
100
101 install .libs/*.so      $RPM_BUILD_ROOT%{_pkglibdir}
102 install modules/*.so    $RPM_BUILD_ROOT%{_pkglibdir}
103
104 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
105 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
106
107 strip --strip-unneeded  $RPM_BUILD_ROOT%{_pkglibdir}/*.so
108
109 install  %{SOURCE1}     .
110 gzip -9nf CODING_STANDARDS CREDITS FAQ* ChangeLog FUNCTION_LIST.txt \
111         MAINTAINERS MODULES_STATUS NEWS TODO*
112
113 %post
114 /usr/sbin/apxs -e -a -n php %{_pkglibdir}/libphp4.so 1>&2
115 if [ -f /var/lock/subsys/httpd ]; then
116         /etc/rc.d/init.d/httpd restart 1>&2
117 fi
118
119
120 %preun
121 if [ "$1" = "0" ]; then
122         /usr/sbin/apxs -e -A -n php %{_pkglibdir}/libphp4.so 1>&2
123         if [ -f /var/lock/subsys/httpd ]; then
124                 /etc/rc.d/init.d/httpd restart 1>&2
125         fi
126 fi
127
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc {CODING_STANDARDS,CREDITS,FAQ*,ChangeLog,FUNCTION_LIST.txt}.gz
135 %doc {MAINTAINERS,MODULES_STATUS,NEWS,TODO*}.gz  
136
137 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
138 /home/httpd/html/icons/*
139
140 %attr(755,root,root) %{_pkglibdir}/libphp4.so
141
142 %files mysql
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_pkglibdir}/mysql.so
This page took 0.046326 seconds and 4 git commands to generate.