]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- release 0.2
[packages/php.git] / php.spec
1 #
2 #   oracle - with oracle support 
3 #   oci8   - with oci8 support
4 #       
5 Summary:        The PHP HTML-embedded scripting language for use with Apache
6 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache
7 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
8 Name:           php
9 Version:        4.0.4pl1
10 Release:        0.2
11 Epoch:          1
12 Group:          Libraries
13 Group(de):      Libraries
14 Group(fr):      Librairies
15 Group(pl):      Biblioteki
16 License:        The PHP license (see "LICENSE" file included in distribution)
17 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
18 Source1:        FAQ.php
19 Source2:        %{name}.ini
20 Source3:        zend.gif
21 Source4:        http://www.php.net/distributions/manual.tar.gz
22 Source5:        php-module-install
23 Patch0:         %{name}-imap.patch
24 Patch1:         %{name}-mysql-socket.patch
25 Patch2:         %{name}-mail.patch
26 Patch5:         %{name}-no_libnsl.patch
27 Icon:           php4.gif
28 URL:            http://www.php.net/
29 BuildRequires:  apache(EAPI)-devel
30 BuildRequires:  zip
31 BuildRequires:  bison
32 BuildRequires:  flex
33 BuildRequires:  db3-devel >= 3.1.17
34 BuildRequires:  freetype-devel
35 BuildRequires:  gd-devel >= 1.8.3
36 BuildRequires:  gdbm-devel
37 BuildRequires:  imap-devel >= 4.7b-1
38 # I think jdk is better for java
39 # BuildRequires:        jdk
40 %{?bcond_on_java:BuildRequires: kaffe-devel}
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libpng >= 1.0.8
44 BuildRequires:  libtiff-devel
45 BuildRequires:  mm-devel >= 1.1.3
46 %{!?bcond_off_ldap:BuildRequires: openldap-devel >= 2.0}
47 BuildRequires:  pam-devel
48 BuildRequires:  pdflib-devel >= 3.0
49 #BuildRequires: libxml-devel >= 2.0.0
50 BuildRequires:  postgresql-devel
51 BuildRequires:  recode-devel >= 3.5
52 BuildRequires:  t1lib-devel
53 BuildRequires:  unixODBC-devel
54 BuildRequires:  zlib-devel >= 1.0.9
55 BuildRequires:  ucd-snmp-devel >= 4.1
56 BuildRequires:  libmcrypt-devel >= 2.4.4
57 BuildRequires:  mhash-devel
58 BuildRequires:  libltdl-devel
59 BuildRequires:  bzip2-devel
60 BuildRequires:  gmp-devel
61 BuildRequires:  curl-devel
62 %if %(expr %{?bcond_on_openssl:1}%{!?bcond_on_openssl:0} + %{!?bcond_off_ldap:1}%{?bcond_off_ldap:0})
63 BuildRequires:  openssl-devel >= 0.9.6
64 %endif
65 Requires:       apache(EAPI) >= 1.3.9
66 Prereq:         perl
67 Prereq:         /usr/sbin/apxs
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _pkglibdir      %{_libdir}/apache
71
72 %description
73 PHP is an HTML-embedded scripting language. PHP attempts to make it
74 easy for developers to write dynamically generated web pages. PHP also
75 offers built-in database integration for several commercial and
76 non-commercial database management systems, so writing a
77 database-enabled web page with PHP is fairly simple. The most common
78 use of PHP coding is probably as a replacement for CGI scripts. The
79 mod_php module enables the Apache web server to understand and process
80 the embedded PHP language in web pages. This package contains PHP
81 version %{version}. If you use applications which specifically rely on
82 PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
83 module contained in the phpfi package. If you're just starting with
84 PHP, you should install this package. You'll also need to install the
85 Apache web server.
86
87 %description -l fr
88 PHP est un langage de script embarque dans le HTM. PHP essaye de
89 rendre simple aux developpeurs d'ecrire des pages web generees
90 dynamiquement. PHP incorpore egalement une integration avec plusieurs
91 systemes de gestion de bases de donnees commerciaux et
92 non-connerciaux, qui rent facile la creation de pages web liees avec
93 des bases de donnees. L'utilisation la plus commune de PHP est
94 probablement en remplacement de scripts CGI. Le module mod_php permet
95 au serveur web apache de comprendre et de traiter le langage PHP
96 integre dans des pages web. Ce package contient PHP version
97 %{version}. Si vous utilisez des applications qui utilisent
98 specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
99 dans le package mod_php. Si vous debutez avec PHP, vous devriez
100 installer ce package. Vous aurez egalement besoin d'installer le
101 serveur web Apache.
102
103 %description -l pl
104 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
105 plikach HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP
106 (jak np. Apache), który interpretuje te polecenia. Umo¿liwia to
107 tworzenie dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona
108 zosta³a z jêzyków: C, Java i Perl.
109
110 %package mysql
111 Summary:        MySQL database module for PHP
112 Summary(pl):    Modu³ bazy danych MySQL dla PHP
113 Group:          Libraries
114 Group(de):      Libraries
115 Group(fr):      Librairies
116 Group(pl):      Biblioteki
117 PreReq: %{name} = %{version}
118
119 %description mysql
120 This is a dynamic shared object (DSO) for Apache that will add MySQL
121 database support to PHP. If you need back-end support for MySQL, you
122 should install this package in addition to the main %{name} package.
123
124 %description mysql -l pl
125 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych MySQL.
126
127
128 %package pgsql
129 Summary:        PostgreSQL database module for PHP
130 Summary(pl):    Modu³ bazy danych PostgreSQL dla PHP
131 Group:          Libraries
132 Group(de):      Libraries
133 Group(fr):      Librairies
134 Group(pl):      Biblioteki
135 PreReq: %{name} = %{version}
136
137 %description pgsql
138 This is a dynamic shared object (DSO) for Apache that will add
139 PostgreSQL database support to PHP. If you need back-end support for
140 PostgreSQL, you should install this package in addition to the main
141 %{name} package.
142
143 %description pgsql -l pl
144 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych PostgreSQL.
145
146 %package oci8
147 Summary:        Oracle 8 database module for PHP
148 Summary(pl):    Modu³ bazy danych Oracle 8 dla PHP
149 Group:          Libraries
150 Group(de):      Libraries
151 Group(fr):      Librairies
152 Group(pl):      Biblioteki
153 PreReq: %{name} = %{version}
154 Autoreq:        false
155
156 %description oci8
157 This is a dynamic shared object (DSO) for Apache that will add Oracle
158 8 database support to PHP. If you need back-end support for Oracle 8,
159 you should install this package in addition to the main %{name}
160 package.
161
162 %description oci8 -l pl
163 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 8. }
164
165 %package oracle
166 Summary:        Oracle 7 database module for PHP
167 Summary(pl):    Modu³ bazy danych Oracle 7 dla PHP
168 Group:          Libraries
169 Group(de):      Libraries
170 Group(fr):      Librairies
171 Group(pl):      Biblioteki
172 PreReq: %{name} = %{version}
173 Autoreq:        false
174
175 %description oracle
176 This is a dynamic shared object (DSO) for Apache that will add Oracle
177 7 database support to PHP. If you need back-end support for Oracle 7,
178 you should install this package in addition to the main %{name}
179 package.
180
181 %description oracle -l pl
182 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 7. }
183
184 %package gd
185 Summary:        GD extension module for PHP
186 Summary:        Modu³ GD dla PHP
187 Group:          Libraries
188 Group(de):      Libraries
189 Group(fr):      Librairies
190 Group(pl):      Biblioteki
191 PreReq: %{name} = %{version}
192
193 %description gd
194 This is a dynamic shared object (DSO) for Apache that will add GD
195 support to PHP. You should install this package in addition to the
196 main %{name} package if you want to create and manipulate images with
197 PHP.
198
199 %description gd -l pl
200
201 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
202 %package java
203 Summary:        Java extension module for PHP
204 Summary(pl):    Modu³ Javy dla PHP
205 Group:          Libraries
206 Group(de):      Libraries
207 Group(fr):      Librairies
208 Group(pl):      Biblioteki
209 PreReq: %{name} = %{version}
210
211 %description java
212 This is a dynamic shared object (DSO) for Apache that will add JAVA
213 support to PHP. This extension provides a simple and effective means
214 for creating and invoking methods on Java objects from PHP.
215
216 %description java -l pl
217 %endif
218
219 %package xml
220 Summary:        XML extension module for PHP
221 Summary(pl):    Modu³ XML dla PHP
222 Group:          Libraries
223 Group(de):      Libraries
224 Group(fr):      Librairies
225 Group(pl):      Biblioteki
226 PreReq: %{name} = %{version}
227
228 %description xml
229 This is a dynamic shared object (DSO) for Apache that will add XML
230 support to PHP. This extension lets you create XML parsers and then
231 define handlers for different XML events. If you want to be able to
232 parse XML documents you should install this package in addition to the
233 main %{name} package.
234
235 #%description xml -l pl
236
237 %package dba
238 Summary:        DBA extension module for PHP
239 Summary(pl):    Modu³ DBA dla PHP
240 Group:          Libraries
241 Group(de):      Libraries
242 Group(fr):      Librairies
243 Group(pl):      Biblioteki
244 PreReq: %{name} = %{version}
245
246 %description dba
247 This is a dynamic shared object (DSO) for Apache that will add
248 flat-file databases (DBA) support to PHP.
249
250 #%description dba -l pl
251
252 %package odbc
253 Summary:        ODBC extension module for PHP
254 Summary(pl):    Modu³ ODBC dla PHP
255 Group:          Libraries
256 Group(de):      Libraries
257 Group(fr):      Librairies
258 Group(pl):      Biblioteki
259 PreReq: %{name} = %{version}
260
261 %description odbc
262 This is a dynamic shared object (DSO) for Apache that will add
263 ODBC support to PHP.
264
265 #%description odbc -l pl
266
267 %package calendar
268 Summary:        Calendar extension module for PHP
269 Summary(pl):    Modu³ funkcji kalendarza dla PHP
270 Group:          Libraries
271 Group(de):      Libraries
272 Group(fr):      Librairies
273 Group(pl):      Biblioteki
274 PreReq: %{name} = %{version}
275
276 %description calendar
277 This is a dynamic shared object (DSO) for Apache that will add
278 calendar support to PHP.
279
280 #%description calendar -l pl
281
282 %package dbase
283 Summary:        DBase extension module for PHP
284 Summary(pl):    Modu³ DBase dla PHP
285 Group:          Libraries
286 Group(de):      Libraries
287 Group(fr):      Librairies
288 Group(pl):      Biblioteki
289 PreReq: %{name} = %{version}
290
291 %description dbase
292 This is a dynamic shared object (DSO) for Apache that will add DBase
293 support to PHP.
294
295 #%description dbase -l pl
296
297 %package filepro
298 Summary:        FilePro extension module for PHP
299 Summary(pl):    Modu³ FilePro dla PHP
300 Group:          Libraries
301 Group(de):      Libraries
302 Group(fr):      Librairies
303 Group(pl):      Biblioteki
304 PreReq: %{name} = %{version}
305
306 %description filepro
307 This is a dynamic shared object (DSO) for Apache that will add FilePro
308 support to PHP.
309
310 #%description filepro -l pl
311
312 %package posix
313 Summary:        POSIX extension module for PHP
314 Summary(pl):    Modu³ POSIX dla PHP
315 Group:          Libraries
316 Group(de):      Libraries
317 Group(fr):      Librairies
318 Group(pl):      Biblioteki
319 PreReq: %{name} = %{version}
320
321 %description posix
322 This is a dynamic shared object (DSO) for Apache that will add POSIX
323 functions support to PHP.
324
325 #%description posix -l pl
326
327 %package pcre
328 Summary:        PCRE extension module for PHP
329 Summary(pl):    Modu³ PCRE dla PHP
330 Group:          Libraries
331 Group(de):      Libraries
332 Group(fr):      Librairies
333 Group(pl):      Biblioteki
334 PreReq: %{name} = %{version}
335
336 %description pcre
337 This is a dynamic shared object (DSO) for Apache that will add Perl
338 Compatible Regular Expression support to PHP.
339
340 #%description pcre -l pl
341
342 %package sysvsem
343 Summary:        SysV sem extension module for PHP
344 Summary(pl):    Modu³ SysV sem dla PHP
345 Group:          Libraries
346 Group(de):      Libraries
347 Group(fr):      Librairies
348 Group(pl):      Biblioteki
349 PreReq: %{name} = %{version}
350
351 %description sysvsem
352 This is a dynamic shared object (DSO) for Apache that will add SysV
353 semafores support to PHP.
354
355 #%description sysvsem -l pl
356
357 %package sysvshm
358 Summary:        SysV shm extension module for PHP
359 Summary(pl):    Modu³ SysV shm dla PHP
360 Group:          Libraries
361 Group(de):      Libraries
362 Group(fr):      Librairies
363 Group(pl):      Biblioteki
364 PreReq: %{name} = %{version}
365
366 %description sysvshm
367 This is a dynamic shared object (DSO) for Apache that will add SysV
368 Shared Memory support to PHP.
369
370 #%description sysvshm -l pl
371
372 %package yp
373 Summary:        NIS (yp) extension module for PHP
374 Summary(pl):    Modu³ NIS (yp) dla PHP
375 Group:          Libraries
376 Group(de):      Libraries
377 Group(fr):      Librairies
378 Group(pl):      Biblioteki
379 PreReq: %{name} = %{version}
380
381 %description yp
382 This is a dynamic shared object (DSO) for Apache that will add NIS
383 (Yellow Pages) support to PHP.
384
385 #%description yp -l pl
386
387 %package bcmath
388 Summary:        bcmath extension module for PHP
389 Summary(pl):    Modu³ bcmath dla PHP
390 Group:          Libraries
391 Group(de):      Libraries
392 Group(fr):      Librairies
393 Group(pl):      Biblioteki
394 PreReq: %{name} = %{version}
395
396 %description bcmath
397 This is a dynamic shared object (DSO) for Apache that will add bc
398 style precision math functions support to PHP.
399
400 #%description bcmath -l pl
401
402 %package ftp
403 Summary:        FTP extension module for PHP
404 Summary(pl):    Modu³ FTP dla PHP
405 Group:          Libraries
406 Group(de):      Libraries
407 Group(fr):      Librairies
408 Group(pl):      Biblioteki
409 PreReq: %{name} = %{version}
410
411 %description ftp
412 This is a dynamic shared object (DSO) for Apache that will add FTP
413 support to PHP.
414
415 #%description ftp -l pl
416
417 %package zlib
418 Summary:        Zlib extension module for PHP
419 Summary(pl):    Modu³ zlib dla PHP
420 Group:          Libraries
421 Group(de):      Libraries
422 Group(fr):      Librairies
423 Group(pl):      Biblioteki
424 PreReq: %{name} = %{version}
425
426 %description zlib
427 This is a dynamic shared object (DSO) for Apache that will add
428 commpresion (zlib) support to PHP.
429
430 #%description zlib -l pl
431
432 %package exif
433 Summary:        exifextension module for PHP
434 Summary(pl):    Modu³ exif dla PHP
435 Group:          Libraries
436 Group(de):      Libraries
437 Group(fr):      Librairies
438 Group(pl):      Biblioteki
439 PreReq: %{name} = %{version}
440
441 %description exif
442 This is a dynamic shared object (DSO) for Apache that will add exif
443 support to PHP.
444
445 #%description exif -l pl
446
447 %package recode
448 Summary:        recodeextension module for PHP
449 Summary(pl):    Modu³ recode dla PHP
450 Group:          Libraries
451 Group(de):      Libraries
452 Group(fr):      Librairies
453 Group(pl):      Biblioteki
454 PreReq: %{name} = %{version}
455
456 %description recode
457 This is a dynamic shared object (DSO) for Apache that will add recode
458 support to PHP.
459
460 #%description recode -l pl
461
462 %package session
463 Summary:        sessionextension module for PHP
464 Summary(pl):    Modu³ session dla PHP
465 Group:          Libraries
466 Group(de):      Libraries
467 Group(fr):      Librairies
468 Group(pl):      Biblioteki
469 PreReq: %{name} = %{version}
470
471 %description session
472 This is a dynamic shared object (DSO) for Apache that will add session
473 support to PHP.
474
475 #%description session -l pl
476
477 %package gettext
478 Summary:        gettextextension module for PHP
479 Summary(pl):    Modu³ gettext dla PHP
480 Group:          Libraries
481 Group(de):      Libraries
482 Group(fr):      Librairies
483 Group(pl):      Biblioteki
484 PreReq: %{name} = %{version}
485
486 %description gettext
487 This is a dynamic shared object (DSO) for Apache that will add gettext
488 support to PHP.
489
490 #%description gettext -l pl
491
492
493 %package snmp
494 Summary:        snmpextension module for PHP
495 Summary(pl):    Modu³ snmp dla PHP
496 Group:          Libraries
497 Group(de):      Libraries
498 Group(fr):      Librairies
499 Group(pl):      Biblioteki
500 PreReq: %{name} = %{version}
501
502 %description snmp
503 This is a dynamic shared object (DSO) for Apache that will add snmp
504 support to PHP.
505
506 #%description snmp -l pl
507
508 %package imap
509 Summary:        imapextension module for PHP
510 Summary(pl):    Modu³ imap dla PHP
511 Group:          Libraries
512 Group(de):      Libraries
513 Group(fr):      Librairies
514 Group(pl):      Biblioteki
515 PreReq: %{name} = %{version}
516
517 %description imap
518 This is a dynamic shared object (DSO) for Apache that will add imap
519 support to PHP.
520
521 #%description imap -l pl
522
523 %package ldap
524 Summary:        LDAP extension module for PHP
525 Summary(pl):    Modu³ LDAP dla PHP
526 Group:          Libraries
527 Group(de):      Libraries
528 Group(fr):      Librairies
529 Group(pl):      Biblioteki
530 PreReq: %{name} = %{version}
531
532 %description ldap
533 This is a dynamic shared object (DSO) for Apache that will add LDAP
534 support to PHP.
535
536 #%description ldap -l pl
537
538 %package sockets
539 Summary:        sockets extension module for PHP
540 Summary(pl):    Modu³ socket dla PHP
541 Group:          Libraries
542 Group(de):      Libraries
543 Group(fr):      Librairies
544 Group(pl):      Biblioteki
545 PreReq: %{name} = %{version}
546
547 %description sockets
548 This is a dynamic shared object (DSO) for Apache that will add sockets
549 support to PHP.
550
551 #%description sockets -l pl
552
553 %package mcrypt
554 Summary:        mcrypt extension module for PHP
555 Summary(pl):    Modu³ mcrypt dla PHP
556 Group:          Libraries
557 Group(de):      Libraries
558 Group(fr):      Librairies
559 Group(pl):      Biblioteki
560 PreReq: %{name} = %{version}
561
562 %description mcrypt
563 This is a dynamic shared object (DSO) for Apache that will add mcrypt
564 support to PHP.
565
566 #%description mcrypt -l pl
567
568 %package mhash
569 Summary:        mhash extension module for PHP
570 Summary(pl):    Modu³ mhash dla PHP
571 Group:          Libraries
572 Group(de):      Libraries
573 Group(fr):      Librairies
574 Group(pl):      Biblioteki
575 PreReq: %{name} = %{version}
576
577 %description mhash
578 This is a dynamic shared object (DSO) for Apache that will add mhash
579 support to PHP.
580
581 #%description mcrypt -l pl
582
583
584 %package doc
585 Summary:        Online manual for PHP
586 Summary(pl):    Dokumentacja dla PHP
587 Group:          Networking/Daemons
588 Group(de):      Netzwerkwesen/Server
589 Group(pl):      Sieciowe/Serwery
590
591 %description doc
592 Comprehensive documentation for PHP, viewable through your web
593 server, too!
594
595 %description doc -l pl
596 Dokumentacja dla pakietu PHP. Mo¿na j± równie¿ ogl±daæ poprzez serwer
597 WWW.
598
599 %prep
600 %setup  -q
601 %patch0 -p1
602 %patch1 -p1
603 %patch2 -p1
604 %patch5 -p1
605
606 %build
607 CFLAGS="$RPM_OPT_FLAGS -DEAPI -I/usr/X11R6/include"; export CFLAGS
608 ./buildconf
609 %configure \
610         --with-apxs=/usr/sbin/apxs \
611         --with-config-file-path=%{_sysconfdir}/httpd \
612         --with-exec-dir=%{_bindir} \
613         --disable-debug \
614         --enable-magic-quotes \
615         --enable-shared \
616         --enable-track-vars \
617         --enable-safe-mode \
618         --enable-trans-sid \
619         --enable-sysvsem=shared \
620         --enable-sysvshm=shared \
621         --enable-shmop=shared \
622         --enable-session \
623         --enable-exif=shared \
624         --with-regex=system \
625         --with-gettext=shared \
626         %{!?bcond_off_ldap:--with-ldap=shared} \
627         --with-mysql=shared \
628         --with-mysql-sock=/var/lib/mysql/mysql.sock \
629         --with-gd=shared \
630          --enable-gd-imgstrttf \
631         --with-dbase=shared \
632         --with-filepro=shared \
633         --enable-ftp=shared \
634         --with-hyperwave \
635         --with-pdflib=shared \
636         --with-cpdflib=shared \
637         %{?bcond_on_java:--with-java} \
638         --with-pgsql=shared,/usr \
639         --with-imap=shared \
640         --enable-bcmath=shared \
641         --enable-calendar=shared \
642         --with-mm \
643         --with-pcre-regex=shared \
644         --enable-posix=shared \
645         --with-ttf \
646         --with-t1lib \
647         --with-recode=shared \
648         --enable-ucd-snmp-hack \
649         --enable-dba=shared \
650         --with-snmp=shared \
651         --with-openssl \
652         --with-gdbm \
653         --with-db3 \
654         --enable-yp=shared \
655         --with-xml=shared \
656         --enable-xml=shared \
657         --with-zlib=shared \
658         --with-mcrypt=shared \
659         --enable-sockets=shared \
660         --with-bz2=shared \
661         --with-ctype=shared \
662         --with-mhash=shared \
663         --with-curl=shared \
664         --with-gmp=shared \
665         %{?bcond_on_openssl:--with-openssl} \
666         --with-unixODBC=shared \
667         %{?bcond_on_oracle:--with-oracle=shared} \
668         %{?bcond_on_oci8:--with-oci8=shared} \
669         --without-db2 
670
671
672
673 # TODO --with-pspell=/usr,shared (pspell missing)
674 #       --with-unixODBC=shared (nie jest shared)
675
676 #       --with-db3 \
677
678 # snmp won
679
680 #Syntax error on line 228 of %{_sysconfdir}/httpd/httpd.conf: Cannot load %{_libdir}/apache/libphp4.so into server: %{_libdir}/apache/libphp4.so: undefined symbol: phpi_get_le_gd
681 # Solution: make pdf and cpdf shared
682 #       --with-gd=shared \
683
684 #       --with-unixODBC \
685
686 # This option get trouble with imap
687 #       --enable-versioning \
688
689 # To old/new libmcrypt ?
690 #       --with-mcrypt=shared \
691 # --with-dom=%{_prefix}/X11R6 \
692
693 %{__make}
694
695 %install
696 rm -rf $RPM_BUILD_ROOT
697 install -d $RPM_BUILD_ROOT{%{_pkglibdir}/php,%{_sysconfdir}/httpd} \
698                 $RPM_BUILD_ROOT/home/httpd/html/{icons,docs,docs/php4-doc} \
699                 $RPM_BUILD_ROOT/%{_sbindir}
700
701 install .libs/*.so      $RPM_BUILD_ROOT%{_pkglibdir}
702 install modules/*.so    $RPM_BUILD_ROOT%{_pkglibdir}/php
703
704 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
705 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
706 install %{SOURCE5} $RPM_BUILD_ROOT/%{_sbindir}
707
708 tar zxf %{SOURCE4} -C $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc
709 ln -s manual.html $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc/index.html
710
711 install %{SOURCE1} .
712 gzip -9nf CODING_STANDARDS CREDITS FUNCTION_LIST.txt \
713       EXTENSIONS NEWS TODO* LICENSE Zend/LICENSE \
714       Zend/ZEND_CHANGES README.SELF-CONTAINED-EXTENSIONS README.EXT_SKEL
715
716 %post
717 /usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
718 perl -pi -e 's|^#AddType application/x-httpd-php .php|AddType application/x-httpd-php .php|'
719 if [ -f /var/lock/subsys/httpd ]; then
720         /etc/rc.d/init.d/httpd restart 1>&2
721 fi
722
723 %postun
724 perl -pi -e 's|^AddType application/x-httpd-php .php|#AddType application/x-httpd-php .php|'
725 if [ -f /var/lock/subsys/httpd ]; then
726       /etc/rc.d/init.d/httpd restart 1>&2
727 fi
728
729 %preun
730 if [ "$1" = "0" ]; then
731         /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
732         if [ -f /var/lock/subsys/httpd ]; then
733                 /etc/rc.d/init.d/httpd restart 1>&2
734         fi
735 fi
736
737
738 %post bcmath
739 %{_sbindir}/php-module-install install bcmath /etc/httpd/php.ini
740
741 %preun bcmath
742 if [ "$1" = "0" ]; then
743         %{_sbindir}/php-module-install remove bcmath /etc/httpd/php.ini
744 fi
745
746 %post calendar
747 %{_sbindir}/php-module-install install calendar /etc/httpd/php.ini
748
749 %preun calendar
750 if [ "$1" = "0" ]; then
751         %{_sbindir}/php-module-install remove calendar /etc/httpd/php.ini
752 fi
753
754 %post dba
755 %{_sbindir}/php-module-install install dba /etc/httpd/php.ini
756
757 %preun dba
758 if [ "$1" = "0" ]; then
759         %{_sbindir}/php-module-install remove dba /etc/httpd/php.ini
760 fi
761
762 %post dbase
763 %{_sbindir}/php-module-install install dbase /etc/httpd/php.ini
764
765 %preun dbase
766 if [ "$1" = "0" ]; then
767         %{_sbindir}/php-module-install remove dbase /etc/httpd/php.ini
768 fi
769
770 %post exif
771 %{_sbindir}/php-module-install install exif /etc/httpd/php.ini
772
773 %preun exif
774 if [ "$1" = "0" ]; then
775         %{_sbindir}/php-module-install remove exif /etc/httpd/php.ini
776 fi
777
778 %post filepro
779 %{_sbindir}/php-module-install install filepro /etc/httpd/php.ini
780
781 %preun filepro
782 if [ "$1" = "0" ]; then
783         %{_sbindir}/php-module-install remove filepro /etc/httpd/php.ini
784 fi
785
786 %post ftp
787 %{_sbindir}/php-module-install install ftp /etc/httpd/php.ini
788
789 %preun ftp
790 if [ "$1" = "0" ]; then
791         %{_sbindir}/php-module-install remove ftp /etc/httpd/php.ini
792 fi
793
794 %post gd
795 %{_sbindir}/php-module-install install gd /etc/httpd/php.ini
796
797 %preun gd
798 if [ "$1" = "0" ]; then
799         %{_sbindir}/php-module-install remove gd /etc/httpd/php.ini
800 fi
801
802 %post gettext
803 %{_sbindir}/php-module-install install gettext /etc/httpd/php.ini
804
805 %preun gettext
806 if [ "$1" = "0" ]; then
807         %{_sbindir}/php-module-install remove gettext /etc/httpd/php.ini
808 fi
809
810 %post imap
811 %{_sbindir}/php-module-install install imap /etc/httpd/php.ini
812
813 %preun imap
814 if [ "$1" = "0" ]; then
815         %{_sbindir}/php-module-install remove imap /etc/httpd/php.ini
816 fi
817
818 %if %{?bond_on_java:1}%{!?bond_on_java:0}
819 %post java
820 %{_sbindir}/php-module-install install libphp_java /etc/httpd/php.ini
821
822 %preun java
823 if [ "$1" = "0" ]; then
824         %{_sbindir}/php-module-install remove libphp_java /etc/httpd/php.ini
825 fi
826 %endif
827
828 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
829 %post ldap
830 %{_sbindir}/php-module-install install ldap /etc/httpd/php.ini
831
832 %preun ldap
833 if [ "$1" = "0" ]; then
834         %{_sbindir}/php-module-install remove ldap /etc/httpd/php.ini
835 fi
836 %endif
837
838 %post mcrypt
839 %{_sbindir}/php-module-install install mcrypt /etc/httpd/php.ini
840
841 %preun mcrypt
842 if [ "$1" = "0" ]; then
843         %{_sbindir}/php-module-install remove mcrypt /etc/httpd/php.ini
844 fi
845
846 %post mhash
847 %{_sbindir}/php-module-install install mhash /etc/httpd/php.ini
848
849 %preun mhash
850 if [ "$1" = "0" ]; then
851         %{_sbindir}/php-module-install remove mhash /etc/httpd/php.ini
852 fi
853
854 %post mysql
855 %{_sbindir}/php-module-install install mysql /etc/httpd/php.ini
856
857 %preun mysql
858 if [ "$1" = "0" ]; then
859         %{_sbindir}/php-module-install remove mysql /etc/httpd/php.ini
860 fi
861
862 %if %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
863 %post oci8
864 %{_sbindir}/php-module-install install oci8 /etc/httpd/php.ini
865
866 %preun oci8
867 if [ "$1" = "0" ]; then
868         %{_sbindir}/php-module-install remove oci8 /etc/httpd/php.ini
869 fi
870 %endif
871
872 %post odbc
873 %{_sbindir}/php-module-install install odbc /etc/httpd/php.ini
874
875 %preun odbc
876 if [ "$1" = "0" ]; then
877         %{_sbindir}/php-module-install remove odbc /etc/httpd/php.ini
878 fi
879
880 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
881 %post oracle
882 %{_sbindir}/php-module-install install oracle /etc/httpd/php.ini
883
884 %preun oracle
885 if [ "$1" = "0" ]; then
886         %{_sbindir}/php-module-install remove oracle /etc/httpd/php.ini
887 fi
888 %endif
889
890 %post pcre
891 %{_sbindir}/php-module-install install pcre /etc/httpd/php.ini
892
893 %preun pcre
894 if [ "$1" = "0" ]; then
895         %{_sbindir}/php-module-install remove pcre /etc/httpd/php.ini
896 fi
897
898 %post pgsql
899 %{_sbindir}/php-module-install install pgsql /etc/httpd/php.ini
900
901 %preun pgsql
902 if [ "$1" = "0" ]; then
903         %{_sbindir}/php-module-install remove pgsql /etc/httpd/php.ini
904 fi
905
906 %post posix
907 %{_sbindir}/php-module-install install posix /etc/httpd/php.ini
908
909 %preun posix
910 if [ "$1" = "0" ]; then
911         %{_sbindir}/php-module-install remove posix /etc/httpd/php.ini
912 fi
913
914 %post recode
915 %{_sbindir}/php-module-install install recode /etc/httpd/php.ini
916
917 %preun recode
918 if [ "$1" = "0" ]; then
919         %{_sbindir}/php-module-install remove recode /etc/httpd/php.ini
920 fi
921
922 %post session
923 %{_sbindir}/php-module-install install session /etc/httpd/php.ini
924
925 %preun session
926 if [ "$1" = "0" ]; then
927         %{_sbindir}/php-module-install remove session /etc/httpd/php.ini
928 fi
929
930 %post snmp
931 %{_sbindir}/php-module-install install snmp /etc/httpd/php.ini
932
933 %preun snmp
934 if [ "$1" = "0" ]; then
935         %{_sbindir}/php-module-install remove snmp /etc/httpd/php.ini
936 fi
937
938 %post sockets
939 %{_sbindir}/php-module-install install sockets /etc/httpd/php.ini
940
941 %preun sockets
942 if [ "$1" = "0" ]; then
943         %{_sbindir}/php-module-install remove sockets /etc/httpd/php.ini
944 fi
945
946 %post sysvsem
947 %{_sbindir}/php-module-install install sysvsem /etc/httpd/php.ini
948
949 %preun sysvsem
950 if [ "$1" = "0" ]; then
951         %{_sbindir}/php-module-install remove sysvsem /etc/httpd/php.ini
952 fi
953
954 %post sysvshm
955 %{_sbindir}/php-module-install install sysvshm /etc/httpd/php.ini
956
957 %preun sysvshm
958 if [ "$1" = "0" ]; then
959         %{_sbindir}/php-module-install remove sysvshm /etc/httpd/php.ini
960 fi
961
962 %post xml
963 %{_sbindir}/php-module-install install xml /etc/httpd/php.ini
964
965 %preun xml
966 if [ "$1" = "0" ]; then
967         %{_sbindir}/php-module-install remove xml /etc/httpd/php.ini
968 fi
969
970 %post yp
971 %{_sbindir}/php-module-install install yp /etc/httpd/php.ini
972
973 %preun yp
974 if [ "$1" = "0" ]; then
975         %{_sbindir}/php-module-install remove yp /etc/httpd/php.ini
976 fi
977
978 %post zlib
979 %{_sbindir}/php-module-install install zlib /etc/httpd/php.ini
980
981 %preun zlib
982 if [ "$1" = "0" ]; then
983         %{_sbindir}/php-module-install remove zlib /etc/httpd/php.ini
984 fi
985
986 %clean
987 rm -rf $RPM_BUILD_ROOT
988
989 %files
990 %defattr(644,root,root,755)
991 %doc {CODING_STANDARDS,CREDITS,FUNCTION_LIST.txt,Zend/ZEND_CHANGES}.gz
992 %doc {LICENSE,Zend/LICENSE,EXTENSIONS,NEWS,TODO*}.gz  
993 %doc {README.EXT_SKEL,README.SELF-CONTAINED-EXTENSIONS}.gz
994
995 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
996 %dir %{_pkglibdir}/php
997
998 #%attr(755,root,root) %{_libdir}/apache/php/*.so
999
1000 /home/httpd/html/icons/*
1001
1002 %attr(755,root,root) %{_pkglibdir}/libphp4.so
1003 %attr(755,root,root) %{_sbindir}/*
1004
1005 %files mysql
1006 %defattr(644,root,root,755)
1007 %attr(755,root,root) %{_pkglibdir}/php/mysql.so
1008
1009 %files pgsql
1010 %defattr(644,root,root,755)
1011 %attr(755,root,root) %{_pkglibdir}/php/pgsql.so
1012
1013 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
1014 %files oracle
1015 %defattr(644,root,root,755)
1016 %attr(755,root,root) %{_pkglibdir}/php/oracle.so
1017 %endif
1018
1019 %if  %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
1020 %files oci8
1021 %defattr(644,root,root,755)
1022 %attr(755,root,root) %{_pkglibdir}/php/oci8.so
1023 %endif
1024
1025 %files gd
1026 %defattr(644,root,root,755)
1027 %attr(755,root,root) %{_pkglibdir}/php/gd.so
1028
1029 %files xml
1030 %defattr(644,root,root,755)
1031 %attr(755,root,root) %{_pkglibdir}/php/xml.so
1032
1033 %files dba
1034 %defattr(644,root,root,755)
1035 %attr(755,root,root) %{_pkglibdir}/php/dba.so
1036
1037 %files dbase
1038 %defattr(644,root,root,755)
1039 %attr(755,root,root) %{_pkglibdir}/php/dbase.so
1040
1041 %files filepro
1042 %defattr(644,root,root,755)
1043 %attr(755,root,root) %{_pkglibdir}/php/filepro.so
1044
1045 %files pcre
1046 %defattr(644,root,root,755)
1047 %attr(755,root,root) %{_pkglibdir}/php/pcre.so
1048
1049 %files posix
1050 %defattr(644,root,root,755)
1051 %attr(755,root,root) %{_pkglibdir}/php/posix.so
1052
1053 %files sysvsem
1054 %defattr(644,root,root,755)
1055 %attr(755,root,root) %{_pkglibdir}/php/sysvsem.so
1056
1057 %files sysvshm
1058 %defattr(644,root,root,755)
1059 %attr(755,root,root) %{_pkglibdir}/php/sysvshm.so
1060
1061 %files yp
1062 %defattr(644,root,root,755)
1063 %attr(755,root,root) %{_pkglibdir}/php/yp.so
1064
1065 %files calendar
1066 %defattr(644,root,root,755)
1067 %attr(755,root,root) %{_pkglibdir}/php/calendar.so
1068
1069 %files bcmath
1070 %defattr(644,root,root,755)
1071 %attr(755,root,root) %{_pkglibdir}/php/bcmath.so
1072
1073 %files ftp
1074 %defattr(644,root,root,755)
1075 %attr(755,root,root) %{_pkglibdir}/php/ftp.so
1076
1077 %files zlib
1078 %defattr(644,root,root,755)
1079 %attr(755,root,root) %{_pkglibdir}/php/zlib.so
1080
1081 %files exif
1082 %defattr(644,root,root,755)
1083 %attr(755,root,root) %{_pkglibdir}/php/exif.so
1084
1085 %files recode
1086 %defattr(644,root,root,755)
1087 %attr(755,root,root) %{_pkglibdir}/php/recode.so
1088
1089 #%files session
1090 #%defattr(644,root,root,755)
1091 #%attr(755,root,root) %{_pkglibdir}/php/session.so
1092
1093 %files gettext
1094 %defattr(644,root,root,755)
1095 %attr(755,root,root) %{_pkglibdir}/php/gettext.so
1096
1097 %files imap
1098 %defattr(644,root,root,755)
1099 %attr(755,root,root) %{_pkglibdir}/php/imap.so
1100
1101 %files snmp
1102 %defattr(644,root,root,755)
1103 %attr(755,root,root) %{_pkglibdir}/php/snmp.so
1104
1105 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
1106 %files java
1107 %defattr(644,root,root,755)
1108 %attr(755,root,root) %{_pkglibdir}/php/libphp_java.so
1109 %endif
1110
1111 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
1112 %files ldap
1113 %defattr(644,root,root,755)
1114 %attr(755,root,root) %{_pkglibdir}/php/ldap.so
1115 %endif
1116
1117 %files sockets
1118 %defattr(644,root,root,755)
1119 %attr(755,root,root) %{_pkglibdir}/php/sockets.so
1120
1121 %files mcrypt
1122 %defattr(644,root,root,755)
1123 %attr(755,root,root) %{_pkglibdir}/php/mcrypt.so
1124
1125 %files mhash
1126 %defattr(644,root,root,755)
1127 %attr(755,root,root) %{_pkglibdir}/php/mhash.so
1128
1129 %files odbc
1130 %defattr(644,root,root,755)
1131 %attr(755,root,root) %{_pkglibdir}/php/odbc.so
1132
1133 %files doc
1134 %defattr(644,root,root,755)
1135 /home/httpd/html/docs/php4-doc
This page took 0.164394 seconds and 3 git commands to generate.