]> git.pld-linux.org Git - packages/php-redis.git/blob - php-redis.spec
b728b5a65b0a6c1938936833f72dd89d259c011f
[packages/php-redis.git] / php-redis.spec
1 # TODO
2 # - use external igbinary and make it's dependency optional
3 #
4 # Conditional build:
5 %bcond_without  tests           # build without tests
6
7 %define         php_name        php%{?php_suffix}
8 %define         modname redis
9 Summary:        %{modname} A PHP extension for Redis
10 Name:           %{php_name}-%{modname}
11 Version:        2.1.3
12 Release:        3
13 License:        PHP 3.01
14 Group:          Development/Languages/PHP
15 Source0:        https://github.com/nicolasff/phpredis/tarball/%{version}#/%{modname}-%{version}.tgz
16 # Source0-md5:  eb2bee7e42f7a32a38c2a45377f21086
17 Source1:        https://github.com/ukko/phpredis-phpdoc/tarball/master/%{modname}-phpdoc.tgz
18 # Source1-md5:  b7cce5ee29c6597e0fdd3557397e1b2a
19 URL:            https://github.com/nicolasff/phpredis
20 %{?with_tests:BuildRequires:    /usr/bin/php}
21 BuildRequires:  %{php_name}-devel >= 4:5.0.4
22 %{?with_tests:BuildRequires:    %{php_name}-session}
23 %{?with_tests:BuildRequires:    %{php_name}-simplexml}
24 BuildRequires:  rpmbuild(macros) >= 1.519
25 %{?requires_php_extension}
26 Requires:       %{php_name}-session
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The phpredis extension provides an API for communicating with the
31 Redis key-value store.
32
33 This extension also provides session support.
34
35 %prep
36 %setup -qc -a1
37 mv nicolasff-php%{modname}-*/* .
38 mv ukko-phpredis-phpdoc-* phpdoc
39
40 %build
41 phpize
42 %configure
43 %{__make}
44
45 %if %{with tests}
46 # simple module load test
47 %{__php} -n \
48         -dextension_dir=modules \
49         -dextension=%{php_extensiondir}/simplexml.so \
50         -dextension=%{php_extensiondir}/spl.so \
51         -dextension=%{php_extensiondir}/session.so \
52         -dextension=%{modname}.so \
53         -m > modules.log
54 grep %{modname} modules.log
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         EXTENSION_DIR=%{php_extensiondir} \
61         INSTALL_ROOT=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
64 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
65 ; Enable %{modname} extension module
66 extension=%{modname}.so
67 EOF
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %php_webserver_restart
74
75 %postun
76 if [ "$1" = 0 ]; then
77         %php_webserver_restart
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CREDITS README.markdown phpdoc
83 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
84 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.220466 seconds and 4 git commands to generate.