]> git.pld-linux.org Git - packages/phpunit.git/blob - php-phpunit-PHPUnit.spec
- updated to 3.3.16
[packages/phpunit.git] / php-phpunit-PHPUnit.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PHPUnit
3 %define         _status         stable
4 %define         _pearname       %{_class}
5 Summary:        %{_pearname} - regression testing framework for unit tests
6 Summary(pl.UTF-8):      %{_pearname} - zestaw testów regresyjnych
7 Name:           php-%{_pearname}
8 Version:        3.3.16
9 Release:        1
10 License:        BSD
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.phpunit.de/get/PHPUnit-%{version}.tgz
13 # Source0-md5:  1bafa52c00d773c84931d43e37532729
14 URL:            http://www.phpunit.de/
15 BuildRequires:  php-pear >= 4:1.1-2
16 BuildRequires:  php-pear-PEAR
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 BuildRequires:  rpmbuild(macros) >= 1.473
19 Requires:       php-common >= 3:4.1.0
20 Requires:       php-pear >= 4:1.1-2
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # exclude optional dependencies
25 %define         _noautoreq      'pear(Image/GraphViz.*)' 'pear(Log.*)'
26
27 %description
28 PHPUnit is a regression testing framework used by the developer who
29 implements unit tests in PHP. It is based upon JUnit, which can be
30 found at <http://www.junit.org/>.
31
32 In PEAR status of this package is: %{_status}.
33
34 %description -l pl.UTF-8
35 PHPUnit jest zestawem testów regresyjnych używanych przez developerów,
36 którzy implementują jednostki testowe w PHP. Jest bazowane na JUnit,
37 który można znaleźć pod adresem <http://www.junit.org/>.
38
39 Ta klasa ma w PEAR status: %{_status}.
40
41 %package tests
42 Summary:        Tests for PEAR::%{_pearname}
43 Summary(pl.UTF-8):      Testy dla PEAR::%{_pearname}
44 Group:          Development/Languages/PHP
45 Requires:       %{name} = %{version}-%{release}
46 AutoProv:       no
47 AutoReq:        no
48
49 %description tests
50 Tests for PEAR::%{_pearname}.
51
52 %description tests -l pl.UTF-8
53 Testy dla PEAR::%{_pearname}.
54
55 %prep
56 %pear_package_setup
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{php_pear_dir}
61 install -d $RPM_BUILD_ROOT%{_bindir}
62 install usr/bin/phpunit $RPM_BUILD_ROOT%{_bindir}
63 %pear_package_install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc install.log optional-packages.txt
71 %{php_pear_dir}/.registry/.channel.pear.phpunit.de/*.reg
72 %{php_pear_dir}/%{_class}
73 %attr(755,root,root) %{_bindir}/phpunit
74
75 %files tests
76 %defattr(644,root,root,755)
77 %{php_pear_dir}/tests/%{_pearname}
This page took 0.02895 seconds and 4 git commands to generate.