]> git.pld-linux.org Git - packages/php-pecl-xslcache.git/blob - php-pecl-xslcache.spec
- use php(core) as dependency to require php version
[packages/php-pecl-xslcache.git] / php-pecl-xslcache.spec
1 %define         modname xslcache
2 Summary:        %{modname} - A modification of PHP's standard XSL extension that caches the parsed XSL stylesheet representation
3 Summary(pl.UTF-8):      %{modname} - modyfikacja standardowego rozszerzenia XSL PHP, które buforuje przetworzone reprezentacje arkuszów stylów XSL
4 Name:           php-pecl-%{modname}
5 Version:        0.7.1
6 Release:        5
7 License:        PHP 3.01
8 Group:          Development/Languages/PHP
9 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
10 # Source0-md5:  1e32327f62122055ece6f78fa2b851b2
11 URL:            http://pecl.php.net/package/xslcache
12 BuildRequires:  libxslt-devel >= 1.1.0
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.519
15 %{?requires_php_extension}
16 Requires:       php(core) >= 5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The XSL Cache extension is a modification of PHP's standard XSL
21 extension that caches the parsed XSL stylesheet representation between
22 sessions for 2.5x boost in performance for sites that repeatedly apply
23 the same transform. Although there is still some further work that
24 could be done on the extension, this code is already proving
25 beneficial in production use for a few applications on the New York
26 Times' website.
27
28 %prep
29 %setup -q -c
30 mv %{modname}-%{version}/* .
31
32 %build
33 phpize
34 %configure \
35         --with-xslcache=%{_libdir} \
36         --with-xsl-exsl-dir=%{_libdir}
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
42
43 %{__make} install \
44         INSTALL_ROOT=$RPM_BUILD_ROOT \
45         EXTENSION_DIR=%{php_extensiondir}
46 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
47 ; Enable %{modname} extension module
48 extension=%{modname}.so
49 EOF
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %php_webserver_restart
56
57 %postun
58 if [ "$1" = 0 ]; then
59         %php_webserver_restart
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CREDITS
65 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
66 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.332504 seconds and 4 git commands to generate.