]> git.pld-linux.org Git - packages/php-pecl-tidy.git/blob - php-pecl-tidy.spec
- superfluous BR libtool removed
[packages/php-pecl-tidy.git] / php-pecl-tidy.spec
1 %define         _modname        tidy
2 %define         _status         stable
3
4 Summary:        %{_modname} - Tidy HTML Repairing and Parsing
5 Summary(pl):    %{_modname} - Czyszczenie, naprawa oraz parsowanie HTML
6 Name:           php-pecl-%{_modname}
7 Version:        1.1
8 Release:        0.1
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  ecb2d3c62e1d720265a65dfb7e00e081
13 URL:            http://pecl.php.net/package/tidy/
14 BuildRequires:  php-devel
15 BuildRequires:  tidy-devel
16 Requires:       php-common
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 Tidy is a binding for the Tidy HTML clean and repair utility which
25 allows you to not only clean and otherwise manipluate HTML documents,
26 but also traverse the document tree using the Zend Engine 2 OO
27 semantics.
28
29 In PECL status of this package is: %{_status}.
30
31 %description -l pl
32 Tidy jest dowi±zaniem do narzêdzia "Tidy HTML clean and repair", które
33 pozwala nie tylko na czyszczenie oraz manipulacjê dokumentami HTML,
34 ale tak¿e na przemierzanie przez strukturê dokumentu za pomoc±
35 zorientowanej obiektowo semantyki silnika Zend Engine 2.
36
37 To rozszerzenie ma w PECL status: %{_status}.
38
39 %prep
40 %setup -q -c
41
42 %build
43 cd %{_modname}-%{version}
44 phpize
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 cd %{_modname}-%{version}
52 %{__make} install \
53         INSTALL_ROOT=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
60
61 %preun
62 if [ "$1" = "0" ]; then
63         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc %{_modname}-%{version}/{CREDITS,TODO,README}
69 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.051761 seconds and 4 git commands to generate.