]> git.pld-linux.org Git - packages/php-pecl-syck.git/blob - php-pecl-syck.spec
05d4d5a0dcd8fb5803c518907124fd34c4517e04
[packages/php-pecl-syck.git] / php-pecl-syck.spec
1 %define         _modname        syck
2 %define         _status         beta
3 Summary:        %{_modname} - YAML-1.0 parser and emitter
4 Summary(pl.UTF-8):      %{_modname} - analizator i emiter YAML-1.0
5 Name:           php-pecl-%{_modname}
6 Version:        0.9.3
7 Release:        1
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  cbbe638b431f74eec71c76588cd14f7e
12 URL:            http://pecl.php.net/package/syck/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 BuildRequires:  syck-devel
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 Requires:       php-pecl-hash
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 A binding to the Syck library.
23
24 YAML(tm) (rhymes with "camel") is a straightforward machine parsable
25 data serialization format designed for human readability and
26 interaction with scripting languages. YAML is optimized for data
27 serialization, configuration settings, log files, Internet messaging
28 and filtering.
29
30 In PECL status of this extension is: %{_status}.
31
32 %description -l pl.UTF-8
33 Dowiązania do biblioteki Syck.
34
35 YAML(tm) (rymuje się ze słowem "camel") to prosty do analizy format
36 serializacji danych zaprojektowany pod kątem czytelności dla człowieka
37 i interakcji z językami skryptowymi. YAML jest zoptymalizowany pod
38 kątem wykorzystania w celu serializacji danych, przechowywania opcji
39 konfiguracyjnych, logów, komunikatorów internetowych czy różnorakich
40 filtrów.
41
42 To rozszerzenie ma w PECL status: %{_status}.
43
44 %prep
45 %setup -q -c
46
47 %build
48 cd %{_modname}-%{version}
49 phpize
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
56
57 %{__make} install \
58         -C %{_modname}-%{version} \
59         INSTALL_ROOT=$RPM_BUILD_ROOT \
60         EXTENSION_DIR=%{php_extensiondir}
61 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
62 ; Enable %{_modname} extension module
63 extension=%{_modname}.so
64 EOF
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %php_webserver_restart
71
72 %postun
73 if [ "$1" = 0 ]; then
74         %php_webserver_restart
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc %{_modname}-%{version}/{CHANGELOG,TODO}
80 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
81 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.062913 seconds and 3 git commands to generate.