]> git.pld-linux.org Git - packages/php-pecl-stats.git/blob - php-pecl-stats.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-stats.git] / php-pecl-stats.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname stats
3 %define         status          stable
4 Summary:        %{modname} - extension with routines for statistical computation
5 Summary(pl.UTF-8):      %{modname} - rozszerzenie z funkcjami do wykonywania obliczeń statystycznych
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.2
8 Release:        4
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  96f105be1e76fbc5dca424057066e4d8
13 URL:            http://pecl.php.net/package/stats/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Provides:       php(%{modname}) = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Extension that provides few dozens routines for statistical
23 computation, such as stats_absolute_deviation(), stats_covariance(),
24 harmonic_mean() and others.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 To rozszerzenie dostarcza wiele różnych funkcji do wykonywania
30 obliczeń statystycznych, takich jak stats_absolute_deviation(),
31 stats_covariance(), harmonic_mean() i inne.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38
39 %build
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
47 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49 ; Enable %{modname} extension module
50 extension=%{modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc CREDITS TODO
67 %doc tests
68 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.071304 seconds and 3 git commands to generate.