]> git.pld-linux.org Git - packages/php-pecl-statgrab.git/blob - php-pecl-statgrab.spec
4d1a46cdce9815f7245957a27ba329db1647f05e
[packages/php-pecl-statgrab.git] / php-pecl-statgrab.spec
1 %define         _modname        statgrab
2 %define         _smodname       Statgrab
3 %define         _status         stable
4 Summary:        %{_modname} - libstatgrab bindings
5 Summary(pl):    %{_modname} - dowi±zania biblioteki libstatgrab
6 Name:           php-pecl-%{_modname}
7 Version:        0.6.0
8 Release:        2
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  5e8e659e28d95da57c3d5a694cfb5af4
13 URL:            http://pecl.php.net/package/statgrab/
14 BuildRequires:  libstatgrab-devel >= 0.10
15 BuildRequires:  php-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 %{?requires_php_extension}
18 Requires:       php-common >= 4:5.0.4
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 libstatgrab is a library that provides a common interface for
24 retrieving a variety of system statistics on a number of *NIX like
25 systems.
26
27 This extension allows you to call the functions made available by
28 libstatgrab library.
29
30 In PECL status of this package is: %{_status}.
31
32 %description -l pl
33 libstatgrab to biblioteka dostarczaj±ca wspólny interfejs do
34 odczytywania ró¿nych statystyk systemowych na wielu systemach
35 uniksowych.
36
37 To rozszerzenie pozwala wywo³ywaæ funkcje udostêpniane przez
38 bibliotekê libstatgrab.
39
40 To rozszerzenie ma w PECL status: %{_status}.
41
42 %prep
43 %setup -q -c
44
45 %build
46 cd %{_smodname}-%{version}
47 phpize
48 %configure
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
54
55 install %{_smodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
57 ; Enable %{_modname} extension module
58 extension=%{_modname}.so
59 EOF
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %php_webserver_restart
66
67 %postun
68 if [ "$1" = 0 ]; then
69         %php_webserver_restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc %{_smodname}-%{version}/CREDITS
75 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
76 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.333892 seconds and 2 git commands to generate.