]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blob - php-pecl-ssh2.spec
e2046ef0c6d6ff8103f7a468fafeb378b3952623
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
1 %define         modname ssh2
2 %define         status          beta
3 Summary:        %{modname} - bindings for the libssh2 library
4 Summary(pl.UTF-8):      %{modname} - dowiązania do biblioteki libssh2
5 Name:           php-pecl-%{modname}
6 Version:        0.11.0
7 Release:        2
8 License:        PHP
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  9f5dcd5b92299458389038f7318cbc46
12 Patch0:         php-pecl-ssh2-libssh2.patch
13 URL:            http://pecl.php.net/package/ssh2/
14 BuildRequires:  libssh2-devel >= 0.16
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  php-devel >= 4:5.0.4
17 BuildRequires:  rpmbuild(macros) >= 1.344
18 %{?requires_php_extension}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Provides bindings to the functions of libssh2 which implements the
23 SSH2 protocol.
24
25 In PECL status of this extension is: %{status}.
26
27 %description -l pl.UTF-8
28 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
29 implementującej protokół SSH2.
30
31 To rozszerzenie ma w PECL status: %{status}.
32
33 %prep
34 %setup -qc
35 mv %{modname}-%{version}/* .
36 %patch0 -p0
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
66 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.042526 seconds and 2 git commands to generate.