]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
- new
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         _modname        sasl
2 %define         _status         alpha
3
4 Summary:        %{_modname} - Cyrus SASL Extension
5 Summary(pl):    %{_modname} - Rozszerzenie Cyrus SASL
6 Name:           php-pecl-%{_modname}
7 Version:        0.1.0
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 URL:            http://pecl.php.net/package/sasl/
14 BuildRequires:  cyrus-sasl-devel
15 BuildRequires:  libtool
16 BuildRequires:  php-devel
17 Requires:       php-common
18 Obsoletes:      php-pear-%{_modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sysconfdir     /etc/php
22 %define         extensionsdir   %{_libdir}/php
23
24 %description
25 SASL is the Simple Authentication and Security Layer (as defined by
26 RFC 2222). It provides a system for adding plugable authenticating
27 support to connection-based protocols. The SASL Extension for PHP
28 makes the Cyrus SASL library functions available to PHP. It aims to
29 provide a 1-to-1 wrapper around the SASL library to provide the
30 greatest amount of implementation flexibility. To that end, it is
31 possible to build both a client-side and server-side SASL
32 implementation entirely in PHP.
33
34 In PECL status of this extension is: %{_status}.
35
36 #%description -l pl
37 #
38 #To rozszerzenie ma w PECL status: %{_status}.
39
40 %prep
41 %setup -q -c
42
43 %build
44 cd %{_modname}-%{version}
45 phpize
46 %configure
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{extensionsdir}
52
53 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
60
61 %preun
62 if [ "$1" = "0" ]; then
63         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc %{_modname}-%{version}/docs/TODO
69 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.07074 seconds and 4 git commands to generate.