]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
- one more try to build this on amd64
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         _modname        sasl
2 %define         _status         alpha
3
4 Summary:        %{_modname} - Cyrus SASL extension
5 Summary(pl):    %{_modname} - rozszerzenie Cyrus SASL
6 Name:           php-pecl-%{_modname}
7 Version:        0.1.0
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 Patch0:         %{name}-lib_fix.patch
14 Patch1:         %{name}-lib64_fix.patch
15 URL:            http://pecl.php.net/package/sasl/
16 BuildRequires:  cyrus-sasl-devel
17 BuildRequires:  libtool
18 BuildRequires:  php-devel
19 Requires:       php-common
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc/php
24 %define         extensionsdir   %{_libdir}/php
25
26 %description
27 SASL is the Simple Authentication and Security Layer (as defined by
28 RFC 2222). It provides a system for adding plugable authenticating
29 support to connection-based protocols. The SASL extension for PHP
30 makes the Cyrus SASL library functions available to PHP. It aims to
31 provide a 1-to-1 wrapper around the SASL library to provide the
32 greatest amount of implementation flexibility. To that end, it is
33 possible to build both a client-side and server-side SASL
34 implementation entirely in PHP.
35
36 In PECL status of this extension is: %{_status}.
37
38 #%description -l pl
39 #
40 #To rozszerzenie ma w PECL status: %{_status}.
41
42 %prep
43 %setup -q -c
44 # Ugly, could be done somehow prettier (one combined patch?)
45 %ifnarch amd64
46 %patch0 -p1
47 %else
48 %patch1 -p1
49 %endif
50
51 %build
52 cd %{_modname}-%{version}
53 phpize
54 %configure
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{extensionsdir}
60
61 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
68
69 %preun
70 if [ "$1" = "0" ]; then
71         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc %{_modname}-%{version}/docs/TODO
77 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.040984 seconds and 4 git commands to generate.