]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
- superfluous BR libtool removed
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         _modname        sasl
2 %define         _status         alpha
3
4 Summary:        %{_modname} - Cyrus SASL extension
5 Summary(pl):    %{_modname} - rozszerzenie Cyrus SASL
6 Name:           php-pecl-%{_modname}
7 Version:        0.1.0
8 Release:        2
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 Patch0:         %{name}-lib_fix.patch
14 Patch1:         %{name}-lib64_fix.patch
15 URL:            http://pecl.php.net/package/sasl/
16 BuildRequires:  cyrus-sasl-devel
17 BuildRequires:  php-devel
18 Requires:       php-common
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/php
23 %define         extensionsdir   %{_libdir}/php
24
25 %description
26 SASL is the Simple Authentication and Security Layer (as defined by
27 RFC 2222). It provides a system for adding plugable authenticating
28 support to connection-based protocols. The SASL extension for PHP
29 makes the Cyrus SASL library functions available to PHP. It aims to
30 provide a 1-to-1 wrapper around the SASL library to provide the
31 greatest amount of implementation flexibility. To that end, it is
32 possible to build both a client-side and server-side SASL
33 implementation entirely in PHP.
34
35 In PECL status of this extension is: %{_status}.
36
37 %description -l pl
38 SASL to warstwa prostego uwierzytelnienia i bezpieczeñstwa (Simple
39 Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
40 system do dodawania wtyczek obs³uguj±cych uwierzytelnianie do
41 protoko³ów opartych na po³±czeniach. Rozszerzenie SASL dla PHP
42 udostêpnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
43 dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostêpniæ jak
44 najwiêksz± elastyczno¶æ implementacji. W tym celu mo¿liwe jest
45 zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
46 ca³kowicie w PHP.
47
48 To rozszerzenie ma w PECL status: %{_status}.
49
50 %prep
51 %setup -q -c
52 # Ugly, could be done somehow prettier (one combined patch?)
53 %if "%{_lib}" == "lib64"
54 %patch1 -p1
55 %else
56 %patch0 -p1
57 %endif
58
59 %build
60 cd %{_modname}-%{version}
61 phpize
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{extensionsdir}
68
69 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
76
77 %preun
78 if [ "$1" = "0" ]; then
79         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc %{_modname}-%{version}/docs/TODO
85 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.031327 seconds and 4 git commands to generate.