]> git.pld-linux.org Git - packages/php-pecl-msession.git/blob - php-pecl-msession.spec
- release 5 (by relup.sh)
[packages/php-pecl-msession.git] / php-pecl-msession.spec
1 # NOTE:
2 # there's no maintainer for the pecl project, so consider this
3 # extension dead.
4 %define         php_name        php%{?php_suffix}
5 %define         modname msession
6 %define         status          stable
7 Summary:        %{modname} - extension module for PHP
8 Summary(pl.UTF-8):      %{modname} - moduł msession dla PHP
9 Name:           %{php_name}-pecl-%{modname}
10 Version:        1.0
11 Release:        5
12 License:        PHP 3.01
13 Group:          Development/Languages/PHP
14 # extracted from php-5.1.2 sources as pecl/msession appears to be older
15 Source0:        %{modname}.tar.bz2
16 # Source0-md5:  a256f635be818a7247d7be15061256f0
17 Patch0:         msession-shared-lib.patch
18 URL:            http://pecl.php.net/package/msession/
19 BuildRequires:  phoenix-devel
20 BuildRequires:  %{php_name}-devel >= 3:5.0.0
21 BuildRequires:  rpmbuild(macros) >= 1.650
22 %{?requires_php_extension}
23 Requires:       php-common >= 4:5.0.4
24 Provides:       php(msession)
25 Obsoletes:      php-msession
26 ExclusiveArch:  %{ix86}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 msession is a high speed session daemon which can run either locally
31 or remotely. It is designed to provide consistent session management
32 for a PHP web farm.
33
34 In PECL status of this extension is: %{status}.
35
36 %description -l pl.UTF-8
37 Moduł PHP dodający umożliwiający korzystanie z demona msession. Jest
38 to demon szybkiej obsługi sesji, który może działać lokalnie lub na
39 innej maszynie. Służy do zapewniania spójnej obsługi sesji dla farmy
40 serwerów.
41
42 To rozszerzenie ma w PECL status: %{status}.
43
44 %prep
45 %setup -q -n %{modname}
46 %patch0 -p3
47
48 %build
49 phpize
50 %configure \
51         --with-msession=shared,/usr
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
57
58 install modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
59 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
60 ; Enable %{modname} extension module
61 extension=%{modname}.so
62 EOF
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %php_webserver_restart
69
70 %postun
71 if [ "$1" = 0 ]; then
72         %php_webserver_restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
78 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.071314 seconds and 4 git commands to generate.