]> git.pld-linux.org Git - packages/php-pecl-mono.git/blob - php-pecl-mono.spec
- more specific URL
[packages/php-pecl-mono.git] / php-pecl-mono.spec
1 %define         _modname        mono
2 %define         _status         beta
3 Summary:        Allows you to access .NET assemblies from PHP
4 Summary(pl):    Pozwala na dostêp do wstawek .NET w PHP
5 Name:           php-pecl-%{_modname}
6 Version:        0.7
7 Release:        0.1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  23639443898018a743250a62b1873a89
12 URL:            http://pear.php.net/package/%{_pearname}/
13 BuildRequires:  php-devel
14 BuildRequires:  mono-devel
15 Requires:       php-common
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sysconfdir     /etc/php
19 %define         extensionsdir   %{_libdir}/php
20
21 %description
22 A C extension that interfaces with the mono library to allow access to
23 .NET assemblies.
24
25 This extension has in PEAR status: %{_status}.
26
27 %description -l pl
28 Rozszerzenie w C, które jest interfejsem do biblioteki mono,
29 pozwalaj±cym na dostêp do wstawek w .NET.
30
31 To rozszerzenie ma w PEAR status: %{_status}.
32
33 %prep
34 %setup -q -c
35
36 %build
37 cd %{_modname}-%{version}
38 phpize
39 %configure \
40         --with-%{_modname}
41
42 %{__make} \
43 CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11/" \
44         CFLAGS_CLEAN="%{rpmcflags}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{extensionsdir}
49
50 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php.ini
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
66 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.063251 seconds and 4 git commands to generate.