]> git.pld-linux.org Git - packages/php-pecl-mono.git/blob - php-pecl-mono.spec
- rebuild with zts and debug requires
[packages/php-pecl-mono.git] / php-pecl-mono.spec
1 # TODO
2 # - doesn't compile
3 %define         _modname        mono
4 %define         _status         beta
5 %define         _sysconfdir     /etc/php
6 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
7 Summary:        Allows you to access .NET assemblies from PHP
8 Summary(pl):    Pozwala na dostêp do wstawek .NET w PHP
9 Name:           php-pecl-%{_modname}
10 Version:        0.7
11 Release:        0.2
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
15 # Source0-md5:  23639443898018a743250a62b1873a89
16 URL:            http://pecl.php.net/package/mono/
17 BuildRequires:  mono-devel
18 BuildRequires:  php-devel >= 3:5.0.0
19 BuildRequires:  rpmbuild(macros) >= 1.254
20 %{?requires_php_extension}
21 Requires:       %{_sysconfdir}/conf.d
22 Obsoletes:      php-mono
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A C extension that interfaces with the mono library to allow access to
27 .NET assemblies.
28
29 In PECL status of this package is: %{_status}.
30
31 %description -l pl
32 Rozszerzenie w C, które jest interfejsem do biblioteki mono,
33 pozwalaj±cym na dostêp do wstawek w .NET.
34
35 To rozszerzenie ma w PECL status: %{_status}.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure \
44         --with-%{_modname}
45
46 %{__make} \
47 CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11/" \
48         CFLAGS_CLEAN="%{rpmcflags}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
53
54 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
55 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
56 ; Enable %{_modname} extension module
57 extension=%{_modname}.so
58 EOF
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
65 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
66
67 %postun
68 if [ "$1" = 0 ]; then
69         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
70         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
76 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
77 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.054676 seconds and 3 git commands to generate.