]> git.pld-linux.org Git - packages/php-pecl-mono.git/blob - php-pecl-mono.spec
125eda953426510c2f9d2eb0d91c2d2d1da4d7aa
[packages/php-pecl-mono.git] / php-pecl-mono.spec
1 # TODO
2 # - doesn't compile
3 # - package examples into examplesdir
4 %define         _modname        mono
5 %define         _status         beta
6 Summary:        Allows you to access .NET assemblies from PHP
7 Summary(pl):    Pozwala na dostêp do wstawek .NET w PHP
8 Name:           php-pecl-%{_modname}
9 Version:        0.7
10 Release:        0.2
11 License:        PHP 2.02
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
14 # Source0-md5:  23639443898018a743250a62b1873a89
15 URL:            http://pecl.php.net/package/mono/
16 BuildRequires:  mono-devel
17 BuildRequires:  php-devel >= 3:5.0.0
18 BuildRequires:  rpmbuild(macros) >= 1.344
19 %{?requires_php_extension}
20 Requires:       php-common >= 4:5.0.4
21 Obsoletes:      php-mono
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A C extension that interfaces with the mono library to allow access to
26 .NET assemblies.
27
28 In PECL status of this package is: %{_status}.
29
30 %description -l pl
31 Rozszerzenie w C, które jest interfejsem do biblioteki mono,
32 pozwalaj±cym na dostêp do wstawek w .NET.
33
34 To rozszerzenie ma w PECL status: %{_status}.
35
36 %prep
37 %setup -q -c
38
39 %build
40 cd %{_modname}-%{version}
41 phpize
42 %configure \
43         --with-%{_modname}
44
45 %{__make} \
46 CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11/" \
47         CFLAGS_CLEAN="%{rpmcflags}"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
52
53 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
54 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
55 ; Enable %{_modname} extension module
56 extension=%{_modname}.so
57 EOF
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 %php_webserver_restart
64
65 %postun
66 if [ "$1" = 0 ]; then
67         %php_webserver_restart
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
73 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
74 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.085799 seconds and 2 git commands to generate.