]> git.pld-linux.org Git - packages/php-pecl-mono.git/blob - php-pecl-mono.spec
- initial release - NFY
[packages/php-pecl-mono.git] / php-pecl-mono.spec
1 %define         _modname        mono
2 %define         _status         alpha
3 Summary:        Allows you to access .NET assemblies from PHP
4 Summary(pl):    Pozwala na dostêp do wstawek .NET w PHP
5 Name:           php-pecl-%{_modname}
6 Version:        0.3.1
7 Release:        0.1
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
11 URL:            http://pear.php.net/
12 BuildRequires:  php-devel
13 Requires:       php-common
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _sysconfdir     /etc/php
17 %define         extensionsdir   %{_libdir}/php
18
19 %description
20 A C extension that interfaces with the mono library to allow access to
21 .NET assemblies.
22
23 This class has in PEAR status: %{_status}.
24
25 %description -l pl
26 Rozszerzenie w C, które jest interfejsem do biblioteki mono,
27 pozwalaj±cym na dostêp do wstawek w .NET.
28
29 Ta klasa ma w PEAR status: %{_status}.
30
31 %prep
32 %setup -q -c
33
34 %build
35 cd %{_modname}-%{version}
36 phpize
37 %configure \
38         --with-%{_modname}
39
40 %{__make} \
41 CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11/" \
42         CFLAGS_CLEAN="%{rpmcflags}"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{extensionsdir}
47
48 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php.ini
55
56 %preun
57 if [ "$1" = "0" ]; then
58         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
64 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.079797 seconds and 3 git commands to generate.