]> git.pld-linux.org Git - packages/php-pecl-mailparse.git/blob - php-pecl-mailparse.spec
- do not use macros in URL
[packages/php-pecl-mailparse.git] / php-pecl-mailparse.spec
1 %define         _modname        mailparse
2 %define         _status         beta
3
4 Summary:        Email message manipulation
5 Summary(pl):    Obrabianie wiadomo¶ci E-mail
6 Name:           php-pecl-%{_modname}
7 Version:        0.9.2
8 Release:        0.1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pear.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  73478cc638522aefb7315cc1976f76d4
13 URL:            http://pear.php.net/package/mailparse/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  php-devel
17 Requires:       php-common
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 Mailparse is an extension for parsing and working with email messages.
25 It can deal with rfc822 and rfc2045 (MIME) compliant messages.
26
27 This extension has in PEAR status: %{_status}.
28
29 %description -l pl
30 Mailparse to rozszerzenie do analizy i pracy z wiadomo¶ciami poczty
31 elektronicznej. Radzi sobie z wiadomo¶ciami zgodnymi z RFC822 oraz
32 RFC2024 (MIME).
33
34 To rozszerzenie ma w PEAR status: %{_status}.
35
36 %prep
37 %setup -q -c
38
39 %build
40 cd %{_modname}-%{version}
41 phpize
42 %{__aclocal}
43 %{__autoconf}
44 %configure \
45         --with-%{_modname}=%{_prefix}/X11R6/include/X11/
46
47 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{extensionsdir}
52
53 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php.ini
60
61 %preun
62 if [ "$1" = "0" ]; then
63         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php.ini
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc %{_modname}-%{version}/CREDITS
69 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.072202 seconds and 3 git commands to generate.