]> git.pld-linux.org Git - packages/php-pecl-lzf.git/blob - php-pecl-lzf.spec
f09cf23551d041511fbb43ee785efcf79c42b18b
[packages/php-pecl-lzf.git] / php-pecl-lzf.spec
1 # TODO
2 # - use system liblzf
3 %define         _modname        lzf
4 %define         _modname_c      LZF
5 %define         _status         stable
6 Summary:        %{_modname} - (de)compression
7 Summary(pl):    %{_modname} - (de)kompresja
8 Name:           php-pecl-%{_modname}
9 Version:        1.4
10 Release:        1
11 License:        PHP 2.02
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{_modname_c}-%{version}.tgz
14 # Source0-md5:  f35d75b70bee9741946c4cb9275a74ab
15 URL:            http://pecl.php.net/package/LZF/
16 BuildRequires:  php-devel >= 3:5.0.0
17 BuildRequires:  rpmbuild(macros) >= 1.344
18 %{?requires_php_extension}
19 Requires:       php-common >= 4:5.0.4
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package handles LZF de/compression.
25
26 In PECL status of this package is: %{_status}.
27
28 %description -l pl
29 Ten pakiet dostarczaj obs³ugê (de)kompresji archiwów LZF.
30
31 To rozszerzenie ma w PECL status: %{_status}.
32
33 %prep
34 %setup -q -c
35
36 %build
37 cd %{_modname_c}-%{version}
38 phpize
39 %configure \
40         --enable-lzf
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46
47 install %{_smodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
48 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
49 ; Enable %{_modname} extension module
50 extension=%{_modname}.so
51 EOF
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %php_webserver_restart
58
59 %postun
60 if [ "$1" = 0 ]; then
61         %php_webserver_restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.036364 seconds and 3 git commands to generate.