]> git.pld-linux.org Git - packages/php-pecl-lchash.git/blob - php-pecl-lchash.spec
31daa7738dbd0cdc3db2eda878a40f3423677e3c
[packages/php-pecl-lchash.git] / php-pecl-lchash.spec
1 %define         _modname        lchash
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5
6 Summary:        %{_modname} - Libc Hash Interface
7 Summary(pl):    %{_modname} - interfejs tablic haszuj±cych libc
8 Name:           php-pecl-%{_modname}
9 Version:        0.9.1
10 Release:        1
11 License:        PHP
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
14 # Source0-md5:  1ad9261f2461db033423e797e67c301c
15 URL:            http://pecl.php.net/package/lchash/
16 BuildRequires:  libtool
17 BuildRequires:  php-devel >= 3:5.0.0
18 BuildRequires:  rpmbuild(macros) >= 1.254
19 Requires:       %{_sysconfdir}/conf.d
20 %{?requires_php_extension}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The LCHASH extension provides interface to libc implementation of hash
25 tables described by POSIX 1003.1-2001.
26
27 In PECL status of this extension is: %{_status}.
28
29 %description -l pl
30 Rozszerzenie LCHASH dostarcza interfejsu do implementacji libc tablic
31 haszuj±cych okre¶lonych przez standard POSIX 1003.1-2001.
32
33 To rozszerzenie ma w PECL status: %{_status}.
34
35 %prep
36 %setup -q -c
37
38 %build
39 cd %{_modname}-%{version}
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
47
48 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
50 ; Enable %{_modname} extension module
51 extension=%{_modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
59 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
64         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
70 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
71 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.095999 seconds and 3 git commands to generate.