]> git.pld-linux.org Git - packages/php-pecl-intl.git/blob - php-pecl-intl.spec
- fix build against php53; rel 2
[packages/php-pecl-intl.git] / php-pecl-intl.spec
1 %define         modname         intl
2 %define         status          stable
3 Summary:        %{modname} - Internationalization extension
4 Summary(pl.UTF-8):      %{modname} - rozszerzenie internacjonalizacji
5 Name:           php-pecl-%{modname}
6 Version:        1.1.1
7 Release:        2
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  f69e662ff0125eb991597be9b5116d96
12 Patch0:         zend_arg_info_static.patch
13 Patch1:         z_refcount.patch
14 URL:            http://pecl.php.net/package/intl/
15 BuildRequires:  libicu-devel >= 3.4.0-1
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  php-devel >= 3:5.0.0
18 BuildRequires:  pkgconfig
19 BuildRequires:  re2c
20 BuildRequires:  rpmbuild(macros) >= 1.344
21 %{?requires_php_extension}
22 Provides:       php(intl)
23 Obsoletes:      php-pecl-idn
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Internationalization extension implements ICU library functionality in
28 PHP.
29
30 Since 1.0.2 it also integrates IDN functions.
31
32 In PECL status of this extension is: %{status}.
33
34 %description -l pl.UTF-8
35 Rozszerzenie to posiada zaimplementowaną obsługę biblioteki ICU.
36
37 To rozszerzenie ma w PECL status: %{status}.
38
39 %prep
40 %setup -qc
41 mv %{modname}-%{version}/* .
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 phpize
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
53
54 %{__make} install \
55         EXTENSION_DIR=%{php_extensiondir} \
56         INSTALL_ROOT=$RPM_BUILD_ROOT
57 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
58 ; Enable %{modname} extension module
59 extension=%{modname}.so
60 EOF
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %php_webserver_restart
67
68 %postun
69 if [ "$1" = 0 ]; then
70         %php_webserver_restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc doc/* CREDITS
76 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
77 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.243306 seconds and 4 git commands to generate.