]> git.pld-linux.org Git - packages/php-pecl-intl.git/blob - php-pecl-intl.spec
- rel 2: O: php-pecl-idn
[packages/php-pecl-intl.git] / php-pecl-intl.spec
1 %define         _modname        intl
2 %define         _status         stable
3 Summary:        %{_modname} - Internationalization extension
4 Summary(pl.UTF-8):      %{_modname} - rozszerzenie internacjonalizacji
5 Name:           php-pecl-%{_modname}
6 Version:        1.0.3
7 Release:        2
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  eda2e2f1b51c146e385f282f3c3df95b
12 URL:            http://pecl.php.net/package/intl/
13 BuildRequires:  libicu-devel >= 3.4.0-1
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 Obsoletes:      php-pecl-idn
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Internationalization extension implements ICU library functionality in
23 PHP.
24
25 In PECL status of this extension is: %{_status}.
26
27 %description -l pl.UTF-8
28 Rozszerzenie to posiada zaimplementowaną obsługę biblioteki ICU.
29
30 To rozszerzenie ma w PECL status: %{_status}.
31
32 %prep
33 %setup -q -c
34
35 %build
36 cd %{_modname}-%{version}
37 phpize
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
44
45 %{__make} install \
46         -C %{_modname}-%{version} \
47         INSTALL_ROOT=$RPM_BUILD_ROOT \
48         EXTENSION_DIR=%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
50 ; Enable %{_modname} extension module
51 extension=%{_modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc %{_modname}-%{version}/{doc/,CREDITS}
68 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
69 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.072835 seconds and 4 git commands to generate.