]> git.pld-linux.org Git - packages/php-pecl-idn.git/blob - php-pecl-idn.spec
- drop obsoletes that never existed, modernize spec
[packages/php-pecl-idn.git] / php-pecl-idn.spec
1 %define         modname idn
2 %define         status  beta
3 Summary:        %{modname} - binding to the GNU libidn
4 Summary(pl.UTF-8):      %{modname} - wiązanie do GNU libidn
5 Name:           php-pecl-idn
6 Version:        0.2.0
7 Release:        2
8 License:        PHP 3.0
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  f42dadf9b15bfc897458ff8735f05f78
12 URL:            http://pecl.php.net/package/idn/
13 BuildRequires:  libidn-devel
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Binding to the GNU libidn for using Internationalized Domain Names.
22
23 In PECL status of this package is: %{status}.
24
25 %description -l pl.UTF-8
26 Wiązanie do GNU libidn do używania umiędzynarodowionych nazw domen
27 (Internationalized Domain Names).
28
29 To rozszerzenie ma w PECL status: %{status}.
30
31 %prep
32 %setup -qc
33 mv %{modname}-%{version}/* .
34
35 %build
36 phpize
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
43
44 %{__make} install \
45         EXTENSION_DIR=%{php_extensiondir} \
46         INSTALL_ROOT=$RPM_BUILD_ROOT
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.475769 seconds and 3 git commands to generate.