]> git.pld-linux.org Git - packages/php-pecl-http.git/blob - php-pecl-http.spec
- updated to 0.7.0
[packages/php-pecl-http.git] / php-pecl-http.spec
1 %define         _modname        http
2 %define         _fmodname       pecl_http
3 %define         _status         beta
4
5 Summary:        %{_modname} - extended HTTP support
6 Summary(pl):    %{_modname} - rozszerzona obs³uga protoko³u HTTP
7 Name:           php-pecl-%{_modname}
8 Version:        0.7.0
9 Release:        1
10 License:        PHP 3.0
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
13 # Source0-md5:  c9e24ea9be29871fc30b7fea9caa8eaa
14 URL:            http://pecl.php.net/package/pecl_http/
15 BuildRequires:  libtool
16 BuildRequires:  php-devel >= 3:5.0.0
17 Requires:       php-common >= 3:5.0.0
18 Obsoletes:      php-pear-%{_modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sysconfdir     /etc/php
22 %define         extensionsdir   %{_libdir}/php
23
24 %description
25 Currently implemented features:
26 - Building absolute URIs
27 - RFC compliant HTTP redirects
28 - RFC compliant HTTP date handling
29 - Parsing of HTTP headers and responses
30 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
31   ETag generation from buffered output)
32 - Sending data/files/streams with (multiple) ranges support
33 - Negotiating user preferred language/charset
34 - Convenient request functions to HEAD/GET/POST if libcurl is available
35 - HTTP auth hooks (Basic)
36 - HTTPi, HTTPi_Response and HTTPi_Request (with libcurl) classes
37
38 In PECL status of this extension is: %{_status}.
39
40 %description -l pl
41 Aktualnie zaimplementowane mo¿liwo¶ci:
42 - tworzenie bezwzglêdnych URI
43 - zgodne z RFC przekierowania HTTP
44 - zgodna z RFC obs³uga daty HTTP
45 - przetwarzanie nag³ówków i odpowiedzi HTTP
46 - buforowanie z u¿yciem "Last-Modified" i/lub ETagów (z opcjê
47   generowania "w locie" ETagów z buforowanego wyj¶cia)
48 - wysy³anie danych/plików/strumieni z obs³ug± (wielu) przedzia³ów
49 - negocjacja preferowanego przez u¿ytkownika jêzyka/zestawu znaków
50 - wygodne funkcje do ¿±dañ HEAD/GET/POST je¶li dostêpna jest libcurl
51 - wywo³ania HTTP auth (Basic)
52 - klasy HTTPi, HTTPi_Response i HTTPi_Request (z u¿yciem libcurl)
53
54 To rozszerzenie ma w PECL status: %{_status}.
55
56 %prep
57 %setup -q -c
58
59 %build
60 cd %{_fmodname}-%{version}
61 phpize
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{extensionsdir}
68
69 install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
76
77 %preun
78 if [ "$1" = "0" ]; then
79         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc %{_fmodname}-%{version}/{docs,EXPERIMENTAL}
85 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.097229 seconds and 4 git commands to generate.