]> git.pld-linux.org Git - packages/php-pecl-http.git/blob - php-pecl-http.spec
d32fbdc336220707c832d93161b78491a94b2acc
[packages/php-pecl-http.git] / php-pecl-http.spec
1 %define         _modname        http
2 %define         _fmodname       pecl_http
3 %define         _status         beta
4 %define         _sysconfdir     /etc/php
5 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
6
7 Summary:        %{_modname} - extended HTTP support
8 Summary(pl):    %{_modname} - rozszerzona obs³uga protoko³u HTTP
9 Name:           php-pecl-%{_modname}
10 Version:        0.13.0
11 Release:        1
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
15 # Source0-md5:  97d867fced7c93b7b6e016044faa7579
16 URL:            http://pecl.php.net/package/pecl_http/
17 BuildRequires:  php-devel >= 3:5.0.0
18 Requires:       %{_sysconfdir}/conf.d
19 %{?requires_php_extension}
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Currently implemented features:
25 - Building absolute URIs
26 - RFC compliant HTTP redirects
27 - RFC compliant HTTP date handling
28 - Parsing of HTTP headers and messages
29 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
30   ETag generation from buffered output)
31 - Sending data/files/streams with (multiple) ranges support
32 - Negotiating user preferred language/charset
33 - Convenient request functions to HEAD/GET/POST if libcurl is
34   available
35 - HTTP auth hooks (Basic)
36 - PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
37   HttpMessage
38
39 In PECL status of this extension is: %{_status}.
40
41 %description -l pl
42 Aktualnie zaimplementowane mo¿liwo¶ci:
43 - tworzenie bezwzglêdnych URI
44 - zgodne z RFC przekierowania HTTP
45 - zgodna z RFC obs³uga daty HTTP
46 - przetwarzanie nag³ówków i wiadomo¶ci HTTP
47 - buforowanie z u¿yciem "Last-Modified" i/lub ETagów (z opcjê
48   generowania "w locie" ETagów z buforowanego wyj¶cia)
49 - wysy³anie danych/plików/strumieni z obs³ug± (wielu) przedzia³ów
50 - negocjacja preferowanego przez u¿ytkownika jêzyka/zestawu znaków
51 - wygodne funkcje do ¿±dañ HEAD/GET/POST je¶li dostêpna jest libcurl
52 - wywo³ania HTTP auth (Basic)
53 - klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool,
54   HttpMessage
55
56 To rozszerzenie ma w PECL status: %{_status}.
57
58 %prep
59 %setup -q -c
60
61 %build
62 cd %{_fmodname}-%{version}
63 phpize
64 %configure
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
70
71 install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
72 cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
73 ; Enable %{_modname} extension module
74 extension=%{_modname}.so
75 EOF
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
82 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
83
84 %postun
85 if [ "$1" = 0 ]; then
86         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
87         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc %{_fmodname}-%{version}/{docs,EXPERIMENTAL}
93 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
94 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.025823 seconds and 3 git commands to generate.