]> git.pld-linux.org Git - packages/php-pecl-http.git/blob - php-pecl-http.spec
- updated to 0.12.0
[packages/php-pecl-http.git] / php-pecl-http.spec
1 %define         _modname        http
2 %define         _fmodname       pecl_http
3 %define         _status         beta
4
5 Summary:        %{_modname} - extended HTTP support
6 Summary(pl):    %{_modname} - rozszerzona obs³uga protoko³u HTTP
7 Name:           php-pecl-%{_modname}
8 Version:        0.12.0
9 Release:        1
10 License:        PHP 3.0
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_fmodname}-%{version}.tgz
13 # Source0-md5:  d180e5b95d22c911e40d8265f7c8fd96
14 URL:            http://pecl.php.net/package/pecl_http/
15 BuildRequires:  libtool
16 BuildRequires:  php-devel >= 3:5.0.0
17 Requires:       %{_sysconfdir}/conf.d
18 %requires_eq_to php-common php-devel
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/php
23 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
24
25 %description
26 Currently implemented features:
27 - Building absolute URIs
28 - RFC compliant HTTP redirects
29 - RFC compliant HTTP date handling
30 - Parsing of HTTP headers and messages
31 - Caching by "Last-Modified" and/or ETag (with 'on the fly' option for
32   ETag generation from buffered output)
33 - Sending data/files/streams with (multiple) ranges support
34 - Negotiating user preferred language/charset
35 - Convenient request functions to HEAD/GET/POST if libcurl is available
36 - HTTP auth hooks (Basic)
37 - PHP5 classes: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool, HttpMessage
38
39 In PECL status of this extension is: %{_status}.
40
41 %description -l pl
42 Aktualnie zaimplementowane mo¿liwo¶ci:
43 - tworzenie bezwzglêdnych URI
44 - zgodne z RFC przekierowania HTTP
45 - zgodna z RFC obs³uga daty HTTP
46 - przetwarzanie nag³ówków i wiadomo¶ci HTTP
47 - buforowanie z u¿yciem "Last-Modified" i/lub ETagów (z opcjê
48   generowania "w locie" ETagów z buforowanego wyj¶cia)
49 - wysy³anie danych/plików/strumieni z obs³ug± (wielu) przedzia³ów
50 - negocjacja preferowanego przez u¿ytkownika jêzyka/zestawu znaków
51 - wygodne funkcje do ¿±dañ HEAD/GET/POST je¶li dostêpna jest libcurl
52 - wywo³ania HTTP auth (Basic)
53 - klasy PHP5: HttpUtil, HttpResponse, HttpRequest, HttpRequestPool, HttpMessage
54
55 To rozszerzenie ma w PECL status: %{_status}.
56
57 %prep
58 %setup -q -c
59
60 %build
61 cd %{_fmodname}-%{version}
62 phpize
63 %configure
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
69
70 install %{_fmodname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}/%{_modname}.so
71 cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
72 ; Enable %{_modname} extension module
73 extension=%{_modname}.so
74 EOF
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
81 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
82
83 %postun
84 if [ "$1" = 0 ]; then
85         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
86         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
87 fi
88
89 %files
90 %defattr(644,root,root,755)
91 %doc %{_fmodname}-%{version}/{docs,EXPERIMENTAL}
92 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/%{_modname}.ini
93 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.095697 seconds and 3 git commands to generate.