]> git.pld-linux.org Git - packages/php-pecl-funcall.git/blob - php-pecl-funcall.spec
support building for multiple php versions
[packages/php-pecl-funcall.git] / php-pecl-funcall.spec
1 %define         php_name        php%{?php_suffix}
2 %define         subver  alpha
3 %define         rel             1
4 %define         modname funcall
5 %define         status  stable
6 Summary:        %{modname} - Add callbacks for any function/method
7 Summary(pl.UTF-8):      %{modname} - odwołania dla dowolnej funkcji / metody
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        0.3.0
10 Release:        0.%{subver}.%{rel}
11 License:        New BSD
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{modname}-%{version}%{subver}.tgz
14 # Source0-md5:  65ddff0346ed4ed4fb0e3734ccf1b7d2
15 URL:            http://pecl.php.net/package/funcall/
16 BuildRequires:  %{php_name}-devel >= 4:5.0.4
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Call callbacks before or after specified functions/methods being
23 called.
24
25 In PECL status of this extension is: %{status}.
26
27 %description -l pl.UTF-8
28 Rozszerzenie to pozwala na wykonywanie odwołań przed lub po wywołaniu
29 określonej funkcji / metody.
30
31 To rozszerzenie ma w PECL status: %{status}.
32
33 %prep
34 %setup -qc
35 mv %{modname}-%{version}%{?subver}/* .
36
37 %build
38 phpize
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
45
46 %{__make} install \
47         EXTENSION_DIR=%{php_extensiondir} \
48         INSTALL_ROOT=$RPM_BUILD_ROOT
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc TODO funcall.php
68 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
69 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.052588 seconds and 4 git commands to generate.