]> git.pld-linux.org Git - packages/php-pecl-ecasound.git/blob - php-pecl-ecasound.spec
3788b0fc0b967e65fc71be2c7e2f163d5870a659
[packages/php-pecl-ecasound.git] / php-pecl-ecasound.spec
1 # TODO
2 # - doesn't build
3 %define         _modname        ecasound
4 %define         _modname_c      Ecasound
5 %define         _status         beta
6 %define         _sysconfdir     /etc/php
7 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
8
9 Summary:        %{_modname} - audio recording and processing functions
10 Summary(pl):    %{_modname} - funkcje do nagrywania i przetwarzania d¼wiêku
11 Name:           php-pecl-%{_modname}
12 Version:        0.2
13 Release:        1
14 License:        PHP
15 Group:          Development/Languages/PHP
16 Source0:        http://pecl.php.net/get/%{_modname_c}-%{version}.tgz
17 # Source0-md5:  002e7bb8c0f018bb41cefc71e5f9f54b
18 Patch0:         %{name}-search_path.patch
19 URL:            http://pecl.php.net/package/ecasound/
20 BuildRequires:  ecasound-devel
21 BuildRequires:  php-devel >= 3:5.0.0
22 BuildRequires:  rpmbuild(macros) >= 1.238
23 %{?requires_php_extension}
24 Requires:       %{_sysconfdir}/conf.d
25 Obsoletes:      php-Ecasound
26 Obsoletes:      php-pear-%{_modname}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This extension wraps the Ecasound libraries to provide advanced audio
31 processing capabilities.
32
33 In PECL status of this package is: %{_status}.
34
35 %description -l pl
36 To rozszerzenie opakowuje biblioteki Ecasound, aby dostarczyæ
37 zaawansowane mo¿liwo¶ci przetwarzania d¼wiêku.
38
39 To rozszerzenie ma w PECL status: %{_status}.
40
41 %prep
42 %setup -q -c
43 %patch0 -p0
44
45 %build
46 cd %{_modname_c}-%{version}
47 phpize
48 %configure
49 %{__make} -j1
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
54
55 install %{_modname_c}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
57 ; Enable %{_modname} extension module
58 extension=%{_modname}.so
59 EOF
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
66 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
67
68 %postun
69 if [ "$1" = 0 ]; then
70         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
71         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
77 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.348716 seconds and 2 git commands to generate.