]> git.pld-linux.org Git - packages/php-pecl-crack.git/blob - php-pecl-crack.spec
- new
[packages/php-pecl-crack.git] / php-pecl-crack.spec
1 %define         _modname        crack
2 %define         _status         stable
3
4 Summary:        %{_modname} - checks if password is vulnerable to dictionary attacks
5 Summary(pl):    %{_modname} - sprawdzanie czy has³o jest podatne na ataki s³ownikowe
6 Name:           php-pecl-%{_modname}
7 Version:        0.1
8 Release:        1
9 License:        Artistic
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  2c0dc4d436904838cc6aba41a3ca7dea
13 URL:            http://pecl.php.net/package/crack/
14 BuildRequires:  libtool
15 BuildRequires:  php-devel >= 3:5.0.0
16 Requires:       php-common >= 3:5.0.0
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sysconfdir     /etc/php
21 %define         extensionsdir   %{_libdir}/php
22
23 %description
24 This package provides an interface to the cracklib (libcrack)
25 libraries that come standard on most unix-like distributions. This
26 allows you to check passwords against dictionaries of words to ensure
27 some minimal level of password security.
28
29 In PECL status of this extension is: %{_status}.
30
31 %description -l pl
32 Ten pakiet dostarcza interfejsu do bibliotek cracklib (libcrack),
33 dostarczanych z wiêkszo¶ci± dystrybucji uniksowo-podobnych. Pozwala to
34 na porównanie hase³ wzglêdem s³owników celem zapewnienia minimalnego
35 poziomu bezpieczeñstwa.
36
37 To rozszerzenie ma w PECL status: %{_status}.
38
39 %prep
40 %setup -q -c
41
42 %build
43 cd %{_modname}-%{version}
44 phpize
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{extensionsdir}
51
52 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
59
60 %preun
61 if [ "$1" = "0" ]; then
62         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
68 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.039911 seconds and 4 git commands to generate.