]> git.pld-linux.org Git - packages/php-pecl-big_int.git/blob - php-pecl-big_int.spec
- release 2
[packages/php-pecl-big_int.git] / php-pecl-big_int.spec
1 %define         _modname        big_int
2 %define         _status         stable
3 Summary:        %{_modname} - set of functions for calculations with arbitrary length integers
4 Summary(pl.UTF-8):      %{_modname} - zestaw funkcji do obliczeń z użyciem liczb o dowolnej wielkości
5 Name:           php-pecl-%{_modname}
6 Version:        1.0.7
7 Release:        2
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  d858d5bcfd3f789cb1ae8cb8ff09d3e9
12 URL:            http://pecl.php.net/package/big_int/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.344
15 %{?requires_php_extension}
16 Requires:       php-common >= 4:5.0.4
17 Obsoletes:      php-pear-%{_modname}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This package is useful for number theory applications. For example, in
22 two-keys cryptography. See tests/RSA.php in the package for example of
23 implementation of RSA-like cryptoalgorithm.
24
25 Also the package has many bitset functions, which allow to work with
26 arbitrary length bitsets.
27
28 This package is much faster than bundled into PHP BCMath. It
29 implements almost all functions as in GMP extension, but it needn't
30 any additional external libraries.
31
32 In PECL status of this extension is: %{_status}.
33
34 %description -l pl.UTF-8
35 Ten pakiet jest przydatny do zastosowań z teorii liczb, na przykład do
36 kryptografii z użyciem dwóch kluczy. Przykładową implementację
37 algorytmu kryptograficznego podobnego do RSA można znaleźć w tym
38 pakiecie w pliku tests/RSA.php.
39
40 Pakiet ma także wiele funkcji operujących na bitach, umożliwiających
41 działanie na zbiorach bitów dowolnej długości.
42
43 Ten pakiet jest dużo szybszy niż wbudowany w PHP BCMath. Implementuje
44 prawie wszystkie funkcje z rozszerzenia GMP, ale nie wymaga żadnych
45 dodatkowych bibliotek zewnętrznych.
46
47 To rozszerzenie ma w PECL status: %{_status}.
48
49 %prep
50 %setup -q -c
51
52 %build
53 cd %{_modname}-%{version}
54 phpize
55 %configure
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
61
62 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
63 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
64 ; Enable %{_modname} extension module
65 extension=%{_modname}.so
66 EOF
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 %php_webserver_restart
73
74 %postun
75 if [ "$1" = 0 ]; then
76         %php_webserver_restart
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc %{_modname}-%{version}/{docs,tests,CREDITS,README}
82 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
83 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.093434 seconds and 3 git commands to generate.