]> git.pld-linux.org Git - packages/php-pecl-bcompiler.git/blob - php-pecl-bcompiler.spec
f0d9271a02329c3afce7981afd7eff0b6e49fb8f
[packages/php-pecl-bcompiler.git] / php-pecl-bcompiler.spec
1 %define         _modname        bcompiler
2 %define         _status         beta
3 %define         _sysconfdir     /etc/php
4 %define         extensionsdir   %(php-config --extension-dir 2>/dev/null)
5 Summary:        %{_modname} - a bytecode compiler for classes
6 Summary(pl):    %{_modname} - kompilator kodu bajtowego dla klas
7 Name:           php-pecl-%{_modname}
8 Version:        0.7
9 Release:        4
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  77163ce732d6cd980de570f021214a17
14 URL:            http://pecl.php.net/package/bcompiler/
15 BuildRequires:  bzip2-devel
16 BuildRequires:  php-devel >= 3:5.0.0
17 BuildRequires:  rpmbuild(macros) >= 1.254
18 %{?requires_php_extension}
19 Requires:       %{_sysconfdir}/conf.d
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 bcompiler enables you to encode your scripts in phpbytecode, enabling
25 you to protect the source. bcompiler could be used in the following
26 situations:
27 - to create a exe file of a PHP-GTK application (in conjunction with
28   other software)
29 - to create closed source libraries
30 - to provide clients with time expired software (prior to payment)
31 - to deliver close source applications
32 - for use on embedded systems, where disk space is a priority.
33
34 In PECL status of this package is: %{_status}.
35
36 %description -l pl
37 bcompiler pozwala na zakodowanie skryptów do kodu bajtowego PHP,
38 pozwalaj±c na chronienie swojego kodu. bcompiler mo¿e byæ u¿ywany w
39 nastêpuj±cych sytuacjach:
40 - tworzenie plików exe dla aplikacji PHP-GTK (w po³±czeniu z innym
41   oprogramowaniem),
42 - tworzenie bibliotek z zamkniêtym kodem,
43 - tworzenie oprogramowania z ograniczonym czasem dzia³ania (zale¿nym
44   od op³at),
45 - dostarczanie aplikacji o zamkniêtym kodzie,
46 - u¿ycie na systemach embedded, gdzie wielko¶æ jest priorytetem.
47
48 To rozszerzenie ma w PECL status: %{_status}.
49
50 %prep
51 %setup -q -c
52
53 %build
54 cd %{_modname}-%{version}
55 cp -f config.m4.old config.m4
56 cp -f Makefile.in.old Makefile.in
57 phpize
58 %configure
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
65
66 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
67 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
68 ; Enable %{_modname} extension module
69 extension=%{_modname}.so
70 EOF
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
77 [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
78
79 %postun
80 if [ "$1" = 0 ]; then
81         [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart
82         [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc %{_modname}-%{version}/examples/*
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
89 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.062829 seconds and 3 git commands to generate.